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Document Generation

The documentation engine allows you to create high quality, professional documentation that can completely replace the
need to create handcrafted documents. Enterprise Architect provides an extensive set of templates that will be useful in
many situations. These templates can be adjusted or new ones created to completely customize the documentation to the
reporting requirements of a particular project or methodology, including cover pages and styles. The standard
documentation facility helps you to report on any Package or element in the repository, and with the Virtual Documents
facility you can selectively pick content from any section of the model and style and order it as you require. There is also
a set of built-in reports with pre-configured content and styles that give you immediate information on specific groups of
elements or properties in the model. You have the options of:

e  Generating one of a set of system-provided reports on specific aspects of your model

e  Generating a report from a system-provided template, with control of the report output through Stylesheets, add-in
cover pages and tables of contents, filters and a wide range of dialog options

e  (Creating your own templates, Stylesheets and add-in pages from which to generate reports, applying an even greater
degree of control over the contents and format of the output

The document formats are common to many word processors, so you can also work on the reports in other
word-processing tools to, for example, integrate the report into a larger, externally-created document.

Documentation Solutions

Feature Detail

Document Generation The Document Generator includes a multi-featured WYSIWYG Document editor
that you can use to:

e Import and export document templates using XML
e Customize copies of the basic, system-provided templates
e  (Create entirely new templates of your own design

e Test templates as you design them, by generating ad-hoc reports within the
designer

e Create and customize independent Stylesheets, Tables of Contents and Cover
Sheets to apply to any of your reports

It also features a documentation generator that:

e  Provides a wide range of simple options for filtering and modifying the report
output

e  Generates detailed and comprehensive documents based on the templates

e Has an embedded viewer for reading the generated documents directly within
Enterprise Architect

A tutorial on using the Document Generator and creating document reports is
available on the Sparx Systems website.

Virtual Documents If you want to create very focused and specific documents, with a greater
complexity and presenting different views of your model data, you can do so using
virtual documents. For these, you set up a Report Package element and/or Model
Document elements, and link Packages or model searches (for elements) into the
document in whatever order or combination is most appropriate to your
requirements.

You can select Packages from different areas of the model, arrange them in any
order, and edit or delete the Packages; the virtual document automatically
incorporates the changes each time you generate it.

(c) Sparx Systems 2025 Page 4 of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

Word Master Documents As an alternative to virtual documents, you can link a number of document reports
into a single MS Word™ master document. This is quite possible with the current
report generator but is of greater use with the original Legacy RTF Report
Generator.

Typically you create a Word master document, then in Enterprise Architect
generate some reports that you link back into sub-sections of the master document
and refresh as required during project development. In this way the project
document becomes an easily-managed and feature-rich work product.

You can also populate a Word document from specific sections of reports, based on
bookmarks - for example, a Word document might have a section for a small part of
your component model; using bookmarks you can generate a full component model,
and then link into just one section of the report.

This way you can maintain a complex Word document from parts of Enterprise
Architect reports; the Document Generator performs one pass for one template, but
using a Word master document and Enterprise Architect bookmarks you can
incorporate material from several documents with different formats based on
different templates.

By adding tables of contents, figure tables, sections, and headers and footers, you
can manage a complex document with relative ease; simply update the Enterprise
Architect reports then refresh the links in Word.

Notes

e In the Corporate, Unified and Ultimate Editions of Enterprise Architect, if security is enabled you must have
'Generate Documents' permission to generate document reports

e  You can have several reports open at the same time, as separate tabs in the central view area of the Enterprise
Architect work area; you can also close the reports individually or all together, leaving views of other types (such as
diagrams or code editors) still open
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How To Generate Documents

When you want to generate a document report on part of your model, you have a number of options for selecting the
object to document, and for defining how your document is to be generated.

A document report describes an element or, more usually, a Package in the model; therefore, your first step is to select
the Package or element to generate the document for, from the:

e Browser window

e Diagram

e Package Browser

e  Specification Manager
e Diagram List or

e Model Search

For a Package, you can also define how the diagrams in the Package are to be set out in the document; you do this in the
diagram 'Properties' dialog for each diagram. When you have prepared and selected your Package, you open the
'Generate Documentation' dialog and configure the parameters for generating the document.

A tutorial for quickly creating a basic document from the Example model is provided in the second of these two tables.
Repeat the tutorial with different selections in the drop-down fields, to see what the system can generate for you
automatically.

Access

Select a Package or element for which to generate documentation, then open the 'Generate Documentation' dialog using
one of these methods.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation

Browser window Toolbar = .
| Documentation | Generate Documentation (RTF/PDF/DOCX)

Keyboard Shortcuts F8

Generating reports

Option Detail

Alternative ways to open Use one of these methods:

the ‘Generate e In the Specification Manager, click on the 'Specification - Specify > Element >

Documentation' dialog Documentation > Generate Documentation (RTF/PDF/DOCX)' ribbon option

e In the Diagram List, Package Browser or Model Search, select one or more
items, right-click and select either 'Documentation | Generate Documentation
for each selected Item' or 'Documentation | Generate Documentation for
selected Items'

Generate report on When you select to create a report from the Diagram List, Package Browser or
elements from Package Model Search tools, you can generate an element-level report rather than a
Browser or Model Search Package-level report, and you have additional flexibility in selecting:
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e The type of element to report on

e The specific elements to report on, together or separately, whether in the same
Package or not

For example, you might want to find all elements with test cases, with the intention
of reporting on some or possibly all such elements; with the Diagram List or
Package Browser, you would identify these elements yourself within the list of all
elements in a selected diagram or Package, but with the Model Search you can
automatically pick out the elements across a section of the model or across the
whole model, as required.

The search filtering could be for specific test cases; however, the results are by
element so if there are test cases outside the range in any element that has a filtered
test, these elements are listed as well.

Having generated the list of elements, you can select individual elements, blocks of
elements, or all elements from it and then use the context menu to generate one
report on all of the selected elements, or a separate report on each element.

Generate and view an example report immediately

Step Action

1 Open the EAExample project.
2 In the Browser window, expand the Testing View and click on the Testing Package.
3 Select the 'Publish > Model Reports > Report Builder > Generate Documentation' ribbon option.

The 'Generate Documentation' dialog displays.

4 In the 'Output to file' field, click on the l:l button and browse for a convenient file location in which to
hold the generated report. Include the appropriate file extension to set the document format (PDF, RTF,
DOCX) of the generated report.

5 In the 'Template' field, click on the drop-down arrow and select 'Basic Report'.

6 In the 'Table of Contents' field, click on the drop-down arrow and select "TOC (portrait)'.

7 In the 'Stylesheet' field, click on the drop-down arrow and select 'Styles - Print Medium'.

8 In the 'Cover Page' field, click on the drop-down arrow and select 'Cover Page (portrait)'.

9 Click on the Generate button.

10 When the report has been generated, click on the View button and examine the report.

Notes

e Reports can be configured to include all Packages within a parent Package, or just the top level
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Basic Document Generation

It is possible to specify a wide range of parameters to control how your document report is generated and output. You
can specify, for example, where the document file is written to and what format it is generated in, what language it is
generated in, and what elements are included in the document. You set these options on the 'Generate Documentation'
dialog, in which the options are provided on a number of tabs.

The first, and default, tab is the 'Generate' tab, on which you define how and where the document is generated. After you
have set options on any or all of the other tabs, you return to the 'Generate' tab and click on the Generate button to
produce your document.

Access

Select a Package or element for which to generate documentation, then open the 'Generate Documentation' dialog using
one of the methods outlined here.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Generate

Keyboard Shortcuts F8 | Generate

Set Report Generation Options

Option Action

Model Document Check the name of the element selected from the Browser window, diagram,

Root Element Diagram List, Specification Manager or Model Search.

If this is the specially-created Model Document element for a virtual document, the
field is 'Model Document'.

Otherwise, this field identifies the selected element of the hierarchy to be reported
on; that is, the Root element or Root Package.

Root Package

Output to File Type or select the location and filename for the generated documentation.

Click on the l_J button to navigate to the location.

Enter the appropriate file extension for the document format in which to generate
the report - PDF, RTF or DOCX.

Template Click on the drop-down arrow and select the name of the template to use for your
document report.

You can select any template from the drop-down list, which is divided into Custom
(or user) templates and System templates. If you have loaded an MDG Technology
containing document templates, those are also listed under the Technology name.

You can also immediately create a new template, by selecting the '<new template>"'
option.

The system checks all template folders for the specified template, in the order
Custom Templates > Technology Templates > System Templates. If there are
different templates available under the same name, the system uses the first found
in this sequence.
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Click on the drop-down arrow and select the name of the cover page definition to
apply to your document report.

You can select any definition from the drop-down list, whether a standard format or
a user-designed page.

Use the default value <none> to not include a cover page, or to use a cover page
built in to the selected user-defined template.

Click on the drop-down arrow and select the name of the Table of Contents
definition to apply to your document report.

You can select any definition from the drop-down list, whether a standard TOC
format or a user-designed format.

Use the default value <none> to not include a Table of Contents, or to use a table of
Contents built in to the selected user-defined template.

Click on the drop-down arrow and select the name of the Stylesheet to apply to
your document report.

You can select any Stylesheet from the drop-down list, whether a standard
definition or a set of user-designed styles.

Use the default value '<none>' to not use a Stylesheet and instead apply the styles
defined in the template you have selected in the 'Template' field.

Click on the drop-down arrow and select a Diagram Theme to apply the color, line
thickness and font style to diagrams of elements in the report, if those elements are
using default values.

If an element has a tailored appearance assigned using, for example, the 'Default
Appearance' dialog, that appearance overrides the Theme settings.

The default option is the Diagram Theme you have currently set in your Local'
options. You can, however, select any other Theme just for this report. The field
setting reverts to your default Theme after the report is generated.

Click on the drop-down arrow and select from a list of Suppress Profiles that you or
other users of the model have created on the 'Suppress Section' tab of the 'Generate
Documentation' dialog.

Each Suppress Profile defines report sections that can be omitted when you
generate the current report. This helps you to tailor the report for a specific
audience on generation.

(You can also omit child Packages from any report generated on the parent
Package; see the Exclude Package from Document and HTML Report Help topic.)

Type in the location of the image to use as a watermark on the document, or click

on the l_l button to browse for the location.

If you have selected a watermark image, select this checkbox to apply a wash to the
image before applying it to the document. This makes the image lighter so that it
does not detract from the report content printed over it.

Click on the drop-down arrow and select the language in which to generate the
document. The list of available languages is defined by the Model Administrator on
the 'Translations' page of the 'Manage Model Options' dialog (‘Settings > Model >
Options').

When the document is generated, the generator includes in the document all Notes,
object names and aliases that have translations into the selected language. If any
fields do not contain a translation for that language, the corresponding document
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field remains blank.

Image Quality Click on the drop-down arrow and select the level of scaling required to reproduce
the diagram images in the report. This determines the visual quality of the image.

e Draft

e Standard (the default)
e High Resolution

e  Very High Resolution

Regardless of the image quality, all images are reproduced at a consistent size.

View Document On Select this checkbox to open the document report as soon as it has been generated.
Completion

Use Language Select this checkbox to switch custom language word substitutions on.
Substitutions

Deselect the checkbox to switch custom language word substitutions off.

Markup Glossary Terms Select this checkbox to apply, throughout the generated RTF report, any styles
applied to any Glossary terms through the Notes text of an element.

A style is applied to a Glossary term according to its Glossary term type.

Use Glossary Substitution (Available if Markup Glossary Terms is selected.)

Click on the drop-down arrow and select a term type. For all glossary terms of that
type, wherever a term occurs in the report it will be replaced by its meaning.

For example, if you select a term type of 'edition', in the report the terms 'Corp',
'Uni' and 'Ult' would be replaced by the meanings 'Corporate’, 'Unified' and
'Ultimate', respectively.

Batch Click on this button to display the 'Batch Document Generation' dialog, to generate
reports in a batch process.

Use Internal Viewer Select this checkbox to enable the View button to launch the generated document in
the Enterprise Architect internal viewer.

Deselect this checkbox to enable the View button to launch the generated document
in the MS Windows default file viewer.

Include all Diagram Select this checkbox to include elements in the report from external Packages that
Elements in Report are referenced from a diagram, for every diagram searched by the report; the
checkbox defaults to selected.

To include the external elements in the document, also select the
'Package.Diagram.Element' and 'Package.Element' checkboxes in the current
template.

If external elements are to be included only for specific diagrams, deselect this
checkbox and - only for the diagrams for which you want to include external
elements in the report - for each diagram select the 'Add each contained element in
Documentation' checkbox in the diagram properties.

When both options are deselected, or when neither of the
'Package.Diagram.Element' or 'Package.Element' checkboxes are selected in the
template, only elements in the current Package are documented.

Progress Indicate the progress of document generation with status messages and an
increasingly filled status bar.
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Resource Document Click on this button to save the currently-set options as a document definition.

Open Template Click on this button to edit the currently-selected template using the Document
Template Editor.

You can only edit user-defined templates, not the standard templates provided with
the system. If you have selected a system template, this button is grayed out.

Generate Click on this button to generate the document (after you have set all the options you
require, on all tabs of the dialog).

View Click on this button to launch the generated document in:
e The MS Windows default file viewer, or

e The Enterprise Architect internal viewer, if you have selected the 'Use Internal
Viewer' checkbox

Abort Click on this button to cancel report generation; a prompt displays to confirm
cancellation of the report.

Notes

e For an introduction to generating document reports, see the Document Reports Help topic

e The second tab on the 'Generate Documentation' dialog, "Templates', is used to develop and maintain custom:
- Templates
- Stylesheets
- Tables of Contents and
- Cover Pages
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Selecting a Template

You use report templates to generate reports on your model that present specific information in a particular format, and
to help you generate those reports repeatedly and consistently. You can select from a range of system templates on the
Document Generator, to immediately generate reports from your model, or you can select custom templates designed by
your project team members specifically for the purposes of your project.

A template principally defines the type of content of the report, so that if you generate a report, say, on a Package you
will extract and present information on a specific set of structures such as:

o the elements and their features and connectors, or

e the elements at the top of the Package hierarchy, or

e all elements in the Package, or

e all elements in the diagrams whether they are in that Package or from other Packages

A template also presents the report information in a specific format and style, initially based on a set of standard styles.
Your report designers can redefine the styles in a custom template to whatever extent they need, but it is better to select
the alternative styles from a Stylesheet so that you can choose to apply that set of styles to a report or not, independent of
which template you are using, as you need.

The initial range of system templates and Stylesheets give you a great deal of flexibility in quickly and easily
determining the content and presentation of the reports you want to generate, and you can further increase this flexibility
with additional templates and Stylesheets developed in-house, customized to the requirements of your organization.
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System Document Templates

When you generate reports on your model, you select one of the report templates to extract information on specific key
aspects of your model. There are several system templates available to use, either to generate a report straight away or to
copy and customize to suit your own requirements. Each of the system templates supports a specific aspect of modeling
or model management.

You usually generate reports on Packages selected from the Browser window; these can be used to produce great
hierarchical reports on parts of your model, or the whole model if you prefer. There are also system templates for
reporting the diagrams in a Package, which you can use to report on elements returned in search results - such reports are
non-hierarchical, as they extract specific information from different areas of the model.

Access - copy existing templates for editing
Display the Document Template editor window, select a template, then click on the 'Save As New' toolbar icon.

Ribbon (B
Publish > Model Reports > Templates : select a particular template >

icon)

(toolbar

Access - select a template for report generation

Use one of the methods outlined here to display the 'Generate Documentation' dialog at the 'Generate' tab, then use the
'"Template' field drop-down list to select which template to use for generating the report.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > select
from the 'Template' drop-down list.

Keyboard Shortcuts F8 | select from the 'Template' drop-down list.

Available Predefined Templates

Template Description
Audit Report - Detailed Incorporates information from the latest Audit runs.
Data Modeling Report Used for reporting on Physical database models of any of the three types - UML

DDL, Information Engineering and IDEF1X.

With data modeling, a Class represents a Table and its attributes represent Table
fields. In the Data Modeling template, the section and field names are selected to
represent the Tables, Columns (fields) and specific Column attributes.

Diagram Report Extracts information on the diagrams for a Package. It is primarily used for
outputting diagram graphics and titles.

A common use of this template is where diagrams linked into an external Word
master document (where Virtual Documents are not being used) are to be refreshed.
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Using the bookmarks generated with the documents, you can refresh the master
document diagrams.

Glossary Extracts the Glossary terms and their types, defined in the Project Glossary.
This is commonly used in Virtual documents for appending the Glossary to a larger
document.

Maintenance Report Extracts the Change, Defect, Document and Issue details for all elements in a

selected Package. This is the information defined on the Maintenance window.

Model Report The most generalized template, which includes all of the commonly used Sections
and fields. It is more appropriate in its use of field names to UML Classes.

This template provides table formatting for most of the element's sub-groups, such
as Scenarios, Constraints, Attributes and Operations.

Project Issues Extracts information on the set of issues that are logged globally in the repository.

To report on the non-global, element-specific issues, see the Element > Issue
section in the Model Report template.

Project Management Shows the Resource allocation, Effort, Metric and Risk details for each element in
Report the selected Package.

Requirements Report - Extracts full information on the external Requirements of the selected Package,
Details including the model structure each forms a part of, and the internal responsibilities,

scenarios and project management and resource records that might exist to support
requirements management.

Requirements Report - Provides a brief description of each Requirement element in the selected Package.
Summary
Specification Manager List Lists the elements and sub-Packages, and their subordinate elements, under the

current Specification Package in the Specification Manager. Items within a level are
listed in alphabetical order.

Test Report Extracts the Test details for all elements in a selected Package, as defined on the
Test Cases window, and the test data generated by xUnit testing and Testpoint code
testing.

Use Case Details Extracts information on the Use Cases in a selected Package, including the details

of any scenarios. This template also excludes child structures.

If you want to include sub-element Use Cases, select the Element > Child Elements
section.

Use Case Summary Extracts basic element description information on the Use Cases in a selected
Package. This excludes scenario details and child structures (to filter out the
information on any Sequence diagrams set as child diagrams of the Use Case
elements).

Notes

e The facility to use the 'Diagram > Element' section to report elements contained in a diagram but defined in another
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Package, is inactive in system templates
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Selecting a Cover Page

A cover page defines the text, styles, graphics and layout of the front page of a document. Enterprise Architect provides
two standard cover pages, one for portrait documents and one for landscape documents, which you can apply to your
document reports independent of the report template and Stylesheet you are using. Your report designers can copy these
standard cover pages as the bases for custom cover pages that reflect your corporate styles, logos and document naming
conventions.

The cover page templates can contain fields that automatically extract and display data such as:
e  The report type

e The Package or element being reported on

e  The version of the report

e  The status of the report

e  The date on which the report was generated

e  The name of the person who generated the report

e  The location of the report file

e Any logos or graphics to be displayed on the front page

In using a cover page, you do not need to spend time defining the inclusion and display of the report title and provenance
- it is already prepared for you. You can access the cover page templates from the 'Cover Page' drop-down list on the
'Generate' tab of the 'Generate Documentation' dialog.

Notes

e Ifyou have custom report templates that already contain the cover page definitions you want, you can still apply
them by just setting the 'Cover Page' field on the 'Generate' tab to '<none>"'
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Selecting a Table of Contents

A very useful feature of any documentation is the inclusion of a Table of Contents. This can, however, be quite
demanding to create, especially when you have to set up a Table of Contents for individual documents. Even setting up
Contents Lists within templates can still be very time consuming, when you have a number of templates to maintain. It is
far quicker and easier to apply a specific Table of Contents template to your document reports independent of which
report you are generating and which content template you are basing the report on.

Enterprise Architect provides two TOC templates - one for landscape documents and one for portrait documents - that
have the appropriate styles, formatting and numbering system already defined. You can access these templates through
the 'Table of Contents' field on the 'General' tab of the 'Generate Documentation' dialog.

Your report developers can copy the two system-provided templates as the bases for custom Tables of Contents, tailored
to the requirements of your organization. These customized templates are also directly available to you through the
drop-down list for the 'Table of Contents' field.

Notes

e Ifyou have a Table of Contents defined in any of your custom report templates, and you want to use it, just set the
'Table of Contents' field on the 'General' tab to '<none>"'
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Selecting a Stylesheet

Using Stylesheets is an effective method of applying consistent format and appearance standards to categories of
documentation, independent of the templates or other methods of defining document content you use. Stylesheets
increase the flexibility of your documentation generation, in that you can:

e  Provide a suite of documents generated from different templates with the same style standards, using one Stylesheet,
and

e Deliver the same document content in different styles for different customer audiences by applying different
Stylesheets to documents generated from one template

Enterprise Architect provides six standard Stylesheets - three for printed documentation and three for online
documentation. Your report designers can copy these as the bases for custom Stylesheets, reflecting the corporate
standards of your organization. Each custom Stylesheet can define a totally different page layout and document styles to
other Stylesheets and to the Normal.rtf Stylesheet. You can access both system and custom Stylesheets from the
'Stylesheet' drop-down list on the 'General' tab of the 'Generate Documentation' dialog.

Style Hierarchy

Stylesheets are the top level of a hierarchy of styles across the system.

e Initially, all documents and templates, whether for Linked Documents or report documents, reflect the global styles
defined in the Normal.rtf file; you can edit this file to provide new global styles for all documents and templates
created after the update

e In a specific document or template, you can edit the styles for that document or for all documents generated from
that template; these edited styles override those of the same name in the Normal.rtf file, but any styles that have not
been changed still reflect the definitions in the Normal.rtf file

e You can use a Stylesheet to apply a set of style definitions to a generated document, independent of the template you
use; these styles override any styles of the same name defined in the document templates and/or the Normal.rtf file

Notes

e Ifyou have custom templates that contain all the style definitions you need, or if you want to just use the Normal.rtf
styles, you can continue to apply those simply by setting the 'Stylesheet' field on the 'General' tab to '<none>'
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Document Options

When defining the contents of your document, you can set a wide range of options for selecting the reported items by
type and property, and you can organize the information within each type in order of position in the Browser window or
by created or modified date. These document options are provided in two different ways:

e On the 'Options' page on the 'Generate Documentation' dialog, to be set for a specific instance of a report; the
options are reset when you exit the dialog or select a different template

e On panels on the 'Document Options' dialog, to be configured in a template as the default settings to be applied to
every report generated using that template; these settings can be overridden by the 'specific instance' settings on the
'Generate Documentation' dialog

The listed options are the same for both dialogs, except that the 'Document Options' dialog:
e Includes the 'Exclude Filters', 'Element Filters' and 'Other Filters' pages from the 'Generate Documentation' dialog
e Includes the 'Custom Query' page (for 'Template Fragments')

e Does not provide these options (as found on the 'Options' page of the 'Generate Documentation' dialog):
- The Switch generator button
- The 'Disable large OLE file support' option
- The 'Insert page breaks when generating a Master Document' option
- The 'Indent Linked Document Headings' option
- The 'Hide diagram borders' option
- The 'Hide non-printable objects' option

Access - 'Generate Documentation’ dialog

Display the 'Generate Documentation' dialog, then select the 'Options' page
Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Options

Keyboard Shortcuts F8 | Options

Access - Template Editor 'Document Options' dialog

Display the Document Template editor window, select a template, then display the 'Document Options' dialog.

Ribbon Publish > Model Reports > Templates : select a particular template > & (toolbar
icon)
Options
Field Action
Packages by Click on the drop down arrow in the first field and select to organize Packages in

the generated documentation by Name, Tree Order, Modified Date or Created Date.

Click on the drop down arrow in the second field and select to list the Packages in
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Elements by

Diagrams by

Hide 'note-less' elements

Propagate Package Filters

Hide 'note-less' connectors

Hide <Anonymous>
elements

Disable large OLE file
support

Use style defined in
template for notes

Insert page breaks when
generating a Master
Document

Include child elements
even if the parent element
is filtered out

Indent Linked Document
Headings

Hide Diagram Borders

Hide non-printable objects

Show status colors
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either Ascending or Descending order.

Click on the drop down arrow in the first field and select to organize elements in
the generated documentation by Name, Tree Order, Modified Date, Created Date or
None.

Click on the drop down arrow in the second field and select to list the elements in
either Ascending or Descending order.

Click on the drop down arrow in the first field and select to organize diagrams in
the generated documentation by Name, Tree Order, Modified Date or Created Date.

Click on the drop down arrow in the second field and select to list the diagrams in
either Ascending or Descending order.

Select this checkbox to exclude all elements without notes from the documentation.

Select this option to apply a top-level Package filter to all child templates and
fragments, overriding any filters set on those child templates.

Select this checkbox to exclude all connectors without notes from the
documentation.

Select this checkbox to hide anonymous elements in the documentation.

Select this checkbox to disable support for large Object Linking and Embedding
(OLE) files.

Select this checkbox to override the character formatting specified in your 'Notes'
fields with the formatting set for the field in the template.

Select this checkbox to insert a page break after each Model Document in a Report
Package.

Select this checkbox to document all child elements that are not otherwise filtered
out by the restrictions, even if the parent elements are filtered out.

Select this checkbox to adjust the heading levels of any Linked Document included
in the report so that they match the heading levels of the report. The adjustment is
made on the assumption that the first heading level in the Linked Document starts
at 1.

Select this checkbox to hide the diagram frame on all diagrams included in the
generated document.

When selected, this option overrides the 'On Saved Images' checkbox on the 'Start >
Application > Preferences > Diagrams' page.

Defaults to selected to hide all objects that have been flagged as non-printable, in
any diagrams in the report. Objects are flagged as non-printable through the
element context menu on a diagram.

To show the non-printable objects in this report, deselect the checkbox.

Select this checkbox to display the status colors of each object in any diagrams in
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the report, regardless of the settings of the 'Show status colors on diagrams' option
on the 'Objects' page of the 'Preferences' dialog.

Convert Element Select this checkbox to covert hyperlinks in the element Notes to hyperlinks
hyperlinks to Help between document sections, when the document is generated using the template.
hyperlinks

No bookmarks Select this checkbox to prevent document bookmarks from being inserted into the

generated document.

Skip root package Select this checkbox to exclude the parent Package from the documentation and
include only the child Packages.

Diagram Format Click on the drop-down arrow and select the diagram format for the images
included within the documentation; either Metafile or Bitmap.

Adjust Heading Levels Click on the drop-down arrow and select the lowest heading level that can be
generated for nested sub-Packages in the document

The Document Generator reproduces heading levels down to the value you set; for
example, if you have four nested levels of sub-Packages and you set this field to:

e Heading 2, all sub-Packages in the report are documented under level 2
headings

e Heading 4, the first level of sub-Packages are documented under level 2
headings, the next level under level 3 headings, and the remainder all under
level 4 headings

e Heading 6, the first level of sub-Packages are documented under level 2
headings, the next level under level 3 headings, the next under level 4
headings, and the next under level 5 headings; if you added further levels of
sub-Package they would all be documented under level 6 headings

The field defaults to Heading 9 to accommodate the maximum number of levels of
nested sub-Packages.

Switch generator Click on this button to switch from this 'Generate Documentation' dialog (the
Enhanced Template Driven Generator) to the 'Rich Text Format Report' dialog
(Legacy Generator).

This button is not available if you displayed the dialog from the Diagram List,
Package Browser or Model Search.

Only include objects Filter elements according to the date they were created or last modified. In the:

e  First field, click on the drop-down arrow and select the value "Modified' or
'Created'

e Second field, click on the drop-down arrow and select the value 'After' or
'Before'

e Third field, select the checkbox, click on the drop-down arrow and select the
appropriate date

Where Package Phase Filter elements according to the value of the Package Phase' field.

In the first field click on the drop-down arrow and select the qualifier, and in the
second field type the required phase (or leave the default value 'All").

With element status Filter elements according to status.

In the first field, click on the drop-down arrow and select the qualifier ('like', 'not
like', 'in', 'not in') and in the second field type the value to be used.
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Values should be enclosed in quotes; for example:
"Proposed".
If you type more than one value, separate them with a comma; for example:

"Proposed", "Implemented"

Connector Direction Click on the drop-down arrow and select the connector direction to include only
connectors having that direction.

If you select 'Both', the connector is documented twice; once for the source element
and once for the target.

For the remaining two values, the connector is documented only for the source or
target element, as appropriate.

Except where Query This option excludes the selected Package or a child Package from the report,
excludes Package where that Package is specifically identified by a Custom SQL Query or a Custom
Script.

Click on the appropriate radio button for the type of query and:

e [fyou have selected 'Custom SQL', type the query into the window beneath the
radio buttons

e Ifyou have selected 'Custom Script', a new field displays; click on the
drop-down arrow and select the script, then type the entry point of the Script
into the window beneath the radio buttons
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Exclude Package Query and Script

On the 'Document Options' dialog (Template Editor) or 'Options' tab (Document Generator) you can enter a custom SQL
Query or select a custom Script to tailor the report in a specific way. One possibility is to exclude the selected Package or
a child Package from the report. You can base your Query or script on the examples provided here.

The two parameters you use in excluding a Package are:
o  #PACKAGEID# - the Package ID of the current record in t package being processed on the exclusion condition

e #OBJECTID# - the Object_ID of the current Package element record in t_object being processed on the exclusion
condition

Custom SQL Query

To exclude the Package from the report using a Custom SQL Query, you can create the Query based on the t package
columns. For example:

SELECT Package ID AS ExcludePackage
FROM t package
WHERE Package ID =#PACKAGEID#
AND  Name = 'Test'
Alternatively, you can create the Query based on the Package object columns in the t object table:
SELECT t package.Package ID AS ExcludePackage
FROM t package,t object
WHERE t_package.Package ID =#PACKAGEID#
AND t object.Object ID =#OBJECTID#
AND t object.Stereotype = NoDoc'

Custom Script

If you have selected the 'Custom Script' option and want to exclude the Package from the report, you can create a script
and enter a call to it, such as:

ExcludePackage(#P ACKAGEID#)

This is a sample of the XML returned by the script:
<?xml version="1.0"?>
<EADATA version="1.0" exporter="Enterprise Architect">
<Dataset 0>
<Data>
<Row>
<ExcludePackage>
89
</ExcludePackage>
</Row>

</Data>
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</Dataset_0>
</EADATA>

This is an example of JScript for excluding the Package:

!'INC Local Scripts.EAConstants-JScript

/*

* Script Name: RTF Exclude Packages Script Sample

*/

function ExcludePackage(packagelD)

{
var xmIDOM = new ActiveXObject("MSXML2.DOMDocument.4.0");
xmIDOM.validateOnParse = false;
xmlIDOM.async = false;

2 September, 2025

var node = xmIDOM.createProcessinglnstruction("xml", "version='1.0"' encoding="TSO-8859-1"");

xmlDOM.appendChild(node);

var xmlIRoot = xmIDOM.createElement("EADATA");

xmIDOM.appendChild(xmIRoot);

var xmlDataSet = xmIDOM.createElement("Dataset _0");

xmlRoot.appendChild(xmlDataSet);

var xmlData = xmIDOM.createElement("Data");

xmlDataSet.appendChild(xmlData);

var xmlRow = xmIDOM .createElement("Row");

xmlData.appendChild(xmlRow);

var package as EA.Package;

package = Repository.GetPackageByID(packagelD)

if(package.StereotypeEx == "NoDoc")

{
var xmlName = xmlDOM.createElement("ExcludePackage");
xmlName.text ="" + package.PackagelD;
xmlRow.appendChild(xmIName);

H

return xmIDOM.xml;
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Suppress Sections

A Suppress Profile defines report sections that can be omitted when you generate the current report. This helps you to
tailor the report for a specific audience on generation. You can define Suppress Profiles on the 'Suppress sections' tab of
the 'Generate Documentation' dialog; you can also use the tab to delete profiles that you or other users have created in the
model.

Access
Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Suppress
sections
Keyboard Shortcuts F8 > Suppress sections

Create a Suppress Profile

To create a Suppress Profile, select the checkbox against each section to exclude from the report.

When you select a section, all its child sections will also be excluded by default. For example, selecting the Diagram
section will exclude the child 'Element', 'Connector', 'Messages' and 'Audit History' sections. If you want to exclude only
some of these, you select the appropriate checkboxes directly.

Having selected the sections to exclude, type a profile name in the drop-down field to the right of the Save button, and
click on that button.

To clear the selected checkboxes, click on the Clear button. To clear the profile name, click on the drop-down arrow at
the end of the name field and select the blank entry.

Delete a Suppress Profile

To delete a Suppress Profile, click on the drop-down arrow at the end of the profile name field, click on the name of the
profile and then on the Delete key.

A prompt displays to confirm the deletion. Click on the Yes button.

Clear the name field, by clicking on the drop-down arrow and selecting the blank entry.
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Exclude Filters

As you specify the output of your report, you might want to exclude objects of a specific type. You can do this using the
'Exclude Filters' tab, through which you can select to exclude from your report one or more:

e Types of element

e  Types of connector, and/or

e Types of diagram

You can select the objects in one of two ways:

e  Click on the All button underneath the appropriate panel, to exclude every type of element, connector or diagram,
and then Ctrl+click on the individual types that you DO want to include in the report, or

e  Click on the None button underneath the appropriate panel to clear all selections (which includes the objects of
every type in the report) and then Ctrl+click on each type of object that you do NOT want to show in the report

Notes

e Ifyou want to specifically include or exclude elements on the basis of their specific properties or features, rather
than their type, use the 'Element Filters' and 'Other Filters' tabs

e Filters set in a template operate only on that template, and do not operate on subtemplates and template fragments
inserted into the template; to filter the subtemplates, set the filter within each one
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Element Filters

As you specify the output of your report, you might want to include only elements that have specific properties, rather
than every element encountered. Using the 'Element Filters' tab, you can define which element properties to report on,
and which fields and field values. You can also delete the element filters if you no longer want to apply them.

The 'Element Filters' tab is provided in two different ways, as a tab of:

e The 'Generate Documentation' dialog, to set filters for a specific instance of a report; the filters are reset when you
exit the dialog or select a different template, or

e  The 'Document Options' dialog, to set filters in a template as the default settings to be applied to every report
generated using that template; these settings can be overridden by the 'specific instance' settings on the 'Generate
Documentation' dialog

The options and behavior are the same for both dialogs, except that the 'Document Options' dialog provides a facility for
importing a previously-defined set of Model Search filters from within your model or from an external file (created by
exporting a Model Search from another model).

The facilities are also provided through the 'Element Filters' page of the Properties' dialog for a Standard Chart element.
This page most closely resembles the tab of the 'Document Options' dialog in the Document Template editor.

Access - 'Generate Documentation’ dialog

Display the 'Generate Documentation' dialog, then select the 'Element Filters' page.

To open the 'Generate Documentation' dialog, use one of the methods outlined here.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Element
Filters
Keyboard Shortcuts F8 | Element Filters

Access - Template Editor 'Document Options' dialog

Display the Document Template editor window, select a template, then display the 'Document Options' dialog and finally
select the 'Element Filters' page of that dialog.

To open the 'Document Options' dialog, use one of the methods outlined here.

Ribbon Publish > Model Reports > Templates : select a particular template > & (toolbar

icon) > Element Filters

Review Element Filters
Column/Button Action

Search In Shows the type and name of each element property field to search on.

Select the checkbox against a property field to include it in the current search.
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Condition

Look For

Required

Element Features
- Optional
- Required

Import Search

Add Filter

Edit Filter

Remove Filter

Notes
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Displays the condition of the search parameter.

The possible values are Contains, Equal To, Not Equals and One Of.

Displays the search term to perform the conditional search on.

This value is specific to the selected field; for example, the value could be a date
for 'DateCreated’ or a text or numerical value for other fields.

The search term can contain multiple values, separated by commas.

Indicates that the search results must include elements with the search term in that
field; these checkboxes are set on the 'Add Filters' dialog.

When no 'Required' checkboxes are selected, the fields listed as filters have an OR
relationship; that is, if the search term is found in any one of those fields, then the
element is displayed.

Any field having the Required' checkbox ticked overrides fields where the
'Required' checkbox is not ticked.

Specify whether element features are optional or required; these appear as a new
branch underneath the root element term in the 'Search In' column.

If you scroll down the 'Search In' column, you might see sub-branches such as
Attribute, Change and Custom Property; these are the element features. You can
add these features using the 'Add Filters' dialog.

Select the:

e 'Optional' radio button to generate a list of elements that have one of the
element features (Element Type = Object), or one of the feature filters
(Attribute Name = Attl); for example, if your search is:

Element Name = Class11, Attribute Name = m_Attl or Scope = Public
the search results list all the elements that have the name of Class11 and all the
elements that have an Attribute Name of m_Att1 or a Scope of Public

e Required radio button to generate a list of elements that must have the element
features; for example, if your search is:
Element Name = Class, Attribute Name = m_Attl or Scope = Public
you would get elements that must have the name of Class AND have an
attribute with a name of m_attl OR a Scope of Public

Click on this button and select to import the filters defined within a search, from
either:

e An external XML file exported from another project, located on a browser
dialog, or

e A list of the standard and custom Model Searches within your installation of
Enterprise Architect

Click on this button to display the 'Add Filters' dialog, to add a new set of
parameters to filter the search on.

Click on this button to display the 'Edit Filters' dialog, to change the search
parameters.

Click on this button to immediately remove the selected filter from the search.
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e  Check that the values you provide for the 'Look for' fields are exactly what is contained in the element data fields to
be searched; for example, the Unit, Integration, System, Acceptance, Scenario and Inspection TestClasses are
represented by attribute values 1 - 6, not by their respective tab names

e Filters set in a template operate only on that template, and do not operate on subtemplates and template fragments
inserted into the template; to filter the subtemplates, set the filter within each one
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Other Filters

As you specify the output of your report, you might want to include only specific features of elements (sub-element
components such as attributes, responsibilities or constraints). If the feature does not have the defined characteristics, it is
not reported for the element. Using the 'Other Filters' tab, you can define which features to report on, and which fields
and field values. You can also delete the filters if you no longer want to apply them.

The 'Other Filters' tab is provided in two different ways, as a tab of:

e The 'Generate Documentation' dialog, to set filters for a specific instance of a report; the filters are reset when you
exit the dialog or select a different template

e  The 'Document Options' dialog, to set filters in a template as the default settings to be applied to every report
generated using that template; these settings can be overridden by the 'specific instance' settings on the 'Generate
Documentation' dialog

The options and behavior are the same for both dialogs.

Access - 'Generate Documentation' dialog

Display the 'Generate Documentation' dialog, then select the 'Other Filters' page.

To open the 'Generate Documentation' dialog, use one of the methods outlined here.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Other
Filters
Keyboard Shortcuts F8 | Other Filters

Access - Template Editor 'Document Options' dialog

Display the Document Template editor window, select a template, then display the 'Document Options' dialog and finally
select the 'Other Filters' tab of that dialog.

To open the 'Document Options' dialog, use one of the methods outlined here.

Ribbon Publish > Model Reports > Templates : select a particular template > = (toolbar

icon) > Other Filters

Manage Other Filters

Column/Button Action

Search In Shows the type and name of each element feature field to search on.

Select the checkbox against a field to include it in the current search.

Condition Displays the condition of the search parameter.

The possible values are Contains, Equal To, Not Equals and One Of.
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Look For Displays the search term to perform the conditional search on.

This value is specific to the selected field; for example, the value could be a date
for 'DateCreated’ or a text value for other fields.

The search term can contain multiple values, separated by commas.

Required Indicates that the search results must include element features with the search term
in that field; these checkboxes are set on the 'Add Filters' dialog.

When no 'Required' checkboxes are selected, the fields listed as filters have an OR
relationship; that is, if the search term is found in any one of those fields, then the
element is displayed.

Any field having the 'Required’ checkbox ticked overrides fields where the
'Required' checkbox is not ticked.

Add Filter Click on this button to display the 'Add Filters' dialog, to add a new set of
parameters to filter the search on.

Edit Filter Click on this button to display the 'Edit Filters' dialog, to change the search
parameters.
Remove Filter Click on this button to remove the selected filter from the search.
Notes

e  Filters set in a template operate only on that template, and do not operate on subtemplates and template fragments
inserted into the template; to filter the subtemplates, set the filter within each one
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Project Constants

As you develop your report, you can incorporate flags that represent project-wide terms and values. The flags - or Project
Constants - are replaced with the actual text during document compilation. Using this facility, you can use a particular
text string or number extensively throughout your project documentation, whilst maintaining the value in a single
location. You define Project Constants on the 'Generate Documentation' dialog; they are then available to be inserted into
all custom document report templates in the text, section headers, end-notes, page headers or page footers, using the
'Document Template Designer' context menu.

Access
Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Project
Constants
Keyboard Shortcuts F8 | Project Constants

Manage Project Constants

Field/Button Action

Add Click on this button to add a new Project Constant to the list.
A prompt displays for the name and value; type these in and click on the OK
button.

Delete Click on this button to remove the selected Project Constant from the list.
A prompt displays to confirm the deletion; click on the OK button to complete the
task..

Import Click on this button to import a set of fields from an external XML file.

A browser displays to select the source file and location.

Export Click on this button to export all fields to an external XML file.
A browser displays to specify the target file and location.
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Word Substitution

In generating document reports, you will call in many English technical terms that are used across the system, in
particular field names. It is possible to replace these field names in your generated documents with other terms that might
be more meaningful to the readers, such as a translation of each term into your own language.

Access
Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Word
Substitution
Keyboard Shortcuts F8 | Word Substitution

Add a translation for a term

Step Action

1 Double-click on the term in the 'English' column; the 'Enter Value' field displays.
2 Type the substitute text in the 'Enter Value' field, and click on the OK button.

The text displays in the 'Substitute' column, against the English term. This substitute will display in your
generated reports in place of the English term.

Notes

e To put the word substitutions into effect in a generated report, select the 'Language Substitution' checkbox on the
'Generate' tab
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Language Substitution

If you want to generate and export document reports from Enterprise Architect in languages or dialects other than US
English, you can customize the codepage, default language ID and character set that the system uses when generating the
documentation. This makes it much easier to generate documentation appropriate to your country or location.

Access
Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Codepage
Keyboard Shortcuts F8 | Codepage

Notes

e Ifyou want to generate reports in a language that requires Unicode support, please note that Enterprise Architect
.eap files default to using JET 3.5 as the database engine, which does not support Unicode character sets (see the
Startup topic); to provide Unicode support in your project, either upsize to a DBMS repository or set JET 4.0 as the
database engine, and download a copy of the Jet 4.0 EABase model from the Sparx Systems website and do an EAP
to EAP transfer of your model into the Jet 4.0 file

e The codes that you select remain set for all reports you generate, until such time as you specifically change them
again

e  You can transport these language tag definitions between models, using the 'Settings > Model > Transfer > Export
Reference Data' and 'Tmport Reference Data' ribbon options

Set Reporting Language

Field/Button Action

Language Click on the drop-down arrow and select the language code appropriate to the
language you want to generate reports in.

Codepage Click on the drop-down arrow and select the codepage appropriate to the language
you want to generate reports in.

Charset Click on the drop-down arrow and select the character set appropriate to the
language you want to generate reports in.

English Tag Lists the default US English language code tags within Enterprise Architect.

Substitute Tag (For advanced use only.) If you want to apply a different language code tag in place
of a US English tag, double-click on the item line. A prompt displays for the
substitute tag code; type in the code and click on the OK button.

To clear a substitute tag, double-click on the item and delete the code value.

When you generate your document reports, the substitute tags are used in the
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output.
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Diagram Options

When generating reports on a Package that includes diagrams, you can set options in each diagram's "Properties' dialog to
define whether that diagram is to be included in the report and, if so, how it is to be represented.

Access
Ribbon Design > Diagram > Manage > Properties > Diagram
Context Menu Right-click on diagram background | Properties > Diagram

Document Options

Option Action
Exclude Image from RTF Select this checkbox to exclude the image of this diagram from any document
Documents reports.
Document Each Contained Select this checkbox to include, in the report, details of any elements that belong in
Element in RTF other (external) Packages but that form part of this diagram within the Package

being reported on; the report includes external elements in each diagram on which
you have selected the checkbox.

On the 'Generate Documentation' dialog, the 'Include all Diagram Elements in
Report' checkbox defaults to selected to include external elements for every
diagram checked by the report; therefore, to include external elements only for
specific diagrams, deselect that checkbox.

In either case, you must enable the Package.Diagram.Element and Package.Element
sections in your (customized) document generation templates in order to include
this external element information in the report.

Divide Diagram Into If the diagram is large, select this checkbox to divide the diagram into separate
Multiple Pages pages in the document report.

This option is only effective when the 'Scaled Printing' option on the 'Print
Advanced' dialog is set to None'.

Rotate Images Select this checkbox to rotate each diagram image by 90 degrees in the document
report; this is only valid for bitmap (.bmp) images.
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Save As Document recipe

When you set the parameters on the 'Generate Documentation' dialog to define an output document as you need it, you
might want to re-use that configuration to obtain a consistent view of changes to your model over time. You can capture
the configuration as a Resource Document, which saves the:

e Package name

e Output file destination and extension (which determines the output format)
e Template

e  Options page settings

e Exclude Filters

e  FElement Filters and

e  Other Filters

The document is saved into the Document Publishing > Report Library folder of the 'Resources' tab of the Browser
window. Saving your often-used report configurations as Resource Documents can simplify future document generation,
both in producing specific documents and in batch-generating all documents or a selection of documents.

Access

To save the current settings as a Resource Document:

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Generate :
Resource Document

Keyboard Shortcuts F8 > Generate : Resource Document

Access

To load a Resource Document and use the settings it has saved;

Ribbon Start > All Windows > Design > General > Browse > Resources > Document
Publishing > Report Library > Right-click on a document > Generate Document

Keyboard Shortcuts Alt+6 | Document Publishing | Report Library | Right-click on a document |
Generate Document

Manage Resource Documents

Task Action
Create a Resource On the 'Generate Documentation' dialog, click on the Resource Document button
Document and, in the 'Enter Value' field, type a name for the document.

Click on the OK button. The document is added to the Document Publishing >
Report Library folder in the 'Resources' tab of the Browser window for easy future
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Open, Generate or Delete
Documents

Batch-generate a number of
documents
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accCess.

In the 'Resources' tab of the Browser window, expand the Document Publishing >
Report Library folder (and, if necessary, the appropriate Document Group
subfolder) and right-click on the required document.

Select the appropriate context menu option:

e 'Edit Name' - Open the 'Edit Item' dialog and type over the current name to
correct or change it; click on the OK button to save the change

e 'Open Document' - Open the corresponding .document file, as specified by the
document template 'Filename' property

e 'Generate Document' - Open the 'Generate Documentation' dialog, loaded with
the specified template

e 'Auto Generate Document' - Generate documentation, with the document
located at the path specified by the template's 'Filename' property

e 'Delete Document' - Remove the specified document

Right-click on the Report Library folder name and select the 'Generate Documents'
option; the 'Batch Document Generation' dialog displays.

The dialog lists all resource documents in the Report Library folder, whether or not
they are contained in Document Groups. All the documents default to selected;
deselect the checkbox against each document that you do not want to generate (or
click on the Deselect All button to clear all selections, then select those you
require).

Click on the OK button to generate each of the remaining reports into their
respective target file locations.

Alternatively, to automatically generate every document in the Report Library
folder (again, whether or not they are in Document Groups), without displaying the
'Batch Document Generation' dialog, click on the 'Generate All Documents' context
menu option.

Manage Resource Document Groups

As you create more Resource Documents, you might find it convenient to group them by category, such as model area or

purpose. This helps you locate the required document quickly, and also refines the facility of generating multiple
documents either through quick manual selection from the group or by generating the whole group automatically.

Task

Create a Document Group

Add Resource Documents
to Group

Delete Document Group
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Action

In the 'Resources' tab of the Browser window, within the Document Publishing
folder, right-click on the Report Library subfolder and select the 'New Generation
Group' option. The 'Enter generation group name' dialog displays, in which you
type the name of the Document Group. Click on the OK button to create the group.

You can subsequently change the group name by right-clicking on it and selecting
the 'Edit Name' option, and then overtyping the name in the 'Edit item' dialog.

To add a Resource document to a Document Group, simply drag it from its current
location (in another group or under the Report Library subfolder) into the required

group.

To delete a Document Group and all the Resource documents it contains,
right-click on the group name and select the 'Delete Document Group' option. A
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warning message displays; if you want to continue and delete the group and
documents, click on the OK button.

Generate selected To generate some - but not necessarily all - of the Resource Documents in the

Documents from the Group group, right-click on the group name and select the 'Generate Documents' option.
The 'Batch Document Generation' dialog displays, with all documents in the group
selected.

Deselect the checkbox against each document that you do not want to generate (or
click on the Deselect All button and reselect the checkboxes against the documents
to generate). Click on the OK button to generate the selected documents to their
defined target files, and to close the dialog.

Generate all Documents in To generate all the Resource Documents in the group as a batch, right-click on the
the Group group name and select the 'Generate All Documents' option. The system
immediately starts to generate the documents in sequence.
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All About Document Templates

You use report templates to generate reports on your model that present specific information in a particular format, and
to generate those reports repeatedly and consistently. You can select from a range of system templates on the Document
Generator, to immediately generate reports from your model.

A template consists of:

e 'Sections' that identify the model components to report on

Fields that identify the type of information to extract on each component

Styles and formatting instructions that define the layout of the report

e Template Fragments containing smaller sub-templates

The system provides more specialized document templates for separate Cover Pages, Stylesheets and Tables of Contents.

You can also design your own custom templates, which provide the additional advantages of being able to generate
reports tailored to your own organization, and to update certain aspects of the report without having to re-define every
other specification. The report generator helps you manage these custom templates; that is:

e Review the custom templates available to you for generating reports

e  Create additional custom templates

e  Edit custom templates

e Import templates that were saved to XML files, and

e Delete any custom templates that are no longer required

Access

Ribbon

Keyboard Shortcuts

Publish > Model Reports > Templates

F8 | Templates

Manage your Custom Templates

Field/Button

Custom Templates

New
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Description

Lists the custom Templates, Fragments, Stylesheets, Cover Pages and Tables of
Contents currently available to you for generating reports through the 'Generate'
tab.

Your custom templates can be grouped within these standard folders (by Template
Type), or in another folder that you have created to hold specific templates.

To create a new custom template, click on this button. The New Document
Template' dialog displays.

In the 'New template' field, type the template name.

In the 'Template Type' field, click on the drop-down arrow and select the type of
template to create.

In the 'Copy Template' field, click on the drop down arrow and select either:

e 'None', to create an empty template to develop from scratch, or
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e The name of an existing system, Technology or custom template to act as a
base; this list is filtered to show templates of the type you specified in the
'"Template Type' field

In the 'Template Group' field either:
e Select an existing group or
e  Enter the name for a new template group, or

e Leave this field blank, to place the template in the appropriate standard type
group

The 'Template Group' determines the organization of document templates in the
'Resources' tab of the Browser window. You cannot create a template of a specific
type and assign it to the standard group of a different type. For example, you cannot
specify a Fragment and select to save it in the Cover Page folder. It either goes to a
user-created group that you select or is automatically redirected to the Fragment
folder.

Click on the OK button; the template opens in the 'Document Template Designer'.

Edit To make changes to an existing template, click on the template name and then click
on this button.

The template opens in the 'Document Template Designer'.

Import From Reference To import custom templates that were previously saved to batch XML files (that is,
File through the 'Export Reference Data' option), click on this button. The Tmport
Reference Data' dialog displays.

Click on the Select File button and browse for and select the required source XML
file.

In the 'Select Datasets to Import' panel, click on the required datasets:
e RTF Document Templates

e Templates - RTF Style Detail

e Templates - RTF Tag & Language Options

Click on the Import button to import the templates. The names of the imported
templates are added to the list on the 'Templates' tab.

If the template you want to import is a single, external file (not in a batch file) you
can instead open a template and use a different option to import the file into that
template.

Delete To delete a custom template, click on the template name and click on the Delete
button.

A prompt displays to confirm the deletion.

You can select multiple custom templates for deletion; press Ctrl or Shift as you
click on each template name.

Notes

e In the Corporate, Unified and Ultimate Editions of Enterprise Architect, if security is switched on, you need
'Configure Resources' access permission to create document templates

e  Whatever template you initially select on the 'Template' tab or New Document Template' dialog, of whichever
template type and/or group, you can easily switch to a different template and template type within the 'Document
Template Editor' whenever you need to
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Design Custom Document Templates

If you want to record and document details of your model, you can do so using a range of document reports, each
generated using a document template. To meet your specific requirements, it is possible to customize the reports by
developing your own templates; during this process you also have the option of generating test reports to review the
output from your design as you develop it. The custom templates you can develop include full-document templates and
independent Stylesheets, Cover Pages and Tables of Contents.

You create and edit report templates using the Document Template Designer to define:
e  The model components to report on

e The information to extract on each component and

e The styles and layout of the report

It is possible to create a template from scratch or by copying and editing either another custom template or a system
template. If you want to review the system templates you can list and display them using the Document Template
Designer, and establish what templates already exist to either extract the information you require, or act as a starting
point for your own design.

Access

When you open a template editor in the Document Template Designer, the Document - Edit ribbon also opens
automatically.

Ribbon Publish > Model Reports > Template Editor

Other 'Resources' tab of the Browser window | Report Templates | System Templates |
<template group> : right-click on a template | Copy

'Resources' tab of the Browser window | Report Templates | Custom Templates |
<template group> : right-click on a template | Open

The Document Template Designer

The Document Template Designer consists of:

e A ToolbarMenu, through which you create or select a template to work on, save your work, and generate and view
the test reports

e A 'Sections' panel, on which you select the components of the model to report on

e A 'Content' panel, in which you develop the content and layout of the report, using an extensive range of context
menu options
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ToolbarMenu Options

Name

New

Open Template

Save

Save As

Template Options

Find in Resource Browser

Show Sections

Generate Document
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Action

Creates a new template.

A prompt displays for you to enter the name of the new template and, optionally,
the name of an existing template to use as a base.

The Open Template tab now directs to opening the Template view within the
Resource tab.

Saves changes to the current template.

Saves the current template as a new template.

A prompt displays for the new template name.

Displays a range of document options that you can set to apply to all reports
generated using the template. These options filter and organize the information
presented in the report.

Opens the 'Resources' tab of the Browser window and/or folder containing the
currently-displayed document template, and highlights the template name.

Toggles the Document Generator view between showing the Sections hierarchy
panel and hiding it.

Generates and displays the test report based on the template.

To generate a test report, you need to specify a target file and select a Package,
diagram or element in the Browser window to run the report on. You could develop
a special test Package for this purpose.
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View Document Displays the report held in the file specified in the file path field.

You can return to a generated report many times whilst you review the effects of
different sections of the template you are editing.

The Sections and Content Panels

Facility Description

Sections Panel Consists of a hierarchy of model components and their properties, each with a
checkbox. To include information on a type of component in the report, you select
the checkbox against it.

As you select checkboxes, corresponding pairs of open/close markers display in the
'Content' panel; for example:
Sections Panel

— Package

+|:| Package Element

i | relationship Matrix

Diagram
P [¥]Connector

Content Panel

package >
diagram >
connector >
< connector
< diagram
< package

Content Panel The editing area, in which you develop the structure and content of the template.

As you add section markers to the template, text containing hints is automatically
added to provide guidance between the markers, such as:

element=
[right-click-to-insernt-Element-field(s)]
=glement

Replace the hint text with a range of fields (that extract information from your
model) and static text that is manually entered.

Editing the template Most of the work you do in creating and updating a document template is
accomplished using the facilities of the 'Document - Edit' ribbon, which is
automatically displayed when you open the Document Template Designer. For
guidance in using these facilities, you can refer to either:

e  Document - Edit Ribbon, which describes the facilities directly, or

e  FEditing Documents and Templates, which describes the document editing
facilities across Enterprise Architect

e  Custom Template Design Options, which identifies editing tasks you might
want to perform and directs you to the facilities for performing those tasks

Content Panel Context If you right-click on the field marker text or background of the 'Content' panel a
Menu context menu displays, providing a number of additional options to:

e Insert a field selected from the displayed list, where the entries are specific to
the section marker you have selected - you must also delete the text prompt
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between the section markers; when the report is generated, the field names are
replaced by the corresponding values from the model

Insert a Project Constant selected from those you have defined in the 'Project
Constants' tab of the 'Generate Documentation' dialog

Insert a Report Constant selected from the standard list; these constants derive
values from the element and Package properties

Update the style sheet used in the template to one of those listed in the
submenu, either system-supplied or user-customized; alternatively, switch from
a tailored style sheet back to the standard Normal.rtf style sheet

Hide or show the 'Sections' panel, either providing guidance on what sections
to add, or giving more space in which to develop the content of the report

Cut or copy selected text, and paste text held in the clipboard into a new
position

Undo a change - or a series of changes - that you have made, in reverse
sequence, or redo undone changes as necessary

e A standard file of global document styles, called Normal.rtf, is automatically applied to all new templates you create
from scratch; it is possible to edit Normal.rtf to tailor the styles to your requirements, and to override these styles

within the template

e You can also create special customized Tables of Contents and Cover Pages to be used optionally on any document
report in place of any Cover Pages or Tables of Contents built into the report templates, and Stylesheets that can be
chosen to override the Normal.rtf styles or any edited styles in a report template

e  You can transport templates between models, using the 'Settings > Model > Transfer > Export Reference Data' and
'Tmport Reference Data' ribbon options
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Setting Sections for Reporting

As part of designing or editing a template for generating a document report, you define the content to deliver in your
report, specifically:

e Which model features to report on (such as elements, attributes, Linked Documents and Tagged Values), using the
'Sections' panel of the Document Template Designer

e  What information to provide on the instances of each feature (such as the name, type, phase, priority or author),
using the 'Content' panel of the Document Template Designer

The information you define here determines the structure of the report, what sections it contains and the order of those
sections.

Access
Ribbon Publish > Model Reports > Templates > Sections
Publish > Model Reports > Templates > Content
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

'Resources' tab of the Browser window | Document Publishing | Custom Templates |
<template type> : right-click on a template | Open > Content

Select model components to be documented in the report

Step Action

1 Expand some or all of the hierarchy in the 'Sections' panel.

E| Package
|:| Package Element
E----DREEﬁDI‘IShip Matrix
E--Diagram
: E----Cu:unnneu:b:ur

2 Select the checkbox next to the feature name; the feature name is then displayed as a pair of section tags
in the 'Content' panel of the Document Template Designer.

element >
< element

For features in the lower levels of the hierarchy, selecting a child feature automatically selects the parent
level(s) and adds the parent tags to the 'Content' panel.

3 If you want to change the sequence of sections, click on the appropriate feature name in the 'Sections'

hierarchy and click on or to move the feature name up or down.

The position of the feature name within the 'Sections' hierarchy determines the position of the section
documenting that feature in the 'Content' panel, and hence in the report. You can change the sequence
either before or after you have selected the checkboxes, it makes no difference.
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4 For each selected feature, click between the section tags in the 'Content' panel and add text, or right-click
and select the 'Insert Fields' option to add fields.

Notes

e More specific guidance is provided for selecting these features:
- Child objects
- Embedded elements
- Profiled Relationship Matrices
- Constraints and Scenarios
- Linked Documents and Document Artifact contents
- Elements held in external Packages
- Tagged Values
- Sections formatted as tables
- Using the Custom section for Custom Query Fragments
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An object in your model can have subordinate objects: for example, elements have child diagrams and other elements;
Packages contain other Packages, elements and diagrams; and diagrams contain elements and connectors. When you set
up your document report template to report on these subordinate objects, you can:

e  Generate just the information you specify in selected fields, such as the object name only; for example, details of
elements could be extracted in a number of places - Package elements, Embedded elements, source and target
elements on connectors, child elements - and you might not require full details in all sections in your report, so you
would just set a field for the element name in some of the sections

Alternatively

e  Generate the same type of information as is provided for the parent-level objects of that type, by not defining any
content (text or fields) between the section tags; for example, you could generate recursive documentation of child
Packages, getting the same level of detail as for the parent Package

Access

Ribbon

Other

Publish > Model Reports > Templates > Sections
Publish > Model Reports > Templates > Content

'Resources' tab of the Browser window | Document Publishing | Custom Templates |
<template type> : right-click on a template | Open > Sections

'Resources' tab of the Browser window | Document Publishing | Custom Templates |
<template type> : right-click on a template | Open > Content

Examples of reporting on child objects

Example

Specific object details

Default to parent-level
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Detail

This template has valid content (text and the 'Element.Name' field) between the
child element tags. Therefore, in the generated report, the child element section will
show only the element name and none of the detail shown for the parent element.

element="7

{Element.Name}y

Npe: =+ -+ f{Element.Type}r-{Flement.BaseClasses}®

Status:— = {Element Status} ~Version {Element Version} ~Phase: {Elem ent Phase} T
Package: —+ {ElementParentPackage}~ = Keywords--{Element. Tag}-{|

Deiail:e —+  Createdtorr{Element DateCreatedShort} T

'_

{Element Notes}*

T

child-element->T
—+ Child>{Element Name}T

< child-elementT
<elementT

This template has no valid content between the child element tags. Therefore, in the
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detail generated report the child element section will default to the detail shown for the
parent element.

element="T

{Element.Name}]

Npe:+ -+ {Element.Type}=-{Element.BaseClasses}™

Status— =+ {Element Status} -~V ersion {Element Version}. ~Phase {Element Phase} T
Package: — {ElementParentPackage}= = Keywords-={Element Tag}-{]

Detailiw  —+  Createdtorr{Element DateCreatedShort} T

T

{Element Notes}'
.

child-element->T
< child element]
<alement?

Default parent detail for Package > Element > Child Element - Package > Element

child objects e Package > Element > Diagram - Package > Diagram
e Package > Diagram > Element - Package > Element
e Package > Diagram > Connector - Package > Element > Connector
Notes

e In principle, it is better to leave Child sections blank to replicate their parent sections
Child sections do not contain the same sub-section detail as their parents; Element::Child Element does not contain
sub-sections such as Scenario or Attribute, so where Child Element sections are populated, these sub-sections are not

rendered

An exception to this is cases where sub-sections are not required, but different formatting of the section fields is
preferred
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Report on Structural Elements

As part of your model, you might have created structural elements on an element, such as:
e  ActivityParameter
e RequiredInterface
e ActionPin

e Port

e  EntryPoint

e ExpansionNode

e ObjectNode

e ProvidedInterface
e ExitPoint

e Part

When you design a document report template, you can add a section to specifically identify and report on these structural
elements.

Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

Add section to report on structural elements on an element

Action Detail

Add section Select the 'Package > Element > Embedded Elements' checkbox. The embedded
elements section markers are added to the template:

embedded elements >
<embedded elements

When the report is generated from the template, any structural elements are listed
with their parent element.

Notes

e The 'Embedded Elements' section does not contain the same sub-sections as the parent 'Element' section, such as
Scenario or Attribute; if you do not define fields in the 'Embedded Elements' section, it defaults to displaying the
same detail as is in the 'Element' section, whereas if you do add fields, only those field values are shown
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Reporting Profiled Relationship Matrices

When you are using the Relationship Matrix, you search on combinations of source and target Packages, element types,
connector type and connector direction. You can save your frequently-used combinations as profiles, and you can
include the results of using these profiles in your document report by setting up a section in the report template.

If you have set up matrix profiles directly within the Relationship Matrix, you do not directly specify a matrix profile in
the report; the Document Generator returns the Relationship Matrix for all profiles that include the documented Package
as the source or target Package.

You can have more direct control over which matrix profiles are presented in a report, by creating a Matrix Specification
Artifact element that defines a profile and then reporting on the Package that contains that Artifact. The profile defined in
the Artifact is independent of the Package that contains the Artifact element, and therefore could specify source and
target Packages other than the parent Package. The Document Generator can report on only one Matrix Specification
Artifact per Package, so if you want to include more than one profile, place each Artifact element in a separate
subPackage of the target Package for the report.

Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

Add section to report on Relationship Matrix contents

Action Detail

Add section Select the 'Package > Relationship Matrix' checkbox; the relationship matrix
section markers are added to the template.

Right-click between the markers and add the Tmage' field to return the Relationship
Matrix in the report.

relationship matrix >
{Matrix.Image}
< relationship matrix

You can also insert a number of fields to identify specific aspects of the profile,
such as relationship name, direction, type, target element and element type, and
source element and element type.

Notes

e  You can view a list of the profiles created directly in the Relationship Matrix, in the Matrix Profiles folder of the
'Resources' tab of the Browser window

e Ifareported Package contains a Matrix Specification Artifact and is also part of a profile created directly in the
Relationship Matrix, the Artifact element takes precedence and the report does not include the direct Relationship
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Matrix profile
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Report on Constraints and Scenarios

In the Document Template Designer, you can create sections to include information from your model on:
e Constraints on Package Elements, Elements, Connectors and Attributes, and
e  Scenarios for Package Elements and Elements

You can set additional options in the 'Constraints' and 'Scenarios' sections to define what types of constraint or scenario
are included in your reports.

Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

Set sections to extract Constraint and Scenario details

Object Detail
Constraints In the 'Sections' panel, you can choose any or all of these constraint option
checkboxes:

e 'Constraint-Pre' - to include all constraints of the type 'pre-condition' in this
section of the report

e 'Constraint-Post' - to include all constraints of the type 'post-condition’ in this
section of the report

e 'Constraint' - to include all constraints that have not been generated in the
'Pre-Constraint' and 'Post-Constraint' sections of the report

Set any fields you need, between the section markers.

Scenarios In the 'Sections' panel, you can choose any or all of these scenario option
checkboxes:

e 'Element > Scenario' - to include all scenarios in this section of the report; if
any of the subsequent sections are also selected, the report includes all
scenarios that are not exception paths

e 'Element > Scenario > Exception' - to include all exceptions for each scenario

e 'Element > Scenario > Structured Scenarios' - to include all scenario steps in
the scenario sections of the report

e 'Element > Scenario > Structured Scenarios > Exception' - to include the steps
for each exception path in the scenario sections of the report

Set any fields you need, between the section markers.
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Reporting Linked Documents

If you have large quantities of information to provide on an element or Package, you can attach it as a formatted
document either as the content of a Document Artifact element associated with your subject element, or by attaching the
document file directly to the element (depending on the edition of Enterprise Architect you are using). In either case, you
can include the Linked Document contents in your document report by selecting one or more of the 'Linked Document'
checkboxes in the report template definition.

Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

Add sections to report on Linked Documents

Action Detail
Add sections Select the checkboxes for the levels of Linked Document you want to include in the
report:

e 'Package > Package Element > Linked Document'

e 'Package > Package Element > External Requirements > Linked Document'

e 'Package > Element > Linked Document' or

e 'Package > Element > External Requirements > Linked Document'

The Linked Document is rendered into the document report between these markers:
linked document >

<linked document

Notes

e In some system templates that you might copy, the "Linked Document' checkbox is only available as a child of the
'External Requirements' checkbox

®  You do not need to add any fields between the Linked Document section markers
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Report Elements From External Packages

Elements can be re-used in different diagrams across a model, which can often mean that a diagram contains 'external'
elements from Packages other than the diagram's parent Package. Using the Document Template Designer, you can
create custom templates to generate reports showing all elements used in a Package with 'internal' and 'external' elements
grouped separately, or only the elements actually held within a Package. You can also select options to expose the
external elements from all diagrams in a Package, or only from selected diagrams in the Package.

The separation of 'external' and 'internal’ elements avoids duplication of information and identifies the elements that
impact the Package but are not part of the Package structure. Normally, you would report the same level of detail for
each internal and external element, but you can also define a smaller group of details for the external elements, including
the name of the parent Package.

Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates

: right-click on a template | Open > Sections

Add sections to include elements in diagrams

Step Action

1 In the 'Sections' panel on the left-hand side of the editor window, select the 'Package > Element' checkbox.

Selecting the checkbox adds this set of sections to the 'Content’ panel of the template:

package *
[right-click-to-insert-Package-field(s)]
element =
[right-click-to-insert-Element-field(s)]
= element
< package

2 Delete the two [right-click-to...] texts and after the:

e package> section marker, type 'Package Name:' then right-click and select the 'Insert Field | Name'
option
e clement> section marker, type 'Element Name:' then right-click and select the 'Insert Field | Name'
option
The template now resembles this illustration:
package »
Package Mame: {Pkg.Name}
element >
Element Mame:{Element.Name}

= element
= package

3 In the 'Sections' panel, select the 'Package > Diagram > Element' checkbox.

Selecting the checkbox extends the set of sections in the 'Content' panel of the template:
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package »

Package Mame: {Pkg.Name}

element >

Element Name: {Element.Name}

= element

diagram >
[right-click-to-insert-Diagram-field(sg)]
element >

[right-click-to-insert-Eleme nt-field( )]

= element
= diagram
= package

4 Delete the two [right-click-to...] texts and after the:
e diagram > section marker type 'Diagram:' then right-click and select the 'Insert Field | Name' option
Delete the space between the element > section markers. The template now resembles this illustration:
package »
Package Mame: {Pkg.Name}
element =
Element Name: {Element.Name}
= element
diagram >
Diagram: {Diagram.Name}
element =
= element

= diagram
= package

Because the 'Diagram > Element' section does not contain any fields, the type of content of this section in
the generated report is determined by the 'Package > Element' section.

Specify diagrams and generate report

Step Action

1 Select the appropriate option:

e In the 'Properties' dialog for selected diagrams, the 'Add each contained element in Documentation'
checkbox, to identify all the elements in those diagrams in your report, or

®  On the 'Generate Documentation' dialog, the 'Include all Diagram Elements in Report' checkbox to
include all elements in each and every diagram checked by the report

2 In the Browser window, select the Package to report on, and execute the report through either:
e The Document Template Designer, or

e The 'Generate Documentation' dialog

3 The generated report for the example resembles this output:
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Package Mame: BlockFrame
Element Mame: Activity1
Element Mame: Activitylnitial
Element Mame: Blockl
Element Mame: Block?
Element Mame: Block3
Element Mame: Blockd
Element Mame: Blocks
Element NMame: ExceptionHandler1
Diagram: BlockFrame
Element Mame: Class-who
Element Mame: Class2
Element Mame: Class3

The report shows that the BlockFrame Package contains 8 elements, but has links to three elements from
other Packages because those three elements have been used in the BlockFrame diagram.

Notes

e  The illustrations in this description show the very simplest set-up, to achieve the result of identifying external
elements in a report; you can, if you prefer, populate the report with other sections and fields, leaving the 'Diagram >
Element' section empty to duplicate the structure of the 'Package > Element' section

e Ifyou do add fields to the 'Diagram > Element' section, the section will have its own structure and format and can
provide different element details; for example, selecting the 'Insert Field | Name (Full)' menu option adds the
{Element.FullName} field, which identifies each external element's parent Package

e Ifyou insert the 'Package > Diagram > Element' section but not the 'Package > Element' section, the subsequent
report will show just the elements used in each diagram, without distinguishing between external and internal
elements

e Ifyou insert the 'Package > Element' section but not the 'Package > Diagram > Element' section, the subsequent
report will show just the elements held in the Package
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Report on Tagged Values

Tagged Values are used extensively across the objects of your model, including:

Package Elements

Elements

Connectors and their Source and Target elements
Attributes

Operations (Methods) and

External Requirements

When designing a template to report on these objects, you can include information on their Tagged Values either:

As a group, using the 'Tagged Value' subsection to identify all Tagged Values used in the object, or

e Individually, using the 'valueOf()' field to extract a specific value of a specific tag
Access
Ribbon Publish > Model Reports > Templates > Sections
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Sections

Extract information on Tagged Values

Action Detail
Insert a Tagged Value The Tagged Value section reports all Tagged Values for the object.
section

In the 'Sections' panel, select the checkbox for each object to report on, and for the
Tagged Value subsection for that object. For example:

e Package > Package Element > Tagged Value

e Package > Connector > Source > Tagged Value

e Package > Element > External Requirements > Tagged Value, or
e Package > Element > Method > Tagged Value

The Tagged Value section markers display in the 'Contents' panel.

tagged walue >
[right-click-to-insert-Tagged-Yalue-field(s)]

= tagged value

Delete the [right-click-to-...] text, right-click in the space and select the 'Insert
Fields' option to add 'Tagged Value Name', 'Notes' and/or 'Value' fields.

Insert a valueOf() field For any object having a Tagged Value, you can add a 'valueOf()' field to your report
template to extract the value of a specific tag. This should be one of the tags
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normally associated with the object, such as 'ConnectorAltName' for a connector.
Obtain the name of the tag before starting this procedure.

To insert the field, right-click between the section tags for the object and select the
'Insert Field | valueOf option.

The Document Template Designer prompts you to type in the name of the tag from
which to extract the value. Type the name and click on the OK button. The
Document Template Designer adds the field at the cursor position, in the format:

{Objecttype.valueOf(tagname)}
For example:
{Connector.valueOf(ConnectorAltName)}

The 'valueOf field extracts just the value of the tag, so for clarity you could type
some lead-in text or the meaning of the tag, immediately preceding the value field.
For example:

Alternative Name: {Connector.valueOf(ConnectorAltName)}
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Create Sections as Tables

In a document report template, you can render a model section as a table, defined with any number of columns but with
only two rows:

e  The first row is used to describe the headings of the columns, which you define and format yourself

e The second row defines the output, which you specify by right-clicking in each cell and selecting the output type
from the field list; the output is then generated iteratively for every occurrence of the section in question

For example, you might set up the Model > Glossary > section as a section table, using the table definition:

model =

IVIodeI Glossary

< glcssarﬁr
< model

This table definition renders the document output:

Model Glossary

EAccnuntmg Periods _ ¢ A defined period of time _
5 é : whereby performance reports
i may be extracted. (normally 4
............................................................................................................................... -week periods).
Assnmatmn Tec:hmn::al _A relationship between two or
imaore entities. Implies a
iconnection of some type - for
fexample one entity uses the
isemvices of another, or one
'entit'_-,ris connected to another
i over a network link.

Ribbon Document-Edit > Paragraph > Table > Insert Table

Create and format a table

To Action
Insert a table in the Position the cursor on the point in the text to create the table, and from the
document 'Document-Edit' ribbon bar select 'Paragraph > Table > Insert Table'. The 'New

Table' dialog displays, in which you specify the number of table rows and columns.
For a model section table in a report template you can accept the default values of
two rows and three columns. Click on the OK button.

Your table might be invisible; if so, select the 'Paragraph > Table > Show Gridlines'
from the ribbon bar to reveal the table and cell borders in dotted lines. These lines
are for guidance in creating the document, and do not display on the printed
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document. You can add printable borders if you prefer, using other menu options.

The editor initially creates a table with cells of equal width across the page; you can
change the cell width by dragging the cell borders using the mouse, or using other
context menu options.

Select the top row of the table, and then select 'Paragraph > Table > Header Row'
from the ribbon bar. Apply any heading text, settings and formatting to the
highlighted row.

In the document or compiled report, the heading row is repeated at the top of the
columns each time the table flows on to a new page. In a report, if the heading row
is populated with the values from field names, the heading rows on subsequent
pages reflect the values from that first row.

This option operates on the single row at the top of the table, and not on multiple
TOWS.

Right-click on the table cell and select the 'Insert Field | <field name>' option to add
one or more fields to the cell.

When the report is generated, the field values are extracted and displayed in the
table for each instance of the object, such as an element or attribute.

e Inadocument report template, if you type a carriage return between the end of the table and the section terminator,
the table you generate has a line space between the rows; for example:

Eac kage =3

a

T

BRI :ElementsMames Authors %

T ({Element Mamej=  {Element Authorgs:

g +— Carriage Return
<relementd

Zpackaged

This generates the table:

Element Mame Author
Choose Recipient John Redfern

Line Space
Manage Contacts Walter Frederick

To avoid this, remove any carriage return between the end of the table and the section terminator, as shown:
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Ba-: kage =d

8

alements=d

=ralementd 4+— No Carriage Return
=packaged

This generates a table with no space between the rows:

Element Name Author
Choose Recipient John Redfern
Manage Contacts Walter Frederick
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Add Section Content

In the Document Template Designer, as you select the checkboxes in the 'Sections' panel to report on the different
objects and features of the model, pairs of highlighted tags are added to the 'Contents' panel. Many of these pairs of tags
have a short instruction between them, as shown:

sectionname >
[right-click-to-insert-< objectname >-fields]
< sectionname

Where the text message is shown, you can delete it and use the space between the tags to provide the content of the
report, by:

e Typing or pasting boiler-plate text that you want to include in your reports, and

e Inserting fields that extract the values of specific characteristics and properties of the object

Access
Ribbon Publish > Model Reports > Templates > Content
Other 'Resources' tab of the Browser window | Document Publishing | Custom Templates |

<template type> : right-click on a template | Open > Content

Add information content to template

Action Detail

Add text Click in the space between the tags (or anywhere else in the template) and type or
paste (Ctrl+V) the text you want to display in the report.

Highlight and right-click on text to format it, using the Document Editor
commands.

Insert fields Right-click in the area between the opening and closing tags, and select the 'Insert
Field' option; this displays a context-sensitive list of fields to add to this section of
the template.

Click on the name of the field you want to add. The Document Template Editor
displays the field tag in the text space. For example:

{Element.ParentPackage}

When you generate a report from the template, the report generator replaces the
field name with the actual value. You might need to type lead-in text and add
spaces to support the field value, or use the fields in a table with row and column
headings.

You can insert as many fields as you want from the list; you usually apply each
field once, as the report generator applies the template instructions to each instance
of the object.
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Notes

e  As the model and Linked Document tags do not require fields, you cannot display the editor context menu between
these tags

e  The child element, embedded element and child Package tags represent sections that can have defined fields, but
these fields prevent the sections from replicating the structure of their parent element and Package sections; as it is
preferable to use the parent structures, these tags do not prompt you to add fields with the
[right-click-to-insert-<objectname>-fields] message, although the message is still applicable

e Ifyou select a field with short date format (such as Pkg.DateCreatedShort, Diagram.DateModifiedShort or
Element.DateCreatedShort) the format is actually drawn from the MS Windows settings; to use a different short date
format, click on the Start icon on the Windows desktop and select the 'Control Panel | Regional and Language
Options | Customize' option
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Apply User-Defined Section Numbering

In your report template, you might want to number the section levels, with a numbering format of your own design. For
example:

1. Package level 1
1.1 Package level 2 (child Package)
1.1.1 Element Level 1
1.1.1.1 Element (child element)
To define the numbering format you:
e  First create a numbering list, then
e (Create a set of list overrides for this list

In the overrides, you change the initial 1.0.0 setting to 1.1.1. You can then apply the numbering list to the headings set
for Packages and elements, using paragraph numbering.

Access

Ribbon Document-Edit > Edit > Edit > List and Overrides

Define the numbering format

Step Action

1 To create the numbering list, select the 'Create List Item' menu option.
The 'List Properties' dialog displays:
e In the 'List Name' field, type a name for the list
e [eave the 'Multi-level list' checkbox selected

e [fyou have added sections to your document and want to restart numbering for each new section,
select the 'Restart at section break' checkbox

e Click on the OK button to close the dialog

2 To create the list override, select the 'Create List Override' menu option.
The 'List Override Properties' dialog displays:
e In the 'List to Override' field, type or select the name of the list you have just created
e [Leave the 'Override Levels' checkbox selected
e  Click on the OK button to close the dialog

3 To set up the list level properties for a level, select the 'Edit List Level' menu option.
The 'List Level properties' dialog displays.
e  Select the 'List item' radio button and type or select the list item you have just created
e Set the 'List Level' field to '1' (for the Package Section) and the 'Number text' field to '~1~'
e  Click on the OK button to save the values and close the dialog
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4 Select the 'Edit List Level' menu option again to re-open the dialog:
e  Select the 'List item' radio button and type or select the list item you have just created
e Set 'List Level' to '2' (for the 'Element Section' or 'Child Package Section', for example)
e Set 'Start at' to 'l' (to ensure that numbering at this level begins at 1.1 rather than 1.0)
e  Click on the OK button to close the dialog and save the changes

5 Repeat steps 3 and 4 for each additional list level to need, incrementing the List Level number and
resetting Start at to 1 each time.

Apply the defined numbering levels

Step Action

1 In the 'Content' panel of the Document Editor, select the first item of text to be numbered (for example,
Package).

> Pl Marmel

Element<Element. NameM]
childelements-=
<=childelements

<=glemen

childpadckages-=
<=childpackages

<packageq|

2 Set the text style to one of the Heading styles (Heading 1 to Heading 9), using the 'Style' drop-down field
in the Document Editor toolbar.

package-=|

Package:{Pkg.Name} 1

3 Right-click on the text and select the 'Paragraph | List Numbering' menu option.
The 'Apply paragraph numbering using Lists' dialog displays.
e In the 'List' panel, select the required List and Override combination
e Set the 'Level field to the required level (1, for the top level)

e  Click on the OK button to close the dialog, and check that the required level has been applied to the
selected text

package =1

1. Package:-{Pkg.Name}q
4 Repeat step 3 for the next level (Element), but change the 'Level' field to 2.

element-=

1.1 Element:-{Element.Name}q

5 Continue applying the overrides for each lower section level as necessary, then generate your document.
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The output will be numbered and formatted, as illustrated by the example.

Numbering Level Example

1. Package: Formal Requirements
1.1 Package: Manage Users

1.1.1 Element: REQO11 — Manage User Accounts
1.1.2 Element: REQ016 — Add Users

1.2 Package: Manage Inventory

1.2.1 Element: REQO019 — Manage Inventory

1.2.2 Element: REQ020 — Receive Books

1.2.3 Element: REQO021 — List Stock Levels
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Custom Template Design Options

The Document Template Designer, through the 'Document-Edit' ribbon, provides a wide range of options for defining the
format and styles of the document reports generated from your custom templates. In addition to these functions, you can
also access options from the toolbar at the top of the 'Content' panel, and from an in-text context menu.

Access

When you open a template in the Document Template Designer, the Document - Edit ribbon also opens automatically.
Ribbon Publish > Model Reports > Templates
Other 'Resources' tab of the Browser window | Document Publishing | System Templates |

<template group> : right-click on a template | Copy

'Resources' tab of the Browser window | Document Publishing | Custom Templates |
<template group> : right-click on a template | Open

Option Descriptions

The ribbon option descriptions are grouped according to the actions you are performing.

Actions

Creating and importing templates
Configuring the editor page display and formatting tools shown

Incorporating stylesheets, special texts and Tables of Contents

Managing the base styles in the Normal.rtf style template file

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and repaginating

Inserting and editing page headers and footers, and footnotes and endnotes
Inserting tables

Setting up User-Defined Section Numbering

Inserting hyperlinks
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Inserting images, OLE objects, frames and drawing objects
Checking the spelling of text, and word use

Tracking changes and incorporating or rejecting them
Protecting document and template text from accidental change

Printer set up and printing documents

Notes

Throughout your template editing:

e To undo one or more immediately previous edits, press Ctrl+Z, or select the 'Undo' context menu option; you can
still undo a change even after you have saved the change

e To redo one or more immediately previous undone edits, press Ctrl+Y, or select the 'Redo’ context menu option
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Using Bookmarks

Within a document template, you can insert a bookmark to locate material inside the generated document, either from
within the same document or from a separate Word document.

Manage bookmarks

As your report template develops, the editor automatically assigns a unique bookmark to the start and end of each model
section you select from the 'Sections' panel.

You can also create your own bookmarks in any document wherever you want to reference a specific point, and move
these to other points in the text.

(In the report template you can move the automatic bookmarks as well, but if you want to use these as reference points
for a Word document to access, it is better to leave them as they are.)

Task Description

Insert a Bookmark 1. Right-click on the point in the text to mark, and select the 'Bookmark' menu
option; the 'Bookmarks' dialog displays.
2. Either select an existing bookmark from the list (to switch it to the current

location) or type a new bookmark name in the top field. Do not use spaces in
the Bookmark; this will prevent the bookmark from being inserted.

3. Click on the Insert button.

Locate Bookmarked Text 1. Select the 'Bookmark' menu option.

in the Document 2. On the 'Bookmarks' dialog, click on the bookmark and on the Go to button.

The editor displays the point at which the bookmark was set, in the top left
corner of the display.

Delete an Existing Select the 'Bookmark' menu option.

Bookmark On the 'Bookmarks' dialog, click on the bookmark and on the Delete button.
Insert a Reference to a 1. Move the cursor to the point at which to insert the reference and, if you want
Bookmark to, type some lead-in text such as 'Go to page' or 'See page'.

2. Select the 'Bookmark' menu option.

On the 'Bookmarks' dialog, click on the bookmark and on the Set Page
Reference button.

4. The editor inserts the number of the page containing the bookmark, at the
cursor position in the text; for a document, this acts as a hyperlink to the
bookmark position. If you set the reference in a template, the link is created in
the document you generate from the template.

Additional Bookmark Facilities in Document Generation

All .Start and . End bookmarks that enclose a labeled field will hide the label in the report if the field has no content; for
example:

e  The bookmarks Element. Keywords.Start and Element. Keywords.End enclose the Keywords {Element. Keywords}
report field, but if an element has no keywords, the Keywords label in the generated report is hidden and the space
closed up
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All Begin and End bookmarks containing the string LIST will add a comma to the enclosed section, so that all values
extracted from the model for that section will be presented in a comma-separated list; for example:

e  The bookmarks Pkg Element Meth MethParameter LIST Begin and
Pkg Element Meth MethParameter LIST End in the parameter section set a comma that, in the report, is inserted
between the multiple parameter name/type pairs in the section

All Begin and End bookmarks containing the string 7/7LE_will add a line break and a value title to the field, and
present the values extracted from the model as a vertical list underneath the title; for example:

e  The bookmarks Pkg Element Meth FeatTagVal TITLE Begin and Pkg Element Meth FeatTagVal TITLE End
in the Tagged Value section insert a line space and the heading 'Properties’, underneath which is printed, in the
report, the names and values of the parameter Tagged Values

Notes

e When you force a custom SQL field in the fragment to be processed as a formatted notes, you must have '.formatted'
in the custom field name; for example:
{FieldName.Formatted}

e  The same is required in the bookmarks for SQL fragments; for example:
{FieldName.Formatted.Start} or FieldName.Formatted.End}.
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Report Constants

The Document Editor (for generated report templates) provides a set of fields that represent data on the report itself, such
as the report name, title, generation date, version, author and status. When the report is generated, each field is replaced
by the current value of the data item. These are called report constants.

You can insert a report constant anywhere in your template - in text, in headers or footers, or in cover page material.
They are particularly suited for cover pages.

Constants

Constant

ReportAlias

ReportAuthor

ReportClipboard
ReportDateLong
ReportDateShort

ReportFilename

ReportFilenameShort

ReportKeywords

ReportName

ReportSource

ReportStatus

(c) Sparx Systems 2025

Replaced by

(For a report generated on a root Package) The Alias of the Package, from the
Package properties.

(For a report generated on a single element) The Alias of the element, from the
element properties.

Otherwise, the constant remains empty.

The Enterprise Architect login ID of the user who is generating the report.
The image currently held on the clipboard.

The system-generated date in long format.

The system-generated date in short format.

The file name of the generated report, as recorded on the 'Generate Documentation
dialog.

The current filename of the generated report. (Will change if the file is renamed on
disk.)

(For a report generated on a root Package) The Keywords of the Package, from the
Package properties.

(For a report generated on a single element) The Keywords of the element, from the
element properties.

Otherwise, the constant remains empty.

(For a report generated on a root Package) The name of the Package, from the
Package properties.

(For a report generated on a single element) The name of the element, from the
element properties.

Otherwise, the constant remains empty.

The name of the Repository that was used to generate the document.
For file-based repositories, this will be the file path and name of the project file.
For DBMSs this will be the name of the database used.

(For a report generated on a root Package) The status of the Package, from the
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Package properties.

(For a report generated on a single element) The status of the element, from the
element properties.

Otherwise, the constant remains empty.

ReportSummary Provides the content of the 'ReportSummary' Tagged Value found on the root
Package or single element.

If there is no 'ReportSummary' Tagged Value, the constant remains empty.

ReportTitle The name of the template used to generate the report, as selected on the 'Generate
Documentation' dialog.

ReportVersion (For a report generated on a root Package) The version of the Package, from the

Package properties.

(For a report generated on a single element) The version of the element, from the
element properties.

Otherwise, the constant remains empty.

Insert a Report Constant

Right-click on the point in the template to insert the data field and select the 'Report Constants | <field name>' option.
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Notes on Creating Stylesheets

Stylesheets define a range of formatting parameters that control the appearance and layout of a document report. You
create them to provide an alternative set of styles to the Normal.rtf file and to any special styles redefined within a
document report template. A user can choose to apply a Stylesheet to any kind of document report they are generating, in
which case the styles in the Stylesheet override the styles with matching names in the template or Normal.rtf. You can,
therefore, create a Stylesheet that:

e Redefines and overrides certain styles
e Does not include other named styles, so use of those styles defaults to the template or Normal.rtf file definition, and
e Provides additional styles that can be applied by editing the generated report

Each custom Stylesheet can define a totally different page layout and document styles to other Stylesheets and to the
Normal.rtf Stylesheet.

The simplest way to create a new Stylesheet is to copy one of the system-provided files (for print output or for online
output) or another custom Stylesheet, and edit the style definitions in the copy. However, you can create a Stylesheet
from scratch if you prefer; this would be initially derived from the Normal.rtf file.

Access

Use one of the methods outlined here to display the 'New Document Template' dialog. Create the new Stylesheet file,
then edit the styles in the Document Template Designer using the 'Styles, Special Text and Table of Contents' facilities.

Ribbon . £
Publish > Model Reports > Templates : or

Start > All Windows > Design > Explore > Browse > Resources > Document
Publishing > Custom Templates > right-click on Style Sheets > Create Template

Start > All Windows > Design > Explore > Browse > Resources > Document
Publishing > Custom Templates > Style Sheets > right-click on <stylesheet name> |

Copy

Other In the 'Resources' tab of the Browser window, expand the Document Publishing
folder, then:

e Expand the Custom Templates folder | right-click on Style Sheets | Create
Template, or

e Expand the System Templates folder | Expand the Style Sheets folder |
right-click on <stylesheet name> | Copy

You can also create Stylesheets within the 'Templates' tab of the 'Generate
Documentation' dialog.
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Notes on Creating Tables of Contents

A Table of Contents template defines the style, levels and numbering formats of a document report Table of Contents
that a user can choose to apply to any kind of document report they are generating, in which case the Table of Contents
template overrides any Table of Contents styles defined in the template or Normal.rtf file.

The simplest way to create a new Table of Contents is to copy one of the system-provided files (for portrait output or for
landscape output) or another custom Tables of Contents, and edit the style definitions in the copy. However, you can
create a Table of Contents from scratch if you prefer; this would be initially derived from the Normal.rtf file.

Access

Use one of the methods outlined here to display the New Document Template' dialog and create the new Table of
Contents template file.

After creating the new template file, edit the styles in the Document Template Designer using the 'Styles, Special Text
and Table of Contents' facilities.

Ribbon ) %
Publish > Model Reports > Templates :

Other In the 'Resources' tab of the Browser window, expand the Document Publishing
folder, then:

e  Expand the Custom Templates folder | right-click on Table of Contents | Create
Template, or

e Expand the System Templates folder | Expand the Table of Contents folder |
right-click on <table of contents name> | Copy

Insert a new Table of Contents

To insert a new Table of Contents:
e  Add at least one character of text to the document
e  Set that to a 'Heading n' style. For example 'Heading 1'

e Move the cursor to the point at which to insert the Table of Contents, and select the option:
Document-Edit > Edit > Insert > Table of Contents.

A small dialog displays in which you specify the highest and lowest Table of Contents levels to apply in the table in this
document; when you have specified the levels, click on the OK button.

Insert Custom TOC bl

Select Table of Content Range

Start |1 - End 9 -

DK Cancel

Note: If there are corresponding headings within the specified range, the Table of Contents displays; otherwise, the line
remains blank.

e Remove the Heading Style text added above.
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e  Save the template.
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Import a Document Template

Many organizations have established corporate formats and templates, or might design templates outside Enterprise
Architect. If you want to use such 'external' templates from your business to apply formats and standards to your
document reports, you can import them into your document template library.

Access

Ribbon Document-Edit > File > File > Import File

Import a template from an external directory

Step Action

1 Save the external template as a document.
2 In Enterprise Architect, create a new blank template.
Either:

e Click on the { icon in the Document Template Designer, or

e Right-click on a User Template folder in the 'Resources' tab of the Browser window and select 'Create
Template'

The 'New Document Template' dialog displays. Name the template, but do not specify an existing
template to copy from.

3 Once the new blank template is loaded in the Document Template Designer, select the option
'Document-Edit > File > File > Import File'.

The 'File Open' dialog displays.

4 Locate your template file, and click on the Open button.

The 'Open' dialog closes, returning you to the Document Template Designer; this now contains your
imported template.

5 Select the option 'Document-Edit > File > Save'.

If necessary, make any changes to the template and select the option 'Document-Edit > File > Save' again.

Notes

e Standard graphical images (such as a logo in the header, main text or footer) are imported; however, any meta-file
graphics are not imported

®  You can select the new template to use in generating a document report, either on the 'Generate Documentation'
dialog or in a Model Document element
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Notes on Creating Cover Pages

A Cover Page template defines the style, fields and format of a document report front cover that a user can choose to
apply to any kind of document report they are generating, in which case the Cover Page styles override any styles of the
same name defined in the report template or Normal.rtf file.

The simplest way to create a new Cover Page is to copy one of the system-provided files (for portrait output or for
landscape output) or another custom Cover Page Contents, and edit the style definitions in the copy. However, you can
create a Cover Page from scratch if you prefer; this would be initially derived from the Normal.rtf file.

Access

Use one of the methods outlined here to display the New Document Template' dialog and create the new Cover Page
template file.

After creating the new template file, edit the styles in the Document Template Designer using the 'Styles, Special Text
and Table of Contents' facilities.

Ribbon . i:j
Publish > Model Reports > Templates :

Other In the 'Resources' tab of the Browser window, expand the Document Publishing
folder, then:

e Expand the Custom Templates folder | right-click on Cover Pages | Create
Template, or

e Expand the System Templates folder | Expand the Cover Pages folder |
right-click on <cover page name> | Copy
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Template Fragments

Within a document template you can include one or more sub-templates, or Template Fragments. Using Template
Fragments, you can include in your document reports information extracted from the model using SQL Queries and
Model Scripts, providing a greater level of customization of the document output. You can also use a Template Selector
Fragment to call other Template Fragments depending on which type of element is being reported on. It is possible to
reuse the same Template Fragment in several different templates, so you can develop a library of common Template
Fragments that can be used to build larger, more complex document reports.

A Template Fragment is created through the same process as a normal, full-document template. Each Template Fragment
can have its own document options applied, such as filtering and sorting.

You can also use, copy and edit a number of system-provided Template Fragments, which you can access from the
Document Publishing > System Templates > Fragments folder in the 'Resources' tab of the Browser window.

Template Fragments - Process Overview

Step Action

1 Create the Template Fragments to be included in your template.
2 Create a normal, full-document template that is to include your Template Fragments.
3 Within this full-document template add references to your Template Fragments in the appropriate
locations.
Notes

e  You cannot generate documentation directly from a Fragment; to use a Fragment it must be included in a template
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Creating a Template Fragment

A Template Fragment can return data from either an SQL Query or Model Scripts. The process of defining the content of
a Template Fragment depends on which type of data you want your Template Fragment to return; the choices being:

Normal Document Template model data - the Template Fragment operates in the same way as a normal template

Template Selector - to define a template that calls in other Template Fragments depending on the element type being
reported on

Custom SQL - to refer to the data returned by a custom SQL Query
Custom Scripts - to refer to data returned from a Model Script

Document Script - to identify a Model Script to be used by your Template Fragment; the script must return either an
empty string or a string that contains raw RTF

Custom XML Script - to create a query to report values from an XML file produced by a previously-generated
script, such as the data from a simulation; the query operates on static data that is not being continually or
automatically updated

In all cases the process is very similar to creating a normal document template.

Access

Use one of the methods outlined here to open the New Document Template' dialog.

Ribbon ) o )
Publish > Model Reports > Templates : New Template icon
Keyboard Shortcuts F8 > Templates : New
Other In the 'Resources' tab of the Browser window, expand the Document Publishing

folder, then:

e Expand the folder Custom Templates | right-click on the folder Fragments |
Create Template or

e Expand the folder Custom Templates | expand the folder Fragments |
right-click on <template name> | Copy or

e Expand the folder System Templates | expand the folder Fragments | right-click
on <template name> | Copy

Create a new Template Fragment

Step Action

1

Using one of these methods, display the New Document Template' dialog.
In the 'New Template' field, type the name for the Template Fragment.
In the 'Template Type' field, click on the drop-down arrow and select the 'Fragments' option.

In the 'Copy Template' field, click on the drop down arrow and select either:
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e 'None', to create an empty Template Fragment to develop from scratch, or

e The name of an existing Template to act as a base

5 In the 'Template Group' field either:
e  Click on the drop-down arrow and select an existing group from the list, or
e Type a name to generate a new template group, or
e Leave this field blank, to not place the Template Fragment in a group

The Template Group determines the location of the Template Fragment in the 'Resources' tab of the
Browser window.

6 Click on the OK button.

The Document Template Designer displays in the Diagram View.

7 Define the contents of your Template Fragment; the actual steps you follow depend on the data source you
want the Template Fragment to operate on:

e Normal Document Template model data
e Template Selector

e (Custom SQL

e  Custom Scripts

e Document Script

e Custom XML Script

8 Once you have created the Template Fragment, you incorporate it into a normal template (or into an
existing Template Fragment, if you prefer).

Notes

e  Custom Queries and the Custom template section can only be used in Template Fragments; they cannot be used in
normal, full-document templates

e As with normal document templates, Template Fragments can also be created and opened via the 'Resources' tab of
the Browser window

e Template Fragments in the 'Resources' tab are held in a Fragments folder in each of the Document Publishing >
System Templates and Document Publishing > Custom Templates folders, and are indicated by a T symbol

e Ifyou have an existing template that you want to use as a Template Fragment, copy the template as the base of a
new Fragment

e Filtering operates only for the template in which it is set, and does not propagate through sub-templates/fragments;
you can set filtering for each sub-template separately, in the Document Options for the sub-template

e Ifyou embed a Template Fragment within another Fragment, report generation from the parent template will be
slower

e Ifyou have a column or node with the name EABOOKMARK, this will insert a document bookmark around the
parent section in the 'Contents' panel

(c) Sparx Systems 2025 Page 85 0of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

How to Define a Template Selector Fragment

A Template Selector is a Template Fragment that calls other Template Fragments, depending on what type of element is
being reported. The Template Fragments being called can be system Fragments or existing user-defined Fragments, as
listed in the 'Resources' tab of the Browser window.

Access

Use one of the methods outlined here to display the 'Custom Query' page of the 'Document Options' dialog. Before you
select the Document Options icon, select the 'Custom' checkbox in the 'Sections' list, to enable the 'custom > <custom'
tags. These are necessary for the Template Selector fragment to work.

Ribbon Publish > Model Reports > Templates : <select a fragment template> : &
(Document Options icon) > Custom Query
Keyboard Shortcuts F8 > Templates | Fragments | Double-click on <Fragment name>, then Gy

(Document Options icon) > Custom Query

Set Up the Template Selector

Option Action
Template Selector Click on this radio button to define the template selection commands.
data field On separate lines, type each element type and the name of the Template Fragment

to use for that element type, in the format:
ElementType:<stereotype>:Fragment Name

For example (elements not extended by a stereotype):
Action::Behavioral
ActionPin::Simple Behavioral
CollaborationUse::Structural

and (element extended by a stereotype):
Class:table:Database Table

To identify the fragment to use if elements are reported that have not been
specifically identified, type:

default::Fragment Name

Also see the Notes section in this topic.

OK Click on this button to save the changes you have made and close the 'Document
Options' dialog.

Notes

(c) Sparx Systems 2025 Page 86 of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

Further advice on providing a value for the data field:

To a certain extent you can adapt the 'extended by stereotype' line according to what alternative modeling language you
are using, what you specifically want to extract in the report, and what elements exist under the Package or element you
execute the report on. For example:

e  Extract ArchiMate Business Actor elements
- From a structure containing UML and ArchiMate elements - Class: ArchiMate Business Actor:BusActFrag
- From a structure containing only ArchiMate elements - Class:BusinessActor:BusActFrag
- From a structure containing only ArchiMate Business Actor elements - Class::BusActFrag

e  Extract Business Actor elements
- From a structure containing UML and ArchiMate elements - Class:Business Actor:BusActFrag
- From a structure containing only ArchiMate elements - Class:BusinessActor:BusActFrag
- From a structure containing only Business Actor elements - Class::BusActFrag

To establish the type and Stereotype details of a representative element selected in the 'Resources' tab of the Browser

window, run this query in the SQL scratch pad (use the ribbon option 'Explore > Search > Model : El > SQL Scratch
Pad"):

e Sclect t_object.name, t_object.Object Type, t_object.Stereotype from t_object where
t_object.Object ID=#CurrentElementID#

For example, selecting a BPMN DataObject in the Browser window and running this SQL gives:
Name - Issue List[Initial]

Object_Type - Artifact

Stereotype - DataObject

So you would use the combination Artifact:DataObject:<fragment name> in the data field

Alternatively, do not use a Template Selector fragment and create a simple template to operate on the 'Element' section
of the report, to extract elements of Type - Class and Stereotype - Business Actor. Run this on the specific element(s).

For a complete example, make a copy of the system-supplied Template Selector in the Document Publishing | System
Templates | Fragments folder of the 'Resources' tab of the Browser window and review the 'Custom Query' tab of the
'Document Options' dialog. (To make a copy, right-click on the template name and select the 'Copy' option.)
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How to Define a Custom SQL Fragment

You can create a Template Fragment to return data from an SQL Query. You do this by defining an SQL Query in the
'Document Options' of the Template Fragment, then adding fields within the 'Custom' section of your Template Fragment

that refer to the columns returned by the SQL Query. The Query is DBMS dependent and so might vary according to the
DBMS you are using.

Create an SQL Query Fragment

Step

Action

Open or create a Template Fragment in the Document Template Editor.

In the Document Template Editor:
e Click on the Document Options @icon.
The 'Document Options' dialog displays.
e  Select the 'Custom Query' page
e In the 'Template Fragment type' panel, select the Custom SQL radio button.

In the main text field on the tab, type the SQL Query that is to be run on your model.
% F' E @ EL [ | |Model Templates - | | Property ~|  |Z\hon @.

Sections @ @ Content
E- Model

O — [ 2 s PR
B-|_| Package

Packagl Element

Relatiofship Matrix
Diagra

custom >
Type Notes

- | v| Custom - {Type Hyperlink} {Note Formatted}
- < custom

Document Options

Document Options Template Fragment
Exclude Filters

Element Filters ¢! Custom SQL Custom Script Template Selector Document Script Custom XML

Other Filters

select #Concat ea_guid, Name# as "Type.Hyperlink", Note as "Note.Formatted"

from t object

where Name like 'Block#wWC#' and ea_guid in (select PDATA1 from t_object where Object_ID=
#0BJECTID#)

For more details see the Create a Custom SOL Query Help topic.

Click on the OK button to close the 'Document Options' dialog.

In the 'Document Template Editor', in the 'Sections' panel, select the 'Custom' checkbox to generate the
'Custom' section.

Within the 'Custom' section, right-click and select the 'Insert Custom Field' option.
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1 HE BR[O Model Templates - || Property - | Zhome
Sections @ @ Content
-] Mogel [ P - - T 23
=[] Package
| Package Element
| Relationship Matrix
| Diagram
] Element

custom >

Type Motes
{Type.Hyperlink}

< custom

Report Constants 4

Insert bstom Field
Insert Custom Field

Update Styles L
A prompt displays for the name of the field to create.
7 In response to the prompt, type the name of the column that is being returned by your Query; for example,
Note.Formatted.
Click on the OK button.
8 Repeat steps 6 and 7 for each column that you want to include in your report.

Add any other formatting and content you need, to the Template Fragment.

11 Save the Template Fragment, and add it to a normal document template.
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Create a Custom SQL Query

When defining your own SQL statement for a template fragment there are a number of options available to assist in
delivering the desired reporting format. The query is DBMS dependent, so the structure can vary according to the
specific repository file or DBMS-type that you are using.

Query Options

Option Description

Macro Substrings In the main text field on the tab, type the SQL Query that is to be run on your
model. You can use #<macro>#s as string substitutions, as for other SQL Search
Queries.

The SQL Query can reference the ID of the element, diagram or Package currently
being processed by the document template, using the macros:

e #OBJECTID#

e #DIAGRAMID#
e #PACKAGEID#
For example:

e SELECT Count(Object Type) AS CountOfActors
FROM't object
WHERE Object_Type = "Actor" and Package ID = #PACKAGEID#

There are a number of other useful macros like:
e #Concat <valuel>, <value2>, ...#
e #WC# Wildcard for your specific Database type.

For more details see the Create Search Definitions Help topic.

Formatted Notes For notes fields, like the Element Notes (t_object.note), the formatting is stored as
(excluding .eap) rich text. It is possible for a note field to be processed from raw data to readable
rich text by providing a column in this format:

{<fieldname>.Formatted}
This is defined in the Custom section in the Template. For example:

e custom>
{Note.Formatted}
< custom

In your custom SQL Query statement, you must use an alias matching the template
field name; for example (in MySQL):

e SELECT ea_guid AS CLASSGUID, Object Type AS CLASSTYPE, Name,
Note as "Note.Formatted"
FROM t_object
Where Object ID=#OBJECTID#

Formatted Notes for .eap For formatted notes using .eap file repositories the format requires:
repositories {<fieldname>.Formatted}
For example:

e custom >
{Note.Formatted}
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< custom

In your custom SQL Query statement format the field-alias as
'[<fieldname>-Formatted]'. For example:

e SELECT ea_guid AS CLASSGUID, Object Type AS CLASSTYPE, Name,
Note AS [Note-Formatted]
FROM t_object
Where Object ID=#OBJECTID#

Hyperlinks (excluding You can make column entries into hyperlinks referencing other entries in the
.eap) generated document. The column header field (in the template text, in the 'Custom
panel) must use the format:

Al

<fieldname>.Hyperlink
For example:

e custom >
{Type.Hyperlink}
< custom

The SQL column entries, or values, must have the format: {guid}<LABEL>
For example:

e SELECT #Concat ea_guid, Name# as "Type.Hyperlink"
FROM t_object
WHERE Object ID=#OBJECTID#;

Note: this uses the #Concat ...# to concatenate the GUID reference and the outward
expression of the hyperlink.

In this format, {guid} is the GUID of the element to link to and LABEL is the
hyperlink text (such as the element name), either manually inserted or returned
from another command. For example:

{570CFDAB-00A4-48d9-AE87-9CD6920418C0} Class2

In the generated report this displays as a hyperlink 'Class2', which links to the
description of Class2 in the document.

This example returns the hyperlinked name of each base (parent) Class of the
element currently being reported:

e SELECT #Concat t_object.ca_guid, t object.Name# AS
"BaseClassName.Hyperlink"
FROM t_object, t_connector
WHERE t_connector.Start Object ID = #OBJECTID#
AND t_object.Object ID =t connector.End_Object 1D
AND t connector.Connector Type = 'Generalization'

This query could return multiple entries, in which case the entries are reported one
per line. You can, if required, have multiple Hyperlink query statements, separated
by commas. You can hyperlink to reported elements, attributes, operations,
diagrams and Packages.

Hyperlinks for.eap The Hyperlink field name format for .EAP repositories requires:
repositories e custom >
{<fieldname>.Hyperlink}
< custom

And the SQL uses: [<fieldname>-Hyperlink]:

e SELECT #Concat t_object.ca_guid, t_object.Name# AS
[BaseClassName-Hyperlink]
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FROM 't object, t connector

WHERE t_connector.Start Object ID = #OBJECTID#
AND t_object.Object ID =t connector.End Object 1D
AND t_connector.Connector Type = 'Generalization'

Notes

e An element Filter will not apply to the 'Custom' section in a Template Fragment

e In your SQL statements you can reference model details using:
- #OBJECTID# returns the ID of the element currently being processed by the document template
- #PACKAGEID# and #Package# return the ID of the Package currently being
processed by the document template
- #Author# takes the user name from the 'Author’ field in the 'General' page of the
'Preferences' dialog, so the defined search can be performed on objects created
by that user (this value can be manually re-set in the 'Preferences' dialog)

®  You can test your SQL Query using the SQL Editor in the Find in Project window
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How to Define a Custom Script Fragment

You can create a Template Fragment to return data from a Model Script. You do this by creating a Script that returns an
XML string in a specific format. You add a reference to this Script in the 'Template Fragment Document Options', then
add fields within the 'Custom' section of your Template Fragment that refer to the data returned by the Script.

Creating a Script Fragment

Step Action

1 Using the Scripting window, create a Model Script that returns a string in XML format.
See the examples of:
e A Script that returns data in the appropriate XML format (Example Template Fragment Script)

e The XML format that the Script must return so that it can be used by a Template Fragment (Example
Output of a Template Fragment Script)

2 Open or create a Template Fragment in the Document Template Editor.

Right-click on the Template background and click on the Iﬁlicon.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' tab and, in the 'Template Fragment type' panel, select the 'Custom Script'
option.

A blank field displays to the right of the options.

4 Click on the drop-down arrow and select your Script from the list.
5 In the main text field on the tab, type the entry point of your Script that returns the XML data.
For example, if you were using the example script mentioned in step 1, in JScript, then the entry point
would be:
MyRtfData(#OBJECTID#);

To convey Package information, you can replace #OBJECTID# with #PACKAGEID#. (Also, for
VBScript, omit the semi-colon at the end.)

This applies to the calling statement (not the script that is called), which can also reference:

e  #Branch# - gets the IDs of the child Packages of the current Package being processed, working
recursively down to the lowest level of sub-Package; this is only valid when processing a Package -
elements return a 0 value

e  #Package# - (as for #PACKAGEID) gets the package ID of the currently-selected Package

6 Click on the OK button to close the 'Document Options' dialog.

7 In the Document Template Editor, in the 'Sections' panel, select the 'Custom' checkbox to generate the
Custom section.

8 Within the 'Custom' section, right-click and select the 'Insert Custom Field' option.

A prompt displays for the name of the field to create.

9 In response to the prompt, type the name of the data field that is being returned by your script.

Referring to the example from step 1, you would add DateGen.
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Click on the OK button.

10 Repeat steps 8 and 9 for each data field that you want to include in your report.

Add any other formatting and content you need, to the Template Fragment.

11 Save the Template Fragment, and add it to a normal Document Template.

Notes

e Scripts have a limit of 60 seconds per call before control is returned to the Document Generator
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Example Template Fragment Script

This JScript returns a row of data in XML format. The XML data can be returned in a document report using a Custom
Script Template Fragment.

The script will also display the XML data in the System Output window, so you can easily check the output without
running a document report.

!'INC Local Scripts.EAConstants-JScript

/*

* Script Name: Document Properties

* Author: Tom O'Reilly

* Purpose: To display the properties of a document

* Date: 02/02/2013

*/

function MyRtfData(objectID)

{

var i;

var xmIDOM = new ActiveXObject("MSXML2.DOMDocument.4.0");
xmlDOM.validateOnParse = false;

xmlDOM.async = false;

var node = xmIDOM .createProcessingInstruction("xml", "version='1.0' encoding="ISO-8859-1"");
xmIDOM.appendChild(node);

var xmlRoot = xmIDOM.createElement("EADATA");
xmlDOM.appendChild(xmIRoot);

var xmlDataSet = xmIDOM.createElement("Dataset 0");
xmlRoot.appendChild(xmlDataSet);

var xmlData = xmIDOM.createElement("Data");
xmlDataSet.appendChild(xmlIData);

var xmlRow = xmIDOM.createElement("Row");
xmlData.appendChild(xmlRow);

var xmlName = xmIDOM .createElement("DateGen");
var today = new Date();

var dd = today.getDate();

var mm = today.getMonth()+1; //January is 0!

var yyyy = today.getFullYear();

if(dd<10){dd='0'+dd} if(mm<10){mm='0+mm} today = mm+'/+dd+"/+yyyy;
xmIName.text = today;
xmlRow.appendChild(xmIName);

var xmlName = xmIDOM.createElement(" TimeGen");
var currentTime = new Date()

var hours = currentTime.getHours()

var minutes = currentTime.getMinutes()
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if (minutes < 10)

{

minutes = "0" + minutes

H

xmlName.text = hours + ":" + minutes + " ";
xmlRow.appendChild(xmIName);

var xmlName = xmIDOM.createElement(" Author");
xmlIName.text = Session.UserName;
xmlRow.appendChild(xmIName);

var xmlName = xmlDOM .createElement("EA_REPOS");
xmlName.text = Repository.ConnectionString;
xmlRow.appendChild(xmIName);

return xmIDOM.xml;

15

Session.Output(MyRtfData(439));
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Example Output of a Template Fragment Script

You can create a Template Fragment to return data from a Model Script into a document report. The Script must return
one or more rows of data in this XML format:

<EADATA>
<Dataset 0>
<Data>
<Row>
<DateGen>09/01/2013</DateGen>
<TimeGen>9:31 </TimeGen>
<Author>John</Author>
<EA_REPOS>C:\Users\John\Documents\Sample Model.ecap</EA_REPOS>
</Row>
</Data>
</Dataset 0>

</EADATA>

Each of these data fields in the XML (such as 'DateGen', 'TimeGen') refers to fields that can be included in the 'Custom’
section of a Template Fragment.

Notes

e  Ifthe text is a formatted Note, add formatted="1" to the field row; for example:
<Author formatted="1"><i>John</i></Author>
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How to Define a Document Script Fragment

You can create a Template Fragment to return data from a Document Script. You do this by creating a Script that returns
either an empty string or a string that contains raw RTF. You add a reference to this Script in the "Template Fragment
Document Options', and the returned RTF string is added to the generated document.

An Example Script

This is an example of a Document Script you might create:

!'INC Local Scripts.EAConstants-JScript

function main()

{
var reporting as EA.DocumentGenerator;
reporting = CreateDocumentGenerator();
if(reporting != null)
{

if(reporting.NewDocument(""))

{

if(!reporting.LoadDocument("<filename>"))

{

Session.Output( "Error: " + reporting.GetLastError() );

}
return reporting.GetDocumentAsRTF();

Create a Document Script Fragment

Step Action

1 Open or create a Template Fragment in the Document Template Editor.

In the Document Template Editor, right-click on the Template background and click on the Iﬁlicon.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' page.
4 In the 'Template Fragment type' panel, select the 'Document Script' radio button.
5 A field displays to the right of the radio button panel; click on the drop-down arrow and select the Model

Script to be used by your Template Fragment.
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6 In the main text field on the tab, type the entry point of your Script that returns the RTF Text.
For example, in JScript, the call to your script would be in the form:
Main(#OBJECTID#);
(For VBScript, omit the semi-colon at the end.)

7 Click on the OK button to close the 'Document Options' dialog.

8 In the 'Document Template Editor', in the 'Sections' panel, select the 'Custom' checkbox to create the
'Custom' section.

9 Save the Template Fragment, and add a call to it in a normal document template.

When run, this will return an RTF string that is incorporated into the generated document.

Notes

e The Model Search macros #..# can be used in the call statement that calls the procedure, but not in the procedure
code; in your call statement you can reference model details using:

- #OBJECTID# to return the ID of the element currently being processed by the document template

- #PACKAGEID# and #Package# to return the ID of the Package currently being processed by the
document template

- #Branch# to get the IDs of the child Packages of the current Package being processed, working
recursively down to the lowest level of sub-Package; this is only valid when processing a Package,
elements return a 0 value
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How to Define a Custom XML Script Fragment

Within a template fragment, you can create a query to report values from an XML file produced by a
previously-generated script; for example, the data from a simulation. The query operates on static data that is not updated
during generation of the document.

An Example Query

This is an example of the query format:

Filename=<filepath>\<filename>.xml

XPath=/EADATA/Dataset 0/Data/Row

The first line is the location of the XML file to process, and the second line is the query to perform on that file, assuming
that the file content is:

<EADATA>
<Dataset 0>
<Data>
<Row Name="NameValue" Second="Value2"></Row>
<Row Name="NameValue2"></Row>
</Data>
</Dataset_0>
</EADATA>

You can then add fields within the 'Custom' section of your Template Fragment, to refer to the data returned by the
query. For example, you might edit:

custom >
[right-click-to-insert-Custom-field(s)]
< custom

to give:
custom >
Name - Second

< custom

Creating a Custom XML Script Fragment

Step Action

1 Using the Scripting window, create a Model Script that returns an XML file.

2 Open or create a Template Fragment in the Document Template Editor.

(c) Sparx Systems 2025 Page 100 of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

Right-click on the Template background and click on the Iﬁlicorl.
The 'Document Options' dialog displays.

3 Select the 'Custom Query' tab and, in the 'Template Fragment type' panel, select the 'Custom XML' option.
4 In the main text field on the tab, type the entry point of your Script that returns the XML data. For
example:

Filename=<filepath>\<filename>.xml
5 Click on the OK button to close the 'Document Options' dialog.

6 In the Document Template Editor, in the 'Sections' panel, select the 'Custom' checkbox to generate the
Custom section.

7 Within the 'Custom' section, right-click and select the 'Insert Custom Field' option.
A prompt displays for the name of the field to create.

8 In response to the prompt, type the name of the data field that is being returned by your script.
Click on the OK button.
9 Repeat steps 7 and 8 for each data field that you want to include in your report.

Add any other formatting and content you need, to the Template Fragment.

10 Save the Template Fragment, and add it to a normal Document Template.

Notes

e The calling statement (not the script that is called) can reference the ID of the element or Package currently being
processed by the document template, using the #OBJECTID# or #PACKAGEID# macros; for example,
MyRtfData(#OBJECTID#):

- #Branch# gets the IDs of the child Packages of the current Package being processed,
working recursively down to the lowest level of sub-Package; this is only valid when
processing a Package - elements return a 0 value

- #Package# gets the package ID of the currently-selected Package
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Adding Fragments to a Document Template

A Template Fragment is a template that can be used as a smaller sub-section of a normal document template. You do not
generate a report from a Template Fragment on its own; instead you use a normal template that includes references to
one or more Template Fragments.

Fragments can be called into these sections in the template:
e Package

e FElement

e  Attribute

e Method

They cannot be called into other sections. When generating a document report, as the report generator processes each
section in the template, if it encounters a reference to a Template Fragment it will process that Fragment, inserting its
output in the appropriate location of the generated report.

Access
Ribbon Publish > Model Reports > Templates
Keyboard Shortcuts F8 > Templates

Incorporating Template Fragments into a Document Template

Step Action

1 Create the Template Fragment(s) to be included in your document template, or identify system Template
Fragments to use.

2 Create a new document template, or open an existing template in the document editor.

3 In the 'Sections' panel, select the checkbox against each section that will refer to the Template Fragment(s)
("Package', 'Element’, 'Attribute' or 'Method").

4 In the 'Content' panel, at the appropriate point within one of these sections, right-click and select the
'Insert Template' option.
The 'Select Template' dialog displays.

5 Click on the drop-down arrow and select the Template Fragment to insert.

6 Click on the OK button.

The tag {Template - <template name>} is inserted at the current cursor position.

7 Repeat steps 4 to 6 for each Fragment you want to insert into the document template.

Complete any other work you need to do on the template, then save it and use it to run reports.
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Editing or Switching Template Fragments

Right-click on the red Template tag > <required option>.

Option Action

View / Edit Fragment Opens the selected Template Fragment in another instance of the Document
Template editor.

If you have selected a System Fragment, you can view the Fragment but not edit it.
If you have selected a Model (user-created) Fragment, you can edit the Fragment.

Override Fragment (Option available for a selected System Fragment)

Opens another instance of the Document Template Editor, where the System
Fragment is duplicated as a Model (user created) Fragment with the same name.
You can edit this Fragment and save it, and the original template will apply that
new Model fragment instead.

Switch Fragment Displays the 'Select Template' dialog; click on the drop-down arrow and select a
different Template Fragment.

Notes

e You can also add a Template Fragment to a document template by locating the Fragment in the Document
Publishing folder in the 'Resources' tab of the Browser window and dragging the Fragment into the Document
Editor; Template Fragments are held in the Fragments folders within the System Templates and Custom Templates
folders

e To delete a Template Fragment from a Template, drag the cursor along the inserted name to highlight it, then press
the Delete key

e [tis possible to embed a Template Fragment within another Fragment; however, this will slow down report
generation
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Editing Documents and Templates

Within Enterprise Architect you can create various documents from templates, and you can create customized templates
to help tailor the documents to the needs and standards of your organization. You can create Linked Documents, Linked
Document Templates and Document (Report) Templates, amongst others. In each case, selecting to create or edit the
document opens the Document-Edit ribbon, which provides a wide range of editing and formatting facilities that you can
use to develop your documentation. This section explains how to perform various editing tasks using the ribbon.

Each type of document can also have its own context menu of additional options, and the editing window might also
have an option toolbar. These facilities are described in the topics specific to the type of document.

Access

Ribbon Create or edit a document or template file; the Document - Edit ribbon displays
automatically

Option Descriptions

The descriptions of the Document - Edit ribbon options are grouped according to the actions you are performing.

Actions

Creating and importing documents

Configuring the editor page display and formatting tools shown
Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and repaginating

Incorporating stylesheets, special texts and Tables of Contents

Managing the base styles in the Normal.rtf style template file

Inserting and editing page headers and footers, and footnotes and endnotes
Inserting tables

Inserting hyperlinks

Inserting images, OLE objects, frames and drawing objects
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Printer set up and printing documents

Checking spelling and use of words

Tracking, accepting and rejecting changes to text
Protecting document text from accidental change

Create and refer to definitions of Glossary terms in the Project Glossary (using the 'Create | Glossary Definition'
menu option)

Notes

e  Throughout your document editing:
- To undo one or more immediately previous edits, press Ctrl+Z, or select the 'Undo' context menu
option; you can still undo a change even after you have saved the change
- To redo one or more immediately previous undone edits, press Ctrl+Y, or select the 'Redo’
context menu option
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File Control

The 'File' panel of the 'Document Edit' ribbon provides a number of options for changing and saving a document report
file contents as a complete file as well as for setting page layout options, such as margins, and for printing the document.

Access

Ribbon Document-Edit > File > File > [options]

File control options

To Action

Import a file Select the option 'Document-Edit > File > File > Import File'. This imports the
contents of an existing document into the current file. The file type in the dialog
defaults to .rtf, but you can import files in a number of other formats. Click on the
drop-down arrow and select the required file type.

The 'Import File' option is useful when creating documents from existing
documents external to Enterprise Architect, such as your own corporate standards
templates and, in conjunction with the '"New' option, of updating the document from
the external file.

Export a Document file Select the option 'Document-Edit > File > File > Save As (Export to File)'. This
saves your document to an external document file.

The "Export' option is useful for saving a specific template or document to be
imported into another project.

Clear a file for redesign Select the option 'Document-Edit > File > File > New (Clear Document)'. This
clears the existing contents of the document.

If you have made any unsaved changes to the file, the editor prompts you to save
them. If you want to protect those changes, click on the Yes button to display a
browser screen and select a file path and file name to save the changes to.

This is a method of clearing out an existing document for redesign. As you do not
change the name, all references to it simply go to the changed content.

Roll back changes to Select the option 'Document-Edit > File > File > Reload from Repository' to roll

previous version back the file contents to the previously-saved version.

Save changes Select the 'Document-Edit > File > Save' icon to save the file contents to the current
file.

Save Template Applicable to the Document Template Designer and Linked Document template
editor.

The key combination Ctrl+Shift+S invokes the 'Save As' command to save a
template contents under a new name, which you are prompted to type in. This
command is not available when editing a document - see 'Export a Document file'
instead.
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Close the file and editor Click on the cross at the right of the document tab or in the top right corner of the
Document Window.

Print options

When you are editing a document or template, you can manage print jobs within the Document Editor. You can select
from options to define the page layout, text to be printed and number of copies, and to check the appearance of the
printing before actually submitting the print job.

To Action

Set the page margins for Select the option 'Document-Edit > File > File > Page Layout'.

viewing and printing the The 'Page Parameters' dialog displays, on which you can define the left, right, top

document and bottom page margins in inches.
The 'Top' and 'Bottom' margins define how much space is set aside to contain
header and footer text.
In the 'Header distance from the Page Top' and 'Footer distance from the Page
Bottom' fields, type the separation of the header and footer text from the edge of the
paper.

Set the parameters for the Select the option 'Document-Edit > File > File > Printer Setup', or press

print run Ctrl+Shift+P.
The 'Setup Page' dialog displays for the default printer, which you would have
selected on the Windows 'Control' panel.
You can simply confirm or reselect the core parameters such as page size, paper
source and page orientation, or click on the Properties button to define more
advanced settings such as use of a watermark, duplex printing and print resolution.

Print your document Select the option 'Document-Edit > File > File > Print Preview', or press Ctrl+P.
The 'Print’ dialog displays, on which you can select the pages to print and the
number of copies, and initiate the print task.
You can also choose to print only a selected part of the file. To do this, highlight
the required text before selecting the 'Print' option. You can print a highlighted
block of:
e Lines, or
e  Characters

Preview document before Select the option 'Document-Edit > File > File > Print Preview' to display the

printing document as it would appear when printed.

The editor displays either one page or two - toggle the display by clicking on the
One Page button or Two Pages button. Scroll to further pages using the scroll bar.

By default the preview rectangle is sized to fit the current window; you can use the
'Fitted' field to enlarge or shrink the size of the displayed pages as required.

Click on the Print button to display and use the 'Print' dialog.

To return to editing mode click on the Edit button, or on the 'Document-Edit > File
> File > Print Preview' menu option again.
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Editor Display Options

Within the Document Editor, to help you edit the document contents you can configure the page display and the
formatting tools visible, using the 'View' menu options in the 'File' panel of the 'Document-Edit' ribbon.

Access

Ribbon Document-Edit > File > View > [options]

Editing tools and options

Menu Option Action

Page Layout Mode Select the option 'Document-Edit > File > View > Page Layout Mode'. Toggles the
text display between page layout and full window layout.

Borderless Mode Select the option 'Document-Edit > File > View > Borderless Mode'. Toggles the
display of page borders, allowing the document to occupy the entire display area.

Horizontal Ruler Select the option 'Document-Edit > File > View > Horizontal Ruler'. Displays or
hides the ruler at the top of the page.

The ruler shows tab stops and paragraph indentation marks; you can also use it to
create or delete tab stops.

Vertical Ruler Select the option 'Document-Edit > File > View > Vertical Ruler'. Displays or hides
the ruler against the left edge of the page.

The ruler indicates the depth of the top and bottom margins of the page.

Status Ribbon Select the option 'Document-Edit > File > View > Status Ribbon'. Displays or hides
the status ribbon at the bottom of the editing panel.

The status ribbon displays the current page number, line number and column
number; it also indicates the current insert/overtype mode (at the left end of the
ribbon).

Hidden Text Select the option 'Document-Edit > File > View > Status Ribbon'. Shows or hides
'hidden' text.

Text formatted with the 'Hidden' option is shown with a dotted underline; when the
'Hidden Text' option is turned off, the hidden text is not visible and the normal text
closes up to single character or line spacing.

Field Names Select the option 'Document-Edit > File > View > Field Names'.
Applicable to all document editing:

If you have inserted any data fields and values, the 'Field Names' option toggles
between displaying field names in the text and displaying the field values.

Applicable to the Document Template Designer:

As you develop your custom document template, you right-click on sections to
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insert field markers and select the 'Insert Fields' option. The 'Field Names' option
makes the 'Insert Fields' option available.

Hyperlink Cursor Select the option 'Document-Edit > File > View > Hyperlink Cursor'.

Applicable to the Document Template Designer and Linked Document Template
Editor:

Toggles the cursor icon when you 'mouse over' a hyperlink, between your default
image (usually a line or arrow) and a 'pointing hand'.

Page Header/Footer Select the option 'Document-Edit > File > View > Page Header/Footer'. Displays or
hides the text of page headers and footers.

To edit the header or footer text, select the option 'Document-Edit > Edit > Edit >
Page Header/Footer'.

Zoom Select the option 'Document-Edit > File > Fixed Zoom'. A short menu displays,
from which you can select from a range (10% to 200%) of percentages of normal
size by which to shrink or enlarge the display of the document content. The menu
also has a 'Custom' option that you can select to display the 'Zoom Parameter'
dialog, on which you define the percentage you need, between 10% and 500%.
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Styles, Special Text and Table of Contents

Using the Document Editor, you can define character-based styles and paragraph-based styles.
e A character style constitutes a set of character formatting attributes and is applied to a character string

e A paragraph style constitutes both a set of character formatting attributes and a set of paragraph formatting
attributes, and is applied to one or more paragraphs

You can also include special, structured text in the document, such as page number, date and time, table of contents and
text input fields.

Every custom template or document you create is automatically based on the Normal.rtf template file. This provides
default styles, numbering and other base formats, which you can change using the Document Editor facilities and save
either as a specific document, template or document report Stylesheet.

Access

Ribbon Select options from the 'Document Edit' ribbon bar.

Editing Styles

To Action

Create and edit styles Select the option 'Document-Edit > Edit > Edit > Edit Style'. The 'Edit Stylesheet'
dialog displays.
Select the appropriate radio button to define a paragraph style or a character style.

If you want to update an existing style, select that style from the list box. If you
want to create a new style, select the 'Create a new style' checkbox, and type a name
in the 'Style Name' field. Short style names are best, but you can type in long names
if necessary.

To begin defining the style properties, click on the OK button.

You can use the ruler, toolbar or context menu selections to modify the style
properties; for an existing stylesheet item, these also reflect the currently-selected
properties.

After you have defined the required style, you set it by either selecting the
'Document-Edit > Edit > Edit > Edit Style' menu option again or clicking anywhere
in the document:

e If you modified an existing stylesheet item, the document automatically
reflects the updated style

e Ifyou created a new stylesheet item, you can apply the style to highlighted text
by selecting the 'Document-Edit > Font > Font > Style' or 'Document-Edit >
Paragraph > Paragraph > Style' ribbon options

Update the standard styles Right-click on the document and select 'Update Styles > [select Stylesheet to
used update]'

e Re-import the standard styles from Normal.rtf, into the current document, or
e  Apply one of the system-supplied standard Stylesheets to the document

A submenu displays from which you select the appropriate style source.
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This is useful for maintaining consistency of styles across all your documents,
including such things as numbering formats.

Edit the hyperlink style This option operates specifically on the style of any hyperlinks you want to create.

Select the option 'Document-Edit > Font > Font > Hyperlink', then select the font,
font size and emphasis (bold, italic) you want to apply. You cannot remove the
hyperlink underline or change the color from blue.

Select the option 'Document-Edit > Font > Font > Hyperlink' again to set the style.

When you create a hyperlink from this point onwards, the link text will be in the
style you have set. Links created before you changed the style remain in the earlier
style.

Apply character styles Highlight the text to be styled and select the option 'Document-Edit > Font > Font >
Style'; the 'Select a Style' dialog displays, from which you select the character style
to apply.

Alternatively, select a character style from the drop-down list in the 'Font' panel of
the 'Document-Edit' ribbon.

Apply paragraph styles Highlight the text to be styled and select the option 'Document-Edit > Paragraph >
Paragraph > Style'; the 'Select a Style' dialog displays, from which you select the
paragraph style to apply.

Alternatively, select a paragraph style from the drop-down list in the 'Font' panel of
the 'Document-Edit' ribbon.

Clear unused lists from the Select the option 'Document-Edit > File > Manage > Remove Unused Lists'.

template or document The system prompts you to confirm removal of the lists when the file is saved.

Click on the Yes button.

When you have list formats such as for bullet or numbered lists in the file, and you
have reversed or otherwise not used them, the formatting instructions for applying
these lists to the text remain in the file. You can see this when you set up the list
and then toggle the bullets or numbering on and off.

If you select the 'Remove Unused Lists' option, when you save the file the unused
format instructions are removed from the file, reducing the number of list formats
maintained in the file and reducing file size.

Insert date and time fields At the point in the text at which to insert the current date and/or time field, select
the option 'Document-Edit > Edit > Insert > Date and Time'.

The 'Insert Current Date/Time' dialog displays, from which you can select the
required date and time format. You can insert the date or time fields separately, or
as a combined field.

The date and time are automatically updated whenever the page text is refreshed
(that is, clicked on).

Insert a table of contents Edit the 'Table of Contents' level styles (TOC 1 to TOC 9) as required, using the
option 'Document-Edit > Edit > Edit > Edit Style'. Add at least one 'Heading n' style
to the document.

Move the cursor to the point at which to insert the Table of Contents, and select the
option 'Document-Edit > Edit > Insert > Table of Contents'. A small dialog displays
in which you specify the highest and lowest Table of Contents levels to apply in the
table in this document; when you have specified the levels, click on the OK button.
If there are corresponding headings within the specified range, the Table of
Contents displays; otherwise, the line remains blank.

To create a Table of Contents heading that displays in the generated document, type
the appropriate text at least one line above the inserted list and define the style as
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required - use a Heading style to include the heading itself in the Table of Contents,
otherwise use a non-heading style.

The Table of Contents is automatically generated and updated whenever generation
or repagination occurs.

Move the cursor to the point at which to insert the data field and select the option
'Document-Edit > Edit > Insert > Data Field' menu option.

The 'Data Field Parameters' dialog displays, in which you enter the field name and
the data value. Wherever you insert the data field, the values are automatically
updated with the most recent data value you enter.

You insert text entry fields so that anyone using the document can type in their own
text in response to either a lead-in sentence or the field name itself.

Move the cursor to the point at which to insert the text entry field and type in any
lead-in text you want to use. Then select the option 'Document-Edit > Edit > Insert
> Text Input Field'.

The 'Input Field Parameters' dialog displays, in which you enter:
e The field name

e The initial value to display as a default

e  The maximum length of the field

e The text font in which to display the text

You can also specify whether or not the field has a border.

Hello |Type your name here|

For example:

If you insert a text entry field in a template, any document generated from the
template shows the typed entry as normal text, not boxed.

You insert checkboxes in a document so that the users of the document can mark
the item represented by the box. The checkbox can be selected and deselected in a
document, a template and a document generated from a template.

Move the cursor to the point at which to insert the checkbox and select the option
'Document-Edit > Edit > Insert > Checkbox Field'.

The 'Checkbox Field Parameters' dialog displays, in which you enter:
e The field name (which does not display in the text)

e Whether the checkbox defaults to selected

e The size of the checkbox

Click on the OK button.

You insert selection fields in a document so that the users of the document can
select one of the items presented in a drop-down list.

Move the cursor to the point at which to insert the checkbox and select the option
'Document-Edit > Edit > Insert > Selection Field'.

The 'Selection Field Parameters' dialog displays, in which you enter:

e The field name

e The options to present in the drop-down list (separated by the | character)
e The value from this list to display as a default

Click on the OK button.

Move the cursor to the point at which to insert the non-breaking space and select
the 'Insert | Non-breaking Space' menu option.
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Insert a non-breaking dash Move the cursor to the point at which to insert the non-breaking dash and select the
'Insert | Non-breaking Dash' menu option.

Insert an optional hyphen Move the cursor to the point at which to insert the hyphen and select the 'Insert |
Optional Hyphen' menu option.

Insert a Project Constant (For Document Report templates.)

You can create Project Constants to insert a specific text string wherever you place
the flag for that string. You can therefore design a report containing many instances
of that string, but create and edit the actual value in one place - on the 'Project
Constants' tab of the 'Generate Report' dialog.

Right-click at the point at which you want to insert the Constant (flag), and select
the 'Project Constants | <flag name>' option. The Constant displays at that point in
the template, and when the report is generated the flag is replaced by its defined
value.

You can insert a Project Constant anywhere in the template - in the text body,
section headings, headers, footers, endnotes or footnotes. Project Constants are
available to any template in the model.

Define level numbering in (Used in the Document Template Editor.)
generated document Select the option 'Document-Edit > Edit > Edit > Lists and Overrides'.
Set up the numbering list and the list overrides.

Apply the numbering list to the headings set for Packages and elements, using
paragraph numbering.

Use double-byte characters Select the option 'Document-Edit > Edit > Edit > Inline Ime’'.

Double-byte characters are, broadly, complex characters used in languages such as
Japanese, Chinese, and Cyrillic.

With this menu option, you can use both single-byte characters and double-byte
characters in your text, without having to switch to an external Input Method Editor
(IME) application.
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Manage Page Counting

As you set up the document structure, especially if you divide the document up into sections, you can insert page counts,
insert and reset page numbers, and repaginate the document to update the page number, page count and Table of
Contents.

Access

Ribbon Document-Edit > Edit > Insert > Page Number
Document-Edit > Edit > Insert > Page Count

Document-Edit > Edit > Edit > Repaginate

Insert the page number

Position the cursor at the point at which to display the page number, and select the option 'Document-Edit > Edit > Insert
> Page Number'.

The page number is displayed in gray.

Insert the page count

Position the cursor at the point at which to display the total number of pages in the document, and select the option
'Document-Edit > Edit > Insert > Page Count'. The page count is displayed in gray.

Repaginate the document

Select the option 'Document-Edit > Edit > Edit > Repaginate'.
The 'Page Number' and 'Page Count' fields and the Table of Contents are all updated.
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The Normal.rtf Style Template

Every custom template or document you create is automatically based on the 'Normal.rtf template' file. This is an
external file that provides default styles, numbering and other base formats, such as the default list numbering,
MasterList. You can edit the Normal.rtf file to apply your own default styles to the documents and templates you create.
You also have the options of:

e Editing selected styles within a template, so that reports or documents created from that template always have those
different styles

e  Using the standard Stylesheets or creating custom Stylesheets, to optionally apply to any document report you
generate independent of the template you are using

The Normal.rtf template is stored in %APPDATA%\Sparx Systems\EA\RTF Templates.

Edit Normal.rtf

Step Action

1 Open the Document Template Designer and create a new template called, for example, Normal.

2 Select the 'Document-Edit > File > File > Import File' menu option to import the Normal.rtf file into the
Normal template.

3 Modify the Normal template style definitions as you want, and remove any text before you save the
template.
4 Export the modified template ('Document-Edit > File > File > Save As (Export to File))' back into the

Normal.rtf file in the RTF Templates folder. The modified styles will be applied to all documents and
templates you create from now on.

Notes

®  You must not edit the SSbookmark style; this defines the section styles and must be preserved

e A related feature in the Document Editor is the 'Update Styles' context menu option, which you select to update an
existing template to reflect any changes to Normal.rtf, or to apply a standard Stylesheet to the template
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Scroll, Search and Select Text

In the Document Editor, you can move the cursor through the template or document using either the keyboard or the
mouse. Alternatively, you could move the cursor to a position in the file by searching for a text string.

Having positioned the cursor on the required text, you can then highlight and manipulate it with various options, in
addition to the standard 'mouse-click-and-drag' and the 'Ctrl+X', 'Ctrl+C' and 'Ctrl+V' keys.

Cursor Positioning

Scroll Using Options

Keyboard Keys Press:
e  Ctrl+Left Arrow to move to the previous word
e Ctrl+Right Arrow to move to the next word

e  Ctrl+Up Arrow to move to the first column of the current line (if not already on
the first column) or the first column of the previous line

e Ctrl+Down Arrow to move to the first column of the next line

e F10 to display the 'Jump to line number' dialog; type in a line number to jump
to, and click on the OK button

Mouse To perform various scrolling functions, click on the vertical or horizontal scroll
bars. These functions are available when the scroll bars have been enabled by the
startup parameters.

Vertical Scroll Bar: To scroll the screen up or down by one line, click on the
arrows on either end.

To scroll the screen up by one page, click above the elevator (the block within the
scroll bar); similarly, to scroll the screen down by one page, click below the
elevator.

You can also scroll the screen up or down by dragging the elevator in the
appropriate direction.

Horizontal Scroll Bar: To scroll the screen left or right by one column, click on
the arrow on the appropriate end of the bar; to scroll the screen left or right by half
a screen, click on the bar on the appropriate side of the elevator.

You can also scroll the screen left or right by dragging the elevator along the bar in
the appropriate direction.

Text Search

When you search for a text string, the dialog for specifying the search details does not persist on the screen, so you can
simply use keyboard keys or a menu option to continue the search without obscuring text behind a dialog.

To Action
Find first instance of a text Select the option 'Document-Edit > Edit > Search > Search’, or press F5.
string The 'Search String Parameters' dialog displays. Specify:

e  The term to search for

e  Whether to search from the start of the file or forwards or backwards from the
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current cursor position, and
e Whether the search should exactly match the case of the search term

The editor searches for the first instance of the specified character string as defined
by the parameters.

Select the option 'Document-Edit > Edit > Search > Search Forward', or press
Ctrl+F.

The editor searches forwards through the file for the next instance of the previously
specified text string, and highlights it.

Select the option 'Document-Edit > Edit > Search > Search Backward', or press
Ctrl+Shift+F.

The editor searches backwards through the file for the next instance of the
previously specified text string, and highlights it.

Select the option 'Document-Edit > Edit > Search > Replace', or press F6.
The 'Replace String Parameters' dialog displays, in which you specify:

e The text string to locate

e The text string to replace it with

e Whether to search the whole document or just a highlighted block of text
e Whether to confirm each replacement before making the change

If you want to confirm replacement, a prompt displays for each occurrence of the
search term to confirm or skip replacing that occurrence.

Action

Double-click on the word.
Move the cursor onto the line and press F8.
Press Shift+F9 to delete the current line; the remaining lines close up.

Select the option 'Document-Edit > Edit > Edit > Paste Special'; the 'Paste Special'
dialog displays, listing the appropriate data type formats for inserting the copied
object.

Click on the Paste button to embed the data into your application, or click on the
Paste Link button to create a link to the original file.

e 'Native Object Format' - If available, this is the first format in the list box; you
can edit data in this format using the original application, by double-clicking
the object

e 'Formatted Text' - A text format; this option offers the most suitable format if
the data is pasted from another text output application, as the font and
formatting attributes are reproduced accurately

e 'Unformatted Text' - Another text format; this option pastes the text without
retaining the formatting information

e 'Picture Format' - The data is available in Picture format; you can later edit the
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object, by double-clicking on it and invoking the Microsoft MS Draw
application

This format is preferable to the Bitmap and the Device Independent Bitmap
formats

e 'Device Independent Bitmap' and 'Regular Bitmap' formats - The data is
available in bitmap formats; you can later edit the object, by double-clicking on
it and invoking the Microsoft MS Draw application
The editor converts these formats into the Picture format before calling the
drawing application
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Format Text

When you create a document template or document, the default character or text styles are already defined, as they are
derived directly from the Normal.rtf style template file. Within the document you can edit any of these character styles or

apply individual formatting to text strings as you require.

When you change the format of existing text, any new characters you type immediately after that text automatically
assume the formatting characteristics you have applied.

Access

Ribbon Highlight the text to which to apply the format, then select options from the 'Font'
panel of the 'Document-Edit' ribbon bar.

Text formatting options

To Action

Apply character format Highlight the text to which to apply the format, and use one or more of these menu
options or key combinations.

From the 'Font' panel of the 'Document-Edit' ribbon, choose:

° or 'Font | Normal', or press Alt+0

Aal
o/
° B o 'Font | Bold', or press Ctrl+B
£ o1 'Font | Italic', or press Ctrl+I
g or 'Font | Underline', or press Ctrl+U
o U~ | 'Double Underline', or 'Font | Double Underline', or press Ctrl+D
e % or'Font | Subscript', or press Alt+5
e * or'Font | Superscript', or press Alt+4
o ¢ o 'Font | Strike', or press Alt+6 (puts a line through the text)
o e | 'Double Strike', or 'Font | Double Strike'

Aa

| lowercase

e AaT |UPPERCASE
e Font| All Caps
e Font| Small Caps

23l
To reset any character format, highlight the text and select the option “ or 'Font |
Normal', or press Alt+0.

Change font typeface and Highlight the text to change and select the required typeface from the 'Font'
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point size drop-down list in the 'Font' panel of the 'Document-Edit' ribbon bar. Select the
required point size from the 'Size' drop-down list, beside the 'Font' list.

Alternatively, select the option 'Document-Edit > Font > Font > Fonts'. The 'Font
Selection' dialog displays, from which you select the required typeface and point
size. Click on the OK button.

Change character style Highlight the text to change and select the required character style from the 'Style’
drop-down list in the Font' panel of the 'Document-Edit' ribbon bar.

Alternatively, select the option 'Document-Edit > Font > Font > Style'.

The 'Select a Style' dialog displays, listing the currently-defined character styles in
the template stylesheet. Select the required style and click on the OK button.

Change the color of text, Highlight the text to change and select one or more of these options, as required:
background (permanent A
highlight) or underline e Document-Edit > Font > ==

ab® _

e  Document-Edit > Font >

e  Document-Edit > Font > o-. Underline Color
In each case, the 'Color’ dialog displays, through which you can select or define the
required color.

When you have selected a color, click on the OK button.

Change character spacing Normal character spacing (the space between characters) is 20 twips; if you want to
change this (or return to it), highlight the text to adjust, and select the option
'Document-Edit > Font > Font > Spacing'. The 'Character Spacing' dialog displays.

Select the radio button to expand or compress spacing, or to return to normal
spacing; if you are changing from normal spacing, enter the number of twips to set
the spacing to.

Click on the OK button.

Change horizontal scaling Highlight the text to change and select the option 'Document-Edit > Font > Font >
Horizontal Scaling'.

The 'Horizontal Character Scaling' dialog displays. Enter a percentage value for the
amount of scaling required (valid values are 10 to 999 inclusive), then click on the
OK button. The text (both characters and spaces) is scaled horizontally, by the
specified amount.

Hide text Hidden text is not displayed on the screen or printer, but remains in the document
and is not deleted.

Highlight the text to hide and select the option 'Document-Edit > Font > Font >
Hidden', or press Ctrl+H.

The highlighted text is not displayed and the rest of the text closes up.

To view hidden text, select the option 'Document-Edit > File > View > Hidden
Text'; you can then make the text normal again by highlighting it and deselecting
the option 'Document-Edit > Font > Font > Hidden'.

Create a box around text Highlight the text to box and select the 'Font | Boxed' menu option; this creates a
broken-line border around the selected text.

Protect text Highlight the line, block or section of text to be protected, and select the option

'Document-Edit > Font > Font > Protect'.

The selected text is displayed in a gray font, and cannot be edited.
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To release the text for editing again, highlight it and reselect the option
'Document-Edit > Font > Font > Protect'.

You can select and release a portion of the protected text; the remainder stays
protected.

Note: If the ribbon option is unavailable, or the text is not faded, it means that you
have not removed the protection lock. (See Protect Document Contents.)
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Create Tables

Within any document report, you can present information using simple tables with any number of rows and columns. In a
report template, it is also possible to render a model section as a table, defined with any number of columns but with only
two rows. You can either add your own text to the tables, or populate the table cells with fields that extract information
from your model.

Access

Ribbon Document-Edit > Paragraph > Table > [option]

Create and format a table

To Action
Insert a table in the Position the cursor on the point in the text to create the table, and select the option
document 'Document-Edit > Paragraph > Table > Insert Table'.

The New Table Parameters' dialog displays, in which you specify the number of
table rows and columns. For a model section table in a report template you can
accept the default values of two rows and three columns. Click on the OK button.

Your table might be invisible; if so, select the option 'Document-Edit > Paragraph >
Table > Show Gridlines' to reveal the table and cell borders in dotted lines. These
lines are for guidance in creating the document, and do not display on the printed
document. You can add printable borders using other context menu options.

The editor initially creates a table with cells of equal width across the page; you can
change the cell width by dragging the cell borders using the mouse, or using other
context menu options.

Insert a new row above the Click on a row and then select the option 'Document-Edit > Paragraph > Table >
current row Insert Row'.

Insert a new column to the Click on a column and then select the option 'Document-Edit > Paragraph > Table
left of the current column > Insert Column'.

Merge cells Highlight the cells to merge and select the option 'Document-Edit > Paragraph >

Table > Merge Cells'.

The width and/or height of the resulting cell is the sum of the widths and/or the sum
of the heights of the merged cells.

You can merge cells across a row, down a column, and in a block spanning both
rows and columns.

Split a cell Select the cell to split and select the option:

e 'Document-Edit > Paragraph > Table > Split Cell Horizontally' to split the
selected cell into two cells of equal width within the column

e 'Document-Edit > Paragraph > Table > Split Cell Vertically' to split the cell
into two cells of equal height, doubling the height of the whole row

Any text in the original cell is assigned to the first cell, and the second cell is
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created empty.

Delete cells Select the cells to delete and select the option 'Document-Edit > Paragraph > Table
> Delete Cells'.

The 'Delete Table Cells' dialog displays, on which you specify whether to delete:

e  Cells - deletes the highlighted cells; realign the column and/or row after doing
this

e  Columns - deletes the column or columns containing the highlighted cells, or

e Rows - deletes the row or rows containing the highlighted cells

If you delete all cells in a table, the table itself is automatically deleted.

Position the table on the Click on any part of the table and select the option 'Document-Edit > Paragraph >
page Table > Row Position'.

The 'Table Row Alignment' dialog displays, on which you select a radio button to
left-justify, center or right-justify the table on the page.

Leave the 'All Rows in the Table' checkbox selected.

This menu option has greater effect if the table is narrower than the page or text

column.
Set the height of a row, or Highlight the rows to adjust and select the option 'Document-Edit > Paragraph >
all rows Table > Row Height'.

The 'Row Height Parameters' dialog displays; you can select to:
e  Allow the row height to be determined automatically

e  Set a minimum row height, or

e Set an exact row height

If you are setting the height, type the value in twips.

You can apply the setting to the selected rows only, or select the 'Apply to all rows
in the current table' checkbox to set the height of all rows in the table.

Add a header row Select the top row of the table, and then select the option 'Document-Edit >
Paragraph > Table > Header Row'. Apply any heading text, settings and formatting
to the highlighted row.

In the document or compiled report, the heading row is repeated at the top of the
columns each time the table flows on to a new page. In a report, if the heading row
is populated with the values from field names, the heading rows on subsequent
pages reflect the values from that first row.

This option operates on the single row at the top of the table, and not on multiple
rows. If you edit the table and add a row to the top of the table to act as a new
header, selecting the menu option on the new row clears the previous setting.

Keep row text together if it Select the rows to protect (preferably all rows in the table) and select the option
continues over a page 'Document-Edit > Paragraph > Table > Keep Row Together'.
If the row continues over the end of the page, the whole row is moved to the top of
the next page.
Set the text flow in the Select the rows and select the option 'Document-Edit > Paragraph > Table > Row
table rows Text Flow'.

The 'Table Text Flow' dialog displays, on which you select a radio button to set the
text flow in the rows to:

e Left toright
e Right to left

(c) Sparx Systems 2025 Page 123 of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

e Default

You can apply the text flow to just the selected rows, or select the 'Apply to all
rows in the current table' checkbox to set the text flow for all rows in the table.

This option also moves the selected rows over to the appropriate side of the page or

column.
Set the width of selected Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
cells > Cell Width'".

The 'Set Cell Width' dialog displays, on which you set the width of the cells and the
margin between the text and the left and right sides of each cell, both in twips. You
can apply the settings to:

e All cells in the table
e The selected cells only
e The complete column or columns containing the selected cells, or

e  The complete row or rows containing the selected cells

Define the width of the cell Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
borders > Cell Border Width'.

The 'Set Cell Border' dialog displays, on which you set the width of the lines at any
or all of the top, bottom, left and right of the selected cells. If you want the border
to enclose:

e The selected cells as a block, select the 'Draw outline border around the
selected cells' checkbox

e Each selected cell separately, leave the checkbox unselected

You can also set the margin between the text in each cell and the left and right
borders, in twips, and apply all the settings to:

e All cells in the table
e The selected cells only
e The complete column or columns containing the selected cells, or

e The complete row or rows containing the selected cells

Define the color of the cell Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
borders > Cell Border Color'".

The 'Set Cell Border Color' dialog displays, on which you set the color of each of
the lines at the top, bottom, left and right of a cell, or all of the cell borders at once.

You can apply the settings to:

e All cells in the table

e The selected cells only

e The complete column or columns containing the selected cells, or

e The complete row or rows containing the selected cells

Define the degree of Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
shading on the cell color > Cell Shading'.

The 'Cell Shading Parameters' dialog displays, in which you type the shading
percentage.

Shading is the intensity of the cell background color, expressed as a percentage, and
is uniform across the selected cells. If the cells have no colored background, a
shading of 0% is white. For colored backgrounds, 0% is the color initially set. In all
cases, a shading of 100% is black.

You can apply the setting to:
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e  All cells in the table
e The selected cells only
e The complete column or columns containing the selected cells, or

e The complete row or rows containing the selected cells

Define the background Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
color of the cell > Cell Color'.

The 'Cell Color Parameters' dialog displays. Click on the Set Color button to
display the 'Color' dialog, on which you select a basic color or define a more
specific color.

When you have selected the color, click on the OK button.

You can apply the setting to:

e  All cells in the table

e  The selected cells only

e The complete column or columns containing the selected cells, or

e The complete row or rows containing the selected cells

Vertically align text in cells Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Vertical Align'.

The 'Cell Vertical Alignment' dialog displays, on which you select to align the text
in the selected cells by the top, center or bottom of the cell or the baseline of the
lowest top line of text.

Text in a table defaults to being aligned with the top of the cell and, as you type it
in, it scrolls downwards. You can change this alignment to the center or bottom of
the cell so that text scrolls out from the center or up from the bottom of the cell.

If you have special formatting - such as 'before-paragraph' spacing - you can align
the text to the base of the lowest first line (the baseline), so that text in a row of
cells is aligned with the special formatted text rather than with the top or bottom of
the cell. If the special formatting is changed or removed, the text remains aligned.

You can apply the setting to:

e  All cells in the table

e  The selected cells only

e The complete column or columns containing the selected cells, or

e The complete row or rows containing the selected cells

Rotate the text of a cell to Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
display vertically > Cell Rotate Text'.

The 'Cell Text Rotation' dialog displays, on which you select to display text
vertically up the cell, vertically down the cell or, if the text is already vertical,
horizontally across the cell,

Text in a table defaults to running horizontally across the cell from left to right, and
scrolling down the cell from top to bottom. You can change the text position so that
the text is rotated through 90 degrees to display:

e From top to bottom, scrolling across the cell from right to left, or
e From bottom to top, scrolling across the cell from left to right

If the text is running horizontally, you can type as much as you need - the row
height increases to accommodate the text. If the text is running vertically, you
adjust the row height and column width manually to accommodate your text.

You can apply the setting to:
e All cells in the table
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e The selected cells only
e  The complete column or columns containing the selected cells, or

e  The complete row or rows containing the selected cells
Select a column Click on a cell and select the option 'Document-Edit > Paragraph > Table > Select
Current Column'.

The whole column is highlighted and selected for further formatting.

Show gridlines Show or hide grid lines for the current table. Note that, for printing purposes,
'Border Width' must be set to a non-zero value.

Notes

e Under some circumstances, a table in a generated report might repeat the header row rather than the output row; if
this occurs, create another row in the table between the header row and the output row, and leave this blank
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Format Paragraphs

When you create a document template or document the default paragraph styles are already defined, as they are derived
directly from the Normal.rtf style template file. Within the document you can edit any of these paragraph styles or apply
individual formatting to text blocks as you need.

Each formatting option operates on the current paragraph, or on a highlighted block of text.

Access

Ribbon

Document-Edit > Paragraph > Paragraph > [options]

There is also a range of icons in the 'Paragraph’ panel of the 'Document-Edit'
ribbon, that provide direct access to commonly used paragraph formatting options

Paragraph formatting options

To

Clear all paragraph
formatting

Center text
Right-justify text
Justify both sides of text

Double Space

Indent paragraph left

Indent paragraph right

Create hanging indent

Keep paragraph lines
together

(c) Sparx Systems 2025

Action

Select the 'Paragraph | Normal' menu option.

All paragraph formatting applied to the current paragraph or selected text will be
removed.

Select the 'Paragraph | Center' menu option, or press Alt+8.

Select the 'Paragraph | Right Justify' menu option, or press Alt+9.

Select the 'Paragraph | Justify Both' menu option.

Select the 'Paragraph | Double Space' menu option to put a double line space
between paragraphs.

Select the 'Paragraph > Indent Left' menu option, or press Alt+L.
Select the option again to increase the indent.

To reduce or cancel the indent, click on the 'Decrease Indent' icon in the Ribbon.

Select the 'Paragraph | Indent Right' menu option or press Alt+R.

Select the option again to increase the indent.

Select the 'Paragraph | Hanging Indent' menu option, or press Alt+T.

Select the option again to increase the indent of all lines below the first.

Select the 'Paragraph | Keep Together' menu option.

The editor attempts to keep all lines within the paragraph on the same page.
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Keep paragraphs together

Prevent 'widow' and
'orphan' lines

Start text on new page

Insert border and shading
for text block

Define line spacing

Set a background color for
text space

Create a bulleted list

Create a numbered list

Apply numbering to
paragraphs

Apply a paragraph style
from the template
stylesheet
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Select the 'Paragraph | Keep with Next' menu option.

The editor attempts to keep the last line of the current paragraph and the first line of
the next paragraph on the same page.

Select the 'Paragraph | Widow/Orphan Control' menu option.
The editor attempts to avoid having:
e the first line of the paragraph on the previous page (‘widow' line)

e the last line of the paragraph on the next page (‘orphan' line)

Move the cursor to the point at which to start the new page, and select the
'Paragraph | Page Break Before' menu option.

Select the 'Paragraph | Border and Shading' menu option.

The "Paragraph Box Parameters' dialog displays, on which you specify:

e  Which sides of the box to display (including a line between text lines)
e Whether the lines are thick or doubled

e The degree of gray shading behind the text

e  The color of the lines

Select the 'Paragraph | Paragraph Spacing' menu option.

The "Paragraph Spacing Parameters' dialog displays, on which you specify the line
spacing and the point spacing before and after lines.

Alternatively, to just set double line spacing, select the 'Paragraph | Double Space'
menu option.

Select the 'Paragraph | Background Color' menu option.
The 'Color' dialog displays, on which you select the background color.
The editor highlights the full width of the page in that color, for the selected lines.

Select the 'Paragraph | Bullet' menu option.
The editor formats the lines into a simple bullet list.

If you want to indent the list (or a part of it) further, select the 'Paragraph | Increase
Level' menu option. If you have increased the indent but now want to decrease it,
select the 'Paragraph | Decrease Level' option.

Highlight the required lines of text and select the 'Paragraph | Numbering' menu
option.

The editor formats the lines into a simple numbered list.

To create multiple-level numbered lists, see Set the list characters.

(Used in the 'Document Template Editor".)

1. Set up a numbering list and overrides ('Document-Edit > Edit > Edit > List and
Overrides > Create List Item' and 'Create List Override').

2. Apply the numbering levels to the template sections ('Document-Edit >
Paragraph > Paragraph > List Numbering').

Select the 'Paragraph | Style' menu option.

The 'Select a Style' dialog displays, listing the currently-defined paragraph styles in
the template stylesheet.
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Select the required style and click on the OK button.

Set text flow in document To set the text flow for:

e A highlighted block of text, select the 'Document-Edit > Paragraph >
Paragraph > Text Flow' ribbon option; the 'Paragraph Text Flow' dialog
displays

e  The entire document, select the 'Document-Edit > Edit > Document Text Flow'

menu option; the 'Document Text Flow' dialog displays

In either case, select the required text flow direction and click on the OK button.
The options are:

e Left toright
e Right to left
e Default

The 'Default' action depends on the language setting of the system; for example, if
the system language is Hebrew or Chinese, the default text flow is right to left.

Paragraph Marker Displays or hides the various space markers in the text, such as:
e  The paragraph marker at the end of each paragraph
e The Tab indicators between tabbed blocks of text, and
e The blank character marker between words

This option is useful when working with page-formatted text that is structured using
both style definitions and key-strokes.

Set the list characters When you have set up your bulleted or numbered list elements, you can toggle
between the list character options using the drop-down arrow icon just to the left of
the bullet list icon on the lower toolbar of the document template editor.

When you click on this icon, you are prompted to select between a single-level list
format and a multiple-level list format. When you select one of these options, you
then make a further selection between:

e Single-level: Arabic numerals, Roman numerals, upper-case letters and
lower-case letters

e  Multiple-level: Arabic numerals, Roman numerals and bullet symbols
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Define Document Sections

Using the Document Editor, you can partition your text into separate sections, present the text in a section in columnar
format, and set different page orientations and printing for each section. A multiple section document is useful to:

e  Change the presentation and format of the text for different areas of information
e Change between portrait and landscape orientation for different parts of the document

e  Vary the page margins from one page to another

Access

Ribbon Document-Edit > Edit > Insert > Insert Break > Section Break

Create a section

Select the 'Insert | Insert Break | Section Break' menu option. This creates a new section on a new page.

AF

The section break is represented by a dotted line; if this is not visible, click on the icon in the "Paragraph’' panel of

the 'Document-Edit' ribbon.

The 'Section Break' menu option is not effective when 'Edit Page Header/Footer' is active, because editing control passes
to the header and footer bands away from the body of the document.

Set section properties

Section properties apply to all the document content following the section break, up to the next section break line.

Select the option 'Document-Edit > Edit > Edit > Edit Section' to display the 'Section Parameters' dialog. Complete each
panel to set up the section as you require.

To Action
Set number of columns in a The Number of Columns' field defaults to '1', to present the text as a normal page
section of text (effectively a single column).

To structure the text in two or more columns on a page:

e In the 'Number of Columns' field, type the number of columns to divide the
text into across the page

e In the 'Space Between the Columns' field, type the separation of the columns,
in inches

e If you want to separate the columns with a vertical line, select the 'Line
Between Columns' checkbox

When you close the dialog, the text is displayed in the selected number of columns
of equal width, across the page. The text wraps at the edge of the column and, when
it reaches the foot of the page, continues at the top of the next column.

Start section on new page If you want to insert a page break before the new section, select the 'Start Section
on New Page' checkbox.
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If you also want to adjust the page numbering so that the new section starts at a
specific page, select the 'Restart Page Number at' checkbox and type the page
number.

The section start page will often be 1, but this facility is also useful for inserting
another document of a constant number of pages between, for example, an
introduction and a technical section.

Set text direction Set the direction of the text flow within the section by selecting the appropriate
radio button.

Set page orientation Set the page orientation within the section by selecting the appropriate radio button.

Set paper size for section Select a standard paper size for the pages of the section.

Alternatively, you can scroll down the list and select the 'Custom Size' option, and
then define the page width and height, in inches.

You can also define special page margins by selecting the option 'Document-Edit >
File > File > Page Layout'.

Set paper source The "Paper Source' selections both default to 'Auto Select', so that the pages of the
section print from whatever paper trays have paper available.

If you are printing on paper from a specific tray, or are manually feeding paper to
the printer for this section, select the appropriate option. You can select different
options for the first page of the section and subsequent pages of the section.

Delete a section break

Move the cursor onto the labeled Section Break line and press the Delete key.

When you delete a section break, the section properties of the preceding section now apply to the document content
following the deleted line.
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Set Tabs

Using the Document Editor, you can define left, right, center and decimal tab points to define the positions of text strings
and columns across the page. A paragraph or highlighted block of text can have as many as twenty tab points, which
apply to every line of the selected text.

If you do not set tab points, the Tab key moves the cursor to default tab points at 0.5-inch intervals.

Access
Ribbon Select 'Document-Edit > Paragraph', then choose one of:
e SetTab
e (lear Tab

e (lear All Tabs,

or click on the ruler at the top of the page.

Create and Clear Tab Points

Operation Detail

Using the ruler If the ruler is not visible, select the option 'Document-Edit > File > View >
Horizontal Ruler'.

To create a:

e Left tab, click on the required tab position on the ruler; the left tab is indicated
on the ruler by an 'L' shape

e Right tab, right-click on the required tab position on the ruler; the right tab is
indicated on the ruler by a reversed 'L' shape

e  Center tab, press Shift and click on the required tab position on the ruler; the
center tab is indicated on the ruler by an inverted 'T' shape

e Decimal tab, press Shift and right-click on the required tab position on the
ruler; the decimal tab stop is indicated on the ruler by an inverted 'T' shape
with a dot on the right hand side
This tab is for numbers with a decimal point; numbers scroll left from the tab
until you type the point, then numbers scroll right.

To move a tab position, click on the tab symbol on the ruler and drag it to the new

position.
Using the Set Tab menu The 'Paragraph > Set Tab' menu option displays the 'Set a Tab Position' dialog, on
option which you select from a set of radio buttons to specify the tab type.

The dialog provides two advantages over the ruler; you can:

e  Set the tab position with more precision and with a clear value (in inches) that
you can duplicate

e Select from a set of radio buttons to add or remove a dotted, broken or solid
line preceding the tab point
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Click on the OK button to save the settings.

Clearing a single tab point Highlight the block of text and select the 'Paragraph | Clear Tab' menu option.
The 'Clear a Tab Position' dialog displays.
Select the tab to clear and click on the OK button.

Clearing all tab points for a Select the block of text and select the 'Paragraph | Clear All Tabs' menu option.
text block

Notes

e  The option 'Document-Edit > File > Manage > Snap To Grid' affects the movement of the tabs (and the paragraph
indentation markers) on the ruler; when you select this option, the movements of the tab markers are locked on to an
invisible grid at intervals of 1/16 inch (half a ruler division)
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Manage Page Breaks

As you set up the document structure, you might want to insert a page or column break to force a specific part of the
document content to start on a new page or column.

Access
Ribbon Document-Edit > Edit > Insert > Insert Break > Page Break, or
Document-Edit > Edit > Insert > Insert Break > Column Break
Keyboard Shortcuts Ctrl+Enter (page break)

Force a page break

Select the option 'Document-Edit > Edit > Insert > Insert Break > Page Break', or press Ctrl+Enter.

The forced page break is indicated by a labeled solid line; if this is not visible, click on the [T icon, in the 'Paragraph'’

panel of the 'Document-Edit' ribbon.
Create a column break
Move the cursor to the appropriate point in the column text and select the option 'Document-Edit > Edit > Insert > Insert

Break > Column Break'. The break is indicated by a labeled 'dot and dash' line.

Normally in a multiple column section, the text flows from the end of one column to the top of the next column; a
column break forces the text to the next column before the current column is completely filled.

Delete a break

A page break or column break is indicated by a labeled line. To delete the break, move the cursor onto this line and press
the Delete key.
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Insert Headers, Footers, Footnotes and Endnotes

When creating a document report or template, you can include page headers, footers, endnotes and footnotes. You switch

options on to create and edit these items, and then switch these options off again to protect the entries. While you are

creating headers and footers, you can also continue to edit the body of the document. You can create headers and footers:

e To apply throughout the document

e  Separately for each section that you might create in your document

e  Separately for the first page of the document and for the subsequent pages (for example, to leave no header and
footer text on the title page of the document)

e  Separately for left-hand and right-hand pages

Header and footer options

To

Create the page header and
footer

Edit or delete the page
header and footer text

Create separate header and
footer for the initial page of
the document

Display the common
document header and
footer on the initial page
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Action

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer'.

A dotted line marks off the header area at the top of the page and the footer area at
the bottom of the page. This dotted line is at a position that is set using the 'Page
Setup' dialog ('Document-Edit > File > File > Page Layout").

Within each of these two areas, a paragraph marker displays to indicate where the
text will sit relative to the top and bottom edges of the paper. This position is also
defined on the 'Page Setup' dialog.

You can type in any kind of free-form or formatted text and insert icons as you
prefer. You would normally work well within the defined areas for the header and
footer, but if the text exceeds the area, the dotted lines simply move to
accommodate the text.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer', move the cursor to the text and make any changes required. If you
need to, delete the text altogether.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > First Page
Header/Footer' and either:

e The 'Create First Page Header' option, or
e The 'Create First Page Footer' option

A paragraph marker displays at the top or bottom of the first page of the document.
If you want specific text to display on the first page of the document, type it in and
format it.

Alternatively, leave the spaces blank so that the first page has no header or footer
text.

If you have created a separate initial page header and/or footer and now want to
display the same header and footer text on the initial page as is shown on
subsequent pages of the document, you specifically delete the 'first page
header/footer' assignment.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
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Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > First Page
Header/Footer' and either:

e The 'Delete First Page Header' option or
e The 'Delete First Page Footer' option

The 'first page' assignment and text are removed from the first page header and/or
footer spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Left Page
Header/Footer' and either:

e The 'Create Left Page Header' option, or
e The 'Create Left Page Footer' option

Scroll to the nearest left-hand page and in the header or footer space type in any
kind of free-form or formatted text and insert icons as you require.

This text displays on every left-hand page in the section or, if there are no sections,
in the document.

Format your document to put left-hand page information on pages with left-hand
headers and footers. For example, in English language documents, even-numbered
pages are usually left-hand pages.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Right Page
Header/Footer' and either:

e The 'Create Right Page Header' option, or
e The 'Create Right Page Footer' option

Scroll to the nearest right-hand page and in the header or footer space type in any
kind of free-form or formatted text and insert icons as you require.

This text displays on every right-hand page in the section or, if there are no
sections, in the document.

Format your document to put right-hand page information on pages with right-hand
headers and footers. For example, in English language documents, odd-numbered
pages are usually right-hand pages, and sections such as Title, Introduction and
Table of Contents start on right-hand pages.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > <side>
Page Header/Footer' (where <side> is either Left of Right) and either:

e The 'Delete <side> Page Header' option, or
e The 'Delete <side> Page Footer' option
You are prompted to confirm the deletion; click on the Yes button.

Left and Right page headers or footers balance each other. If you create one, the
system responds as if the other exists but is blank. If you delete one, the system
responds as if the other is the 'common' header/footer for the section, and all page
headers now contain that remaining text.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces again, and check that you
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cannot move the cursor into the header and footer spaces.

Footnote and Endnote options

To Action

Create a footnote Move the cursor to the position at which to insert the footnote marker, and select
the option 'Document-Edit > Edit > Insert > Footnote/Endnote > Footnote'.

The 'Footnote' dialog displays. In the:

e 'Footnote Marker' field type the marker you want to use, such as a number,
asterisk, hash or letter of the alphabet, or any text string of up to 10 characters

e 'Footnote Text' field, type the text of the footnote

e 'Superscript Footnote Marker' field, leave the checkbox selected to display the
marker as a superscript, or clear the checkbox to display the marker in the same
format as the preceding text

Click on the OK button; the editor inserts the footnote marker at the current cursor

location and displays the marker and text at the bottom of the page, above the page

footer space.

Edit footnote text Select the option 'Document-Edit > Edit > Edit > Edit Footnote/Endnote > Edit
Footnote text'.

The marker and text of each footnote displays in the document text where the
marker was originally inserted, highlighted by a broken underline.

Locate the text and make the required changes. These changes are immediately
reflected in the footnote text at the bottom of the page.

When you have finished editing footnote text, click again on the option
'Document-Edit > Edit > Edit > Edit Footnote/Endnote > Edit Footnote text'; the
footnote text is no longer shown in the document text.

Create an endnote Move the cursor to the position at which to insert the endnote marker, and select the
option 'Document-Edit > Edit > Insert > Footnote/Endnote > Endnote'.

The 'Endnote Parameters' dialog displays. In the:

e 'Endnote Marker' field type the marker you want to use, such as a number or
letter of the alphabet, or any text string of up to 10 characters

e 'Endnote Text' field, type the text of the endnote

e 'Superscript Endnote Marker' field, leave the checkbox selected to display the
marker as a superscript, or clear the checkbox to display the marker in the same
format as the preceding text

Click on the OK button; the editor inserts the endnote marker at the current cursor
location and displays the marker and text at the end of the section or, if there are no
sections, at the end of the document.

Edit endnote text Select the option 'Document-Edit > Edit > Edit > Edit Footnote/Endnote | Edit
Endnote text'.

The marker and text of each endnote displays in the document text where the
marker was originally inserted, highlighted by a broken underline.

Locate the text and make the required changes; these changes are immediately
reflected in the endnotes at the end of the section or document.

When you have finished editing endnote text, click again on the option
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'Document-Edit > Edit > Edit > Edit Footnote/Endnote | Edit Endnote text'; the
endnote text is no longer shown in the document text.

Notes

®  You can create and edit headers and footers whether the option 'Document-Edit > File > View > Page Layout Mode'
is switched on or switched off; this option makes no difference
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Insert Hyperlinks

Within a document, you can insert hyperlinks to display material held outside the document, such as external documents,
Help topics or web pages.

Access

Ribbon Document-Edit > Edit > Insert > Hyperlink

Insert hyperlinks

To insert a hyperlink, right-click on the point in the text at which to create it and select the option 'Document-Edit > Edit
> Insert > Hyperlink'; the 'Insert Hyperlink' dialog displays.

In the 'Link Text' field, type the text to be hyperlinked and, in the 'Link Code' field, type or paste the:
e  Web page URL

e  Help topic file name or

e  External file path and name

To capture the Help topic file name and path, right-click on the displayed topic and copy the file name and path from the
address field at the top of the screen.

Click on the OK button; the hyperlinked text displays in the document. Edit the sentence to accommodate the link text.
To display the web page, Help page or external document:

e Linked in a document, double-click on the link

e Linked in a report template, compile the report and click on the hyperlink in the report

In a Library document, you can also insert hyperlinks to related objects in the model.
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Insert Images, Objects and Frames

In creating your document or template, you might want to embed or display images and other objects in the text, to insert
external information and/or structure the text and graphics on a page. You could insert, for example:

e Animage in the text or as background to the text
e  Alink to an image
e An Object Linking and Embedding (OLE) object, which you create and edit using an external application

e A frame - a rectangular border within the text that can contain separate text and pictures, and that the existing text
flows around

e A drawing object - a rectangle, text box or line that can sit over the existing text
e Another document file

Having inserted an object, you can subsequently move, edit or delete it.

Insert items

To Action
Insert a picture in the You can insert a picture bitmap or Windows metafile in your document as either an
document embedded picture or a link to the external picture file.

Position the cursor at the point at which to insert the picture, and select either:
e 'Document-Edit > Edit > Insert > Embed Picture' (F8) or
e 'Document-Edit > Edit > Insert > Link Picture'

A browser dialog displays, through which you select the picture to insert in the
document; the picture is shown at the current cursor location.

The embedded picture is saved within the document; only the filename of the linked
picture is saved with the document, which is a better option if you intend to edit the
picture over time.

Embed an OLE object in Position the cursor at the point at which to embed the object, and select the
the text 'Document-Edit > Edit > Insert > OLE Object' menu option.

The 'Insert Object' dialog displays, listing the applications that are available to
create the object.

When you select an application, the editor launches it and you create the object;
when you save the application, the editor inserts an icon or view that represents the
inserted object.

You can also use the option 'Document-Edit > Edit > Edit > Paste Special' to import
OLE objects, provided that the object is available in the clipboard.

You can later edit the object using the application, by double-clicking on the object
or by selecting the option 'Document-Edit > Edit > Edit > Edit OLE Object'.

Change the size and Click on the picture and select the option 'Document-Edit > Edit > Edit > Edit
alignment of an embedded Picture'; the 'Edit Current Picture' dialog displays, through which you can change
picture the height and width of the picture, in inches.

You can also align the top, middle, or bottom of the picture with the baseline of any
text on the same line as the picture, or offset the bottom of the picture from that
baseline by any number of twips.

Insert a background or Select the option 'Document-Edit > File > Manage > Watermark Picture'; a browser

(c) Sparx Systems 2025 Page 140 of 175 Created with Enterprise Architect



Document Generation

watermark picture for the
document pages (document
report templates)

Insert a document File

Embed a frame at the
cursor position

Embed a drawing object at
the cursor position

Move the frame or drawing
object

Edit the border,
background and impact on
document text of a drawing
object

Insert text into the frame,

(c) Sparx Systems 2025

2 September, 2025

dialog displays, through which you select the graphic file to insert as a watermark.
The picture occupies the entire text area, and is displayed as a washed-out image. If
you choose an image that is already washed-out, no watermark is displayed at all.

To remove the watermark image, deselect the option 'Document-Edit > File >
Manage > Watermark Picture'.

Position the cursor at the point at which to insert the file, and select the option
'Document-Edit > Edit > Insert > Insert RTF File'.

Select the option 'Document-Edit > Edit > Insert > Frame'.

The border of the frame displays, with the cursor at the top left corner. You can
change the size of the frame by clicking on the border and dragging the small black
'handles'".

Select the option 'Document-Edit > Edit > Insert > Drawing Object'.

The 'Select Drawing Object Type' dialog displays, on which you select the radio
button for either a:

e Text Box
e Rectangle or
e Line

Click on the OK button; the selected object displays, overlaid on the existing
document content. If required, you can change the size of the object by clicking on
the border and dragging the small black 'handles'.

You can also change the appearance and the relationship of the object to the
document text.

Click on the outline of the frame or drawing object and then move the cursor just
outside the outline so that the cursor changes to a plus-shape.

Drag the plus shape (and hence the outline) to the new position.

Select the drawing object by clicking on its outline, then select the option
'Document-Edit > Edit > Edit > Edit Frame/Drawing Object > Edit Drawing
Object'.

The 'Line and Fill attributes' dialog displays.

Select the options to define:

e  Whether to display a border line and, if so, your preferred border thickness,
type and color

e  Whether the object is transparent or filled and, if filled, the fill color

e The wrapping behavior of the text outside the object:

- 'Wrap Through' causes the document text to flow through the
diagram object so that they overlap each other

- 'No Wrap' causes the document text to skip over the object,
so that the text resumes below the object

- 'Wrap Around the Object' causes the document text to flow
around the object, into a column on one side or the other of
the object, or on both sides; if you move the object across the
page, the editor tends to leave a wider margin before it starts
to wrap text to the left of the object

e The Z Order of the object, so that if there is an overlap the object either lies in
front of the document text (Z-order = 1) or behind the document text (Z Order
=> 1)

Click inside the outline and type the text at the cursor position. The text wraps at
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the right hand side of the box and, for a:
e Frame, extends the bottom border of the box

e Text box and rectangle, overflows the bottom of the box but is still associated
with the box and not with the 'normal' text of the document; to enclose all lines
adjust the height manually to enclose the text

If you change the width of the outline, any text inside the outline is automatically
wrapped to adjust to the new width.

Select the option 'Document-Edit > Edit > Edit > Edit Frame/Drawing Object >
Rotate Text'. The 'Text rotation' dialog displays; select the radio button for the text
direction you want to apply:

e 'Horizontal' (default) - the text flows from the top left corner of the box across
the width of the box, wrapping at the right border and scrolling downwards

e 'Top to Bottom' - the characters are rotated through 90 degrees to flow from the
top right corner of the box downward, wrapping at the bottom edge of the box
and scrolling right to left

e 'Bottom to Top' - the characters are rotated through 90 degrees to flow from the
bottom left corner of the box upward, wrapping at the top edge of the box and
scrolling left to right

If the text is running horizontally, you can type as much as you need - the box
height increases to accommodate the text. If the text is running vertically, and it
flows outside the box, you adjust the box height and width manually to
accommodate your text.

Click on the OK button to apply the change.

Click inside the outline and either insert the picture as previously explained, or
copy and paste it at the cursor position.

If the frame or text box contains only the picture, the picture size is automatically
adjusted to as nearly fill the outline as possible without distorting the image.

If you change the width or height of the box, the picture is adjusted to completely
fill the outline; you continue manually adjusting the outline to reduce the distortion
of the image.

You can fix the position of the outline to a specific point so that as you enter and
format the text the outline maintains its position relative to that point.

The default position is relative to the first character of the paragraph, in which case
the outline moves on the page with any change that affects the position of the
paragraph.

You can also fix the position relative to either the:

e Top edge of the page or

e Top margin of the page

In these cases, if the document text on the page is adjusted it flows past the outline.

Click on the outline and select the option 'Document-Edit > Edit > Edit > Edit
Frame/Drawing Object > Vertical Base Position' menu option.

The 'Object Position' dialog displays. Select the radio button for the locking point
you prefer:

e 'Top of the Page'

e 'Top Margin'

e 'Current Paragraph'

Click on the OK button to apply the lock.
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Delete a frame or drawing Click on the outline and press the Delete key.

object The editor prompts you to confirm the deletion; click on the Yes button.

This deletion is reversible - press Ctrl+Z or select the option 'Document-Edit > Edit
> Edit > Undo'.
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Checking Text

In developing a document or template, you would probably want to spell-check the text that you have entered; for
example, to make sure that 'boiler-plate' text is correct, as it will be used many times in many reports. In the Document
Editor you can both spot-correct a word from a context-sensitive list, or run a spell checker over the whole document.
You can also check the use of a word against an online thesaurus, to see if there is a more precise term or to check the
opposite meaning of the word.

Access
Ribbon Document-Edit > Edit > Spell Check > [options]
Check Spelling
To Action
Spot-correct a word Select the option 'Document-Edit > Edit > Spell Check > Auto Spell Checking'.

When the 'Auto Spell Checking' option is on, the Document Editor automatically
checks the spelling of all typed or pasted text in the document (but not field names
or generated text). Words that are apparently spelt incorrectly are underlined in red.

Right-click on an underlined word; a short list displays, containing the correct
spelling of the assumed word and a selection of other words that this word might
have been intended to be. Click on:

e One of the words, to use it in place of the misspelt word
e The 'Ignore All' option to use the word as it is in this context
e The 'Add' option to add the word to the suggested list of spellings/other words

You might be using a language for which there is no spelling dictionary installed,
or text that contains a high proportion of new terms, in which case you might not
want to have the auto spell function underlining all the text. You can turn it off by
selecting the 'Other | Auto Spell' option again.

Run the spell checker over Select the option 'Document-Edit > Edit > Spell Check > Spell Check'.

the whole document The 'Check Spelling' dialog displays, identifying the first apparent spelling mistake
in the document.
You might want to modify the things that the Spell Checker identifies as errors;
click on the Options button to tailor the operation of the checker.
Having tailored the spell checker, respond to each of the possible errors that it
highlights in your document.

When you have acted on all the words presented by the Spell Checker (or clicked
on the Cancel button) a status message displays identifying the number of words
picked up and the number of those words you have corrected. Click on the OK
button.
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Run Thesaurus

To Action

Access the Thesaurus Select a word in the text, then select the option 'Document-Edit > Edit > Spell
Check > Thesaurus'.

The 'Thesaurus' dialog displays, showing the:
e Selected word
e  Word-categories the word belongs to, in the 'Categories' panel

e List of synonyms for the word within the first category (words that have the
same meaning as the selected word) in the 'Synonyms' panel

If there are several categories, click on each one to display the synonyms within
each category.

Display antonyms If you want to display the antonyms for the word (the opposite meanings of the
word), select the Antonyms checkbox.

The Antonyms title displays in the Categories panel, with the word-categories for
the opposite of the selected word listed underneath.

Click on a category name to list the antonyms in that category, in the Synonyms
panel.

Check for homonyms A homonym is a word that sounds similar to another and can be confused with it.
For example, 'Sympathy' might be confused with 'Empathy' or 'Symphony'.

If you want to check that you have not chosen a sound-alike word by mistake, click
on the Suggest button.

The 'Suggestions' dialog displays, listing possible sound-alike words. If you want to
use one of those words, or check for another with the same meaning, click on the
Look up button.

The 'Thesaurus' dialog refreshes with the new word you have selected.

Search for new terms If you want to examine a totally different word, in the 'Term' field type the new
word and click on the Look up button.

The display changes to show the synonyms (and antonyms) of the new word.
Change to a synonym Click on a synonym (or an antonym, if required) in the list, and click on the OK

button.

The word in the text changes to the selection.
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Track Changes

In a team environment, two or more people might work on developing documents and/or templates. You might,
therefore, need to review each other's work, or just be able to see what changes another person has made to the file. In
the Document editor, you can turn on change tracking to highlight the changes you make to the text.

Access

Ribbon Document-Edit > Edit > Tracking > [options]

Tracking options

To Action

Turn tracking on Select the option 'Document-Edit > Edit > Tracking > Enable Tracking'.
Any changes made after Tracking is turned on are immediately highlighted:
e Inserted text - printed in a different color
e Deleted text - struck through with a single colored line
e Formatting changes - indicated by a colored dotted underline

A change bar is also inserted in the page or column margin to indicate the line on
the page on which the change was made.

If you mouse over a highlighted change, a tool-tip displays the type of change, the
name of the person who made the change, and the date and time the change was
made.

Turn tracking off Select the option 'Document-Edit > Edit > Tracking > Enable Tracking' again.

Any changes made after Tracking was turned on remain highlighted, but changes
made after tracking was turned off are not highlighted.

Hide changes If you want to review the document as it is, without the highlighted changes, but
you do not want to lose the changes or highlighting, select the option
'Document-Edit > Edit > Tracking > Hide Changes'.

The highlighted additions and deletions are hidden, and the remaining text closes
up. Format changes are not hidden.

To expose the hidden changes, click on the option 'Document-Edit > Edit >
Tracking > Hide Changes' again.

Locate changes Select the option 'Document-Edit > Edit > Tracking > Find Next Change' or
'Document-Edit > Edit > Tracking > Find Previous Change' to search the text and
place the cursor on the next or previous change made, respectively.

Respond to change If you want to assess each change and act on your decision, select the option:
e 'Document-Edit > Edit > Tracking > Accept Change' to confirm the change, or

e 'Document-Edit > Edit > Tracking > Reject Change' to reverse the change to
the original text or format
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In either case, the change tracking markings are removed. You can make further
changes if necessary.

Accept all changes If you are not assessing each change, for example if you just want to see what a
colleague has done before making your own changes, you can accept all changes
across the document in one action.

Select the option 'Document-Edit > Edit > Tracking > Accept All Changes'.

Reject all changes If you are not assessing each change, but just want to reverse all changes across the
document in one action, select the option 'Document-Edit > Edit > Tracking >
Reject All Changes'.

A prompt displays for you to confirm the action; click on the Yes button.

You might do this if, for example, you or a colleague have edited the wrong version
of a document or acted on a technical change that was itself reversed.
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Protect Document Contents

When you have created a document, or some important text within a document, you might want to protect it from being
edited or deleted so that it is safe from accidental change. The Document Editor defaults to locking against protection, so
you first turn off the lock and then protect either the whole document or a selected block of text. Once protection is set,
neither you nor any other user can change the text without specifically removing the protection.

Access

Ribbon Document-Edit > File > Manage > Text Selection Lock
Document-Edit > Font > Font > Protect

Document-Edit > File > Manage > Protect Document

Protect text

To Action

Enable text protection By default, the Text Selection Lock is enabled.

Select the option 'Document-Edit > File > Manage > Text Selection Lock' to disable
this option.

You can now set protection on your text.

To re-enable the protection lock and prevent protection of further text, select the
option 'Document-Edit > File > Manage > Text Selection Lock' again. The text that
you have already protected, however, remains protected and cannot be edited until
you or another user specifically removes the protection. You cannot remove
protection from this text until you turn off the protection lock again.

Protect text Highlight the line, block or section of text to be protected, and select the option
'Document-Edit > Font > Font > Protect'.

The selected text is displayed in a gray font, and cannot be edited.

If the menu option is unavailable, or the text is not faded, it means that you have
not removed the protection lock.

To release the text for editing again, highlight it and reselect the option
'Document-Edit > Font > Font > Protect’. You can select and release a portion of
the protected text; the remainder stays protected.

Protect a document

Within the document or template, select the option 'Document-Edit > File > Manage > Protect Document'.
The entire document is protected.

An exception is protecting a template in the Document Template Designer. As you select checkboxes in the 'Sections'
panel, section markers are still added to the 'Content' panel. You cannot, however, add fields or text between the markers.
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To release the document for editing again, reselect the option 'Document-Edit > File > Manage > Protect Document'.
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The Legacy RTF Report Generator

Creating a Rich Text Format (RTF) document is a simple and flexible process. An RTF document is based on an element
or (more usually) a Package in your project. To produce a document, you select the Package or element to report on in
the Browser window, Package Browser, Diagram List or Model Search, then press F8 to display the 'Generate
Documentation' dialog. On the 'Options' tab, click on the Switch Generator button to access the legacy 'Rich Text Format
Report' dialog.

The 'Rich Text Format Report' dialog enables you to set the exact contents and look and feel of your report. You enter
the file name of the report, a heading, additional notes, template name (for saving the set-up) and other options. You can
also select the style of the report; either plain or formal.

Optionally, you can set up a filter, the details to include, element types to exclude, whether to process child Packages,
whether to show diagrams and the diagram format.

You can switch back to the 'Generate Documentation' dialog by clicking on the Switch RTF Generator button.

Notes

e The Legacy Generator is available if you have RTF templates created in releases of Enterprise Architect prior to 4.1,
and you prefer to generate RTF reports using the original generator; however, as you can generate reports from these
templates using the post-Enterprise Architect 4.1 RTF Generator, the Legacy Generator and instructions for its use
are no longer updated

e Reports produced using the Legacy RTF Generator do reflect the Notes formatting feature in any text associated
with elements

e The 'Rich Text Format Report' dialog panels are individually described in the subsequent topics of this section (as
listed); the dialog has a lot of options - you can use them selectively to produce output at the level of detail suited to
your project
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Document a Single Element

RTF documentation can also be generated for a single element.

Access

Select the element for which to generate documentation, then open the 'Generate Documentation' dialog using one of the
methods outlined here.

Ribbon Publish > Model Reports > Report Builder > Generate Documentation > Options :
Switch generator

Keyboard Shortcuts F8 | Options | Switch Generator
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Set the Main RTF Properties

The main section of the 'Rich Text Format Report' dialog enables you to set the output location and appearance of the
final RTF document.

Set Output Location and Appearance

Step Action

1

Open the 'Rich Text Format Report' dialog.

2 Supply an Output Filename to save the report into; always include the extension .rtf as part of the
filename.
3 In the 'Template Name' field, provide the name of the template to generate the report from.
4 Select a report Style: Formal or Basic.
5 Type a Heading for your report; this appears as the first heading item in your output.
6 Select your required Heading Style and Initial Heading Level Indent from the drop-down lists.
Notes

It is recommended that you enter a full path name for your report; the images in your report are saved externally in
an images directory, and supplying the full directory path avoids confusion over the location of these images

If you move your report you must also move the images directory
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Apply a Filter

On the 'Rich Text Format Report' dialog you can apply a filter to include or exclude elements by date modified, phase or
status. This helps to track changes and break a document into multiple delivery phases.

Open the 'Rich Text Format Report' dialog.
e To enable the date filter, select the checkbox in the 'Date’ field

e In the first two 'Only include objects' fields, click on the drop-down arrows and select the appropriate criteria
(Modified/Created, Before/After)

e The Package phase filter applies at the Package level (not the element level) and ignores the phase of the root
Package that you are documenting; to enable the phase filter, in the 'Where Package Phase' field click on the
drop-down arrow and select an operator
Enterprise Architect filters out all Packages that do not meet the selection criteria; all elements in the Package are
ignored, regardless of their individual phase

e The element status filter enables you to limit the output by element status; unlike the Package phase filter, this filter
applies to every element
You can filter against a status of like or unlike a criterion, such as 'like proposed', or against the 'in' and 'not in'
operators, such as 'in approved', 'not in validated'; when using the 'in' and 'not in' operators, enter a comma-separated
list of status types as your criteria expression
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Exclude Elements

Using the 'Rich Text Format Report' dialog, you can exclude elements of any type from your final output; this is useful
when you want to highlight particular items and not overburden a report with too much detail.

To do this:
1. Open the 'Rich Text Format Report' dialog.
2. Click on each element to exclude, or click on the All button to exclude all elements.

3. Click on the None button to clear your selections.
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RTF Diagram Format

It is possible to output diagrams to Bitmap files, GIF files or Windows Metafiles.

To do this:

1.  Open the 'Rich Text Format Report' dialog.

2. In the 'Diagram format' panel (bottom center of the dialog) select the required format for the report.

3. Generally the two metafile options ('EMF' and 'WMF') are recommended; however, there are times that the others
might be suitable.
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Include model items in report

The ™Model Include' panel of the 'Rich Text Format Report' dialog has these options:
e 'Glossary' to include the Project Glossary

e 'Tasks' to include project tasks

e 'Issues' to include project issues

Select the appropriate checkbox to include the items in the generated RTF documentation.
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RTF Report Options

Additional RTF report options you can select from the 'Options' panel on the 'Rich Text Format Report' dialog are shown
here.

You can select whether or not to recursively document Packages, show diagrams or add a page break before each new
Package. Select the:

e 'Process all Children' checkbox to recursively process all child Packages within the main Package

e 'Show Diagrams' checkbox to include diagrams in your document; clear this item for no diagrams

e 'New page per package' checkbox to force a page break on each new Package (excepting empty Packages)
e 'Document all elements' checkbox to include all elements included in the project

e 'Document Packages' checkbox to document the Package as an element in addition to the documentation that would
normally be produced for Package documentation

e 'Hide 'note-less' elements' checkbox to exclude all elements without notes from the documentation

e 'Embed Diagrams in Document' checkbox to ensure that the diagram images are contained within the RTF document
rather than stored in a linked external file

e 'Skip root package' checkbox to exclude the parent Package from the documentation and include only the child
Packages

e 'Document Linked Elements' checkbox to include the object details for linked elements that do not originate from the
selected Package

e 'Use Heading styles for Details' checkbox to ensure that the details are formatted as heading styles rather than
formatted text; this option is only available when the 'Heading Style' field in the 'Main' section of the 'Rich Text
Format Report' dialog is set to 'Max 9 levels - elements are Package + 1'
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Select Document Sections

Using the 'For each Object Include' section of the 'Rich Text Format Report' dialog you can select the documentation
sections to include in your report.

What you include or exclude governs how simple or detailed your report is. You can create multiple reports at different
levels of detail for different audiences. Experiment with these options to see what effect inclusion or exclusion has. Most
items are self-explanatory.

Selecting the checkbox against a category item in the list selects all of the options that are contained in the category. To
expand a category, click on the + symbol next to the category name. To exercise greater control over a category of
options expand the top level item and then select the required individual items from the list.

Sometimes an item applies only to a certain type of element; for example, 'Attributes' only applies to Class elements and
a few other element types. The 'Child Diagrams' option shows or hides any diagrams that are attached under a model
element; for example, a Use Case might have a Scenario diagram attached.

Notes

e  Use this feature to produce the right level of detail for your audience; technical readers might want to see everything,
whilst management might require only the general outline
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Custom Language Settings

If you export RTF-format documents from Enterprise Architect in languages other than English, you can customize the
codepage, default language ID and character set that Enterprise Architect uses when generating RTF. This makes it much
easier to generate documentation appropriate to your country or locale.

You can also set up a list of word substitutions. For instance, where Enterprise Architect would include the word 'Figure',
you can specify another word to replace it that is either in your language or more meaningful to your readers.

Set up Substitutions

Step Action

1 Open the 'Rich Text Format Report' dialog.

2 In the 'Language' panel (bottom left of dialog) click on the Adjust button.
The 'Customize RTF Language' dialog displays.

3 Double-click on an item to set or clear its Substitute word.

4 When you have finished, click on the OK button.

Set Up Language, Codepage and Character Set

Step Action

1 From the drop-down lists in the 'Language’, 'Codepage' and 'Charset' fields, select the language, codepage
and character set that most closely match your location.

2 If required, modify the Substitute Tags by double-clicking on each and manually setting the value (for
advanced use only).

3 To clear the substitution list, double-click on each item in turn and delete the substitute value.

4 When you have completed the settings, click on the OK button to save them.

Now when you generate RTF documents, the substitute tags are used in the output.

Notes

e Ifyou want to generate reports in a language that requires Unicode support, please note that Enterprise Architect
.eap files default to using JET 3.5 as the database engine, which does not support Unicode character sets (see the
Startup topic); to provide Unicode support in your project, either upsize to a DBMS repository, or set JET 4.0 as the
database engine and download a copy of the Jet 4.0 EABase model from the Sparx Systems website, then do an EAP
to EAP transfer of your model into the Jet 4.0 file

e  You can transport these language and tag definitions between models, using the 'Settings > Model > Transfer >
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Export Reference Data' and 'Tmport Reference Data' ribbon options
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Generate the Report

Once you have set up the document properties as required, click on the Generate button to generate the report.

When you have generated the document, click on the View button to open the report in MS Word™.
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Save as Document

The Document feature enables a particular documentation configuration to be 'remembered', linking the loaded template
within the 'Report' dialog to the current highlighted Package. If a particular template is always used with a specific
Package, and multiple cases of documentation exist to be propagated, saving these as Documents can ease document
generation later.

Create and use Documents

Step

1

Action

Open the 'Rich Text Format Report' dialog.

Click on the Save as Document button.

The 'Save current as document definition' dialog displays.

In the 'Enter Value' field, type a name for the document and click on the OK button. The document is
added to the 'Resources' tab of the Browser window for easy future access.

To generate documentation from the 'Resources' tab of the Browser window, right-click on the required
document.

The context menu displays.

Select the required context menu option.

e Open Document - Opens the corresponding document file, as specified by the template 'Filename'
property
e  Generate Document - Opens the 'Report’ dialog, loaded with the specified template

e Auto Generate Document - Generates documentation, with the document located at the path specified
by the template's 'Filename' property

e Delete Document - Removes the specified document
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Use Microsoft Word

When generating reports with the 'legacy' Report Generator, you can use Microsoft Word™ to easily incorporate
additional features in the reports. You can:

e (Create a custom master document combining separate reports, to add a common table of contents, table of figures,
headers and footers

e Create documents with sustainable links to generated 'pieces' of Enterprise Architect output, pre-divided using
bookmarks, and updated automatically when the document is opened

e  Open a report in Word

e  Change linked images to embedded images

Notes

e  With the more recent, 'enhanced’' Document Report Generator, many of the facilities provided by Word have been
incorporated into the Generator or otherwise rendered unnecessary; it is therefore likely that you would have no
need to use Word in generating your reports - you can use Virtual Documents, for example, instead of Word master
documents and Bookmarks

e  These topics on the use of Word are therefore included only to support users who are still working with the 'Legacy’
Report Generator, or who are using Word for personal preference

e When you develop a report using Word with Enterprise Architect, leave definition of the section styles in the Editor
to the final stages just prior to report generation; Word truncates the section bookmarks, as it uses a smaller field
length for sections

e In Word, you can review and edit reports generated by Enterprise Architect, but you cannot import them back into
Enterprise Architect without damaging the section style definition
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Open a Report in Microsoft Word

If you want to use Microsoft Word™ to open a document file generated in Enterprise Architect, simply load Word and
open the file as a normal document. Word converts the file for display.

If Word is your default handler of document files, you can also load up and view the report by either:
e Double-clicking on the output file, or

e  Clicking on the View button on the 'Generate Documentation' dialog
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One of the options available when generating document reports is to embed images in the document, instead of
incorporating links to the image files. You would embed images if you want the document to be portable (separated from
the directory containing the image files), but use links to the image files if you want to update the images without
regenerating the document. You would be more likely to link to image files when developing the model and
documentation, and more likely to embed images when the document was ready for review or use.

If you have generated the document report with linked images and imported the document into Word™, and you want to
distribute that document, you can convert the file links to embedded images without having to go back to Enterprise
Architect to regenerate the document with embedded images.

Break image links in Word

Step

1

Action

Open the required document in Word.

Select the 'Edit | Links' menu option.

Highlight all links in the Links list.

Select the 'Save Picture in Document' checkbox.
Click on the Break Link button.

When prompted, click on the Yes button to break the links.

Word breaks the links and saves copies of the images inside the document.
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Document Bookmarks

If you want to create a complex document that consists of sections of one or more document reports, rather than one
complete report, you can create a master document in Microsoft Word™ and within it create links to the report sections
using their bookmarks. Bookmarks are GUID-based numbers that are automatically created for Packages, diagrams and
elements, and placed in a document when it is generated. Every object is bookmarked in the document according to these
rules:

e All alphabetic and numeric characters remain the same
e All other characters (including spaces) are converted to underscores

For example UCO1: Use Case Model becomes UC01__Use Case Model. A Package bookmark applies from the
beginning of a Package to the end, and includes all child Packages and elements underneath. You can also manually
assign bookmarks if you want to have references to additional subdivisions of a model or document. If you change your
model and regenerate your document report, you can simply refresh the links in the master document in Word to
automatically update the Word document.

When you use bookmarks to add sections of a generated report to a Word master document, you work with Word and the
Enterprise Architect Browser window open at the same time.

Add a Bookmarked Section of an RTF Document to a Word Document

Step Action

1 Within the Word file, position the cursor at the point at which to insert the section of the document.

2 Select the Word 'Insert | File' menu option.

The 'Insert File' dialog displays.

3 Browse for and select the document file to insert, then click on the Range button.

4 In the Enterprise Architect Browser window, right-click on the Package, diagram or element to include in
the documentation.

The context menu displays.

5 To paste the object's bookmark into the clipboard, select the menu option:

e Copy/Paste | Copy Documentation Bookmark

6 In Word, in the 'Range' cell of the 'Insert File' dialog, press Ctrl+V to paste the information from the
clipboard.

7 Click on the OK button.

8 Click on the drop-down arrow next to the Insert button. A short menu displays containing two options:

e Insert - embeds a permanent copy of the text
e Insert as Link - creates a link that can be updated if you alter the source document

Select the 'Insert as Link' option.
9 Repeat steps 1 to 8 for each section of each document you want to include in the Word document.
10 Select the "Word Tools | Options' menu option and, on the 'Options' dialog, select the 'General' tab and

select the 'Update automatic links at Open' checkbox.
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Whenever the Word document is opened, the links to the document sections will be automatically updated
with any changes made to the generated documents.

Notes

e  You cannot use Bookmarking in Report Package elements, which effectively replace Bookmarking in Word
Bookmarking requires each bookmark to be unique; when you generate a report with a standard template (including
in a single Model Document element), each bookmark is unique and there is a 1:1 association between the element
details being generated and the elements in the repository
As Report Packages are intended to contain multiple sub-documents, the association ceases to be 1:1; there is no

simple method that enables the generated data to be uniquely identified directly in association with the original
element
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Features of Word

When you have generated reports in the Enterprise Architect 'legacy’ report generator, you can open them in Microsoft
Word™ to enhance the output of your project documentation. Some of the things you might do include:

e Add a table of contents

e Add atable of figures

e Add headers and footers

e  Manipulate the report tables

e Set an option to refresh linked files automatically
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Add Table of Contents

Among the features of Microsoft Word™ that can be incorporated into generated Enterprise Architect document reports
is a Table of Contents, which can be used to aid navigation of the documentation and enhance readability. The Table of
Contents provides hyperlinks to the diagrams in the electronic version of the documentation, and page numbers in both
the printed and electronic versions of the documentation.

Include Table of Contents in document

Step Action

1 In Word, open the report to which to add a Table of Contents.
2 Select the 'Insert | Reference | Index and Tables' menu option.
3 Click on the 'Table of Contents' tab to set the options that are available for setting up the Table of
Contents.
Notes

e  The format of the Table of Contents is dependant on the heading levels created when the document is generated; to
set the heading styles in the document, see the RTF Report Options topic

(c) Sparx Systems 2025 Page 169 of 175 Created with Enterprise Architect



Document Generation 2 September, 2025

Add Table of Figures

Among the features of Microsoft Word™ that can be incorporated into generated Enterprise Architect reports is a Table
of Figures, which can be used to aid navigation of the documentation and enhance readability. The Table of Figures
provides hyperlinks to the diagrams in the electronic version of the documentation, and page numbers in both the printed
and electronic versions of the documentation.

Include Table of Figures in document

Step Action

1 In Word, open the report to which to add a table of figures.
2 Select the 'Insert | Reference | Index and Tables' menu option.
3 Click on the 'Table of Figures' tab to set the options that are available for setting up the table of figures.
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Add Headers and Footers

Among the features of Microsoft Word™ that can be incorporated into generated Enterprise Architect document reports
are headers and footers.

Include headers and footers in the document report

Step Action
1 In Word, open the report to which to add headers and footers.
2 Select the 'View | Header and Footer' menu option, and enter the appropriate information into the header
section and the footer section of the document.
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Manipulate Tables in Word

In the document reports generated from the Legacy report generator in Enterprise Architect, tables are included when
items such as attributes and methods are selected in the 'For each Object' section of the 'Rich Text Format Report' dialog.
Microsoft Word™ offers several levels of customization for tables and can be used to enhance formatting the tables in
situations where the margins of the table exceed the dimensions of the page size selected for printing in Word.

Manually resize the table

When the amount of detail for a documented item, such as an attribute or operation, exceeds the margins of the page in
Word, you can manually resize the table in order to view all of the details.

Step Action
1 Select the table that exceeds the margin size.
2 Mouse over the border of the table until the mouse pointer changes into the 'drag' icon, as shown.
Message Attributes
Attribute Type Notes
sentTime protected - |
Date
recetvedime protected : ol
Date
body protected :
String
3 Drag the cursor to the left to reduce the width of the table, and then select the 'Document-Edit > File >
File > Print Preview' menu option to confirm that the table borders are within the page margins.
4 Resize all of the tables that overhang the margins of the page, using steps 1 to 3.
Apply styles to tables

One of the customizable properties of Word when working with tables is the ability to apply a style to a table, so that you
can rapidly change the appearance of the table.

Step

1

Action

In Word, open the report in which to change the table styles.
Locate and select the table for which to adjust the appearance.

Select the 'Table | Table Auto Format' menu option.
The 'Table Autoformat' dialog displays.

From here you can specify a predefined table style from the Table styles list, or create a new style by
clicking on the New button. The table styles defined in the 'Table Autoformat' dialog only apply to one
table at a time so you must apply the style to each table individually.
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Refresh Links

If you link into reports generated in Enterprise Architect, you can set an option in the Microsoft Word™ master
document so that each time the document is opened, the links are refreshed and - if the reports have changed - the linked
text is automatically updated.

Access

MS Word Tools | Options > General

Refresh linked report text

Step Action

1 Select the 'Update automatic links at Open' checkbox.

2 Click on the OK button.
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