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Guide to the Trial Edition

Thank you for downloading the Trial Edition of Enterprise Architect and taking this time to become acquainted with
what the tool suite has to offer. We hope this short Guide will prove helpful in showing you how to get started and
understand some of the crucial modeling concepts underlying the tool.

Over the next 30 days you will have the opportunity to test-drive Enterprise Architect in all its different editions and find
out for yourself how it can help visualize, examine, verify and enhance your understanding of complex solution domains
across the Business, Software, Systems and Architecture areas.

This Guide is intended to supplement and support your initial contact with Enterprise Architect, and covers the more
important concepts and behaviors that are critical to getting the most out of the tool.

Here is an overview of the Guide and its intended purpose:

e Part 1 is a brief introduction to some important concepts concerning the tool, its repository based modeling and the
general function of the user interface

e  Part 2 will step you through starting up Enterprise Architect, finding the most common and necessary controls and
windows, and learning how to customize the user interface

e  Part 3 will walk through creating a new model, setting a Perspective and using pattern-based model fragments to fast
track model construction

e Part4is a collection of 'where to next' suggested links to other material that will enhance and enrich your Trial
experience, depending on your personal requirements

Please take the time to read through this document if you are a newcomer to Enterprise Architect, as it covers some of
the most fundamental concepts and tools you will be using during this trial period. Enterprise Architect is an incredibly
rich and extremely effective modeling and design tool that implements many technologies, frameworks and tools.
Walking through this Guide will help you find the right tools and right modeling language(s) for your needs.

Thanks once again for taking the time to try out Enterprise Architect. If you have any problems with installation or
getting started, please contact the Sparx Systems Trial support team, at trial-assist@sparxsystems.com.
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Part 1 - Concepts

More than a Drawing Tool

One of the most important concepts underlying Enterprise Architect is that it is far more than a simple drawing tool.
Unlike many of the simple drawing tools that sometimes present themselves as modeling tools, in Enterprise Architect all
models are stored in and built on very detailed and rich repositories. Some important results of this approach are:

e A diagram in Enterprise Architect is a view of some part of the underlying model

e Model elements can appear in multiple diagrams

o  Updating an element in one diagram will update it in all other diagrams it appears in

e Connections between elements are first-level model elements, not just visual representations

e  The Browser window (a UI window you will learn about later) is the doorway into the model itself

e The Diagram Toolbox has a palette of appropriate elements for the current diagram type and modeling language

e Elements from modeling languages have special properties, characteristics and linkage restrictions

Repository Based Modeling

A model Repository in Enterprise Architect can be implemented in a number of ways, depending on need. Regardless of
the type it is important to note that you must create or open a repository before you can do any modeling.

Some typical repository types include:
o A single file (.eap/.eapx/.fdb/.feap) which is typically used by a single developer
e A DBMS (Oracle, SQL Server, MySQL ...) based repository used by workgroups and larger teams

e Aninternal LAN based Sparx Cloud-Server repository (with .FDB or DBMS back end) for simplified deployment,
efficiency and other benefits

e A web facing Sparx Cloud-Server repository for globally distributed development, stakeholder access, optimization
and more

The kind of modeling you will do usually determines the kind of repository you will need. For the purposes of your Trial,
the single file approach will be the easiest to start with, unless you have access to some pre-existing larger repositories.
This guide will assume a single file as the simplest solution to get started with. But remember, your single file model can
always be scaled up later into a full DBMS or Cloud based repository if required!

Technologies, Perspectives & Frameworks

Another term you will come across a lot in learning about Enterprise Architect is "Technology'. In this special case, what
is meant is a collection of domain-related modeling elements that together form a unique modeling language. For
example, UML 2.5 is an open standard modeling language supported by Enterprise Architect; it is commonly referred to
as the 'UML Technology' or 'UML Perspective'.

Technologies
e A Technology is a collection of related modeling elements forming a modeling language

e A Technology in Enterprise Architect can also include scripts, shapes, document templates, patterns and other useful
artifacts

e Technologies can be turned on and off as required in a model repository
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Patterns
e  Patterns are collections of re-usable modeled content, for example a basic Use Case Model or simple Class Model
e  Patterns are used to kick start modeling and speed up the creation of common modeling solutions

e  Enterprise Architect includes a collection of over 1000 patterns with detailed explanations, in many different
modeling languages

Perspectives

e A Perspective is a constraint placed upon the user interface to only show a particular technology or set of
technologies

e A Perspective is used to reduce complexity and help you focus on your task

Frameworks

e A Framework is a collection of patterns, modeling languages and other material that together support a modeling
approach

e Frameworks can aggregate different modeling languages and often help determine model structure

As you work through your 30 day Trial, you will become very familiar with these terms and see how each contributes to
your modeling expressiveness and effectiveness.

Things you can do with a Model

Because an Enterprise Architect model is repository based with a rich set of connections, meta-information and other
material supporting the visual aspect, it is possible to take the model and create a wide range of new material from the
model itself. Some possibilities include:

e Documents in rich text or PDF format that expose underlying aspects of the model as well as the visual
representations

e  Code generation from Class models and from behavioral models
e Model interchange material in XMI and other formats so that your model can be read and acted on by other tools

e Simulations of behavioral models in a variety of formats such as BPSim, DMN, State Models, Activity Graphs and
more

e  Applying a range of mathematical simulation tools to Systems simulation and Dynamic simulation
e  SysML simulation with OpenModelica or MATLAB

e Conduct reviews of model content

e Make models accessible online with WebEA and ProCloud Server

Once you move your model into a DBMS or Cloud based repository you might also implement model security to control
who can modify the model and control locking on individual elements. In the Ultimate Edition you might also implement
Row Level Security and control which users can see what parts of the model.

For the ambitious it is also possible to access the underlying model using the automation (Active-X) interface of
Enterprise Architect using scripts and Plug-ins, or if accessing a Sparx Pro-Cloud Server, via the OSLC interface - a
RESTful API for exploring and modifying the model using standard web based calls.

Next Step

Having installed the Enterprise Architect Trial Edition, you can now start it up and explore it. Please refer to the next
section "Part 2.0 - First Contact'.
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Part 2 - First Contact

Starting Enterprise Architect

We hope you are now familiar with the concepts presented in Part 1 of this Guide. It's now time to start up Enterprise
Architect and find your way around the user interface. Along the way you will make a few choices to help tailor the Trial
Edition to your purpose. Note that any decisions you make are not final and can be changed by restarting Enterprise
Architect or using the various preference tools to customize your experience.

Assuming you have installed Enterprise Architect you can now click on the desktop icon (if available) or find the
shortcut in the Start Menu if preferred. Presuming everything is in place we are now on our way.

Some House-keeping

During the process of opening the Trial, a dialog will pop up.

Evaluation Version of Enterprise Architect

To help you determine the edition best suited to your needs, you can open
this trial product in any configuration.

Professional

Coprporate Compare Editions
Unified

Help

Thank you for trying Enterprise Architect.
You have 23 days left of your evaluaticn.

S
_—(j )
=€ '.I .

b
U=

Pricing | Continue Trial |

This dialog confirms that you have started using the Trial Edition for the 30-day trial period, and provides an option for
accessing the web site to review pricing and purchase options for the product. Also displayed is set of radio buttons from
which you select the edition of Enterprise Architect that you want to try out. Information about what each of the different
editions includes and does is available from the website by clicking on the Compare Editions button.

This dialog will display whenever you open the Trial Edition, so you can explore and compare different editions as many
times as necessary within your trial period.

As shown, the dialog also displays a count-down of the days left in your Trial period.

Click on the radio button for any edition (for the purposes of this topic, it does not matter which) and click on the
Continue Trial button; the main Enterprise Architect workspace displays.
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No current project - EA - 30 Day Trial

Design  Layout  Develop  Publish  Simulate  Specialize Configure @ Find G
- 0
AL ah Fullscreen Ei » . @ Home Page
QA CELG G & <n 5 WP & ®
& 4 Visual Style @ Libraries -
Search Portals Design Share Run Workspaces Preferences Discussions Review Team Help
o = o o o + Library + | © Register
Explore Desktop Collaborate Help
(X Find Package =
Browser R x » Start Page - % Properties o
e =- ) @Start Page x 1 g=-M
Project | Context Diagram Element Element

% <dick to open project... >
Name N

General

Open k Recent ~ ==
Stereotype
Personal Project Alias
COpen File Keywords
Create New Status

Version
Project
Team Repository =
Cloud Connection
- Notes - ox
Server Connection
Custom Data Source B 7fURB- =i %@
URL

Manage Projects...

All Perspectives

You can tailor this workspace to have a different layout, content and appearance to support your work tasks; we will
show you how in a later topic.

First Steps

Very (very) important!

When Enterprise Architect starts up there is no current repository selected. Before you can start modeling and creating
diagrams you will need to either open an existing model or create a new one. If this is your first time working with
Enterprise Architect and you don't have any existing models to use, you should create a new file based repository that
you can experiment and play in while you learn about modeling and using Enterprise Architect.

Let's create a new Repository file now.
Press Ctrl+N which is the hot key to create a new file based repository

-0r-

In the 'Open' section on the Enterprise Architect Start Page, click on the 'Create New' option
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Open

Personal Project
Cpen File
Create Mew E}

Team Repository
Cloud Connection
Server Connection
Custom Data Source
LRL

Manage Projects...

Select a filename and location for your repository

You will be prompted to select a file name and location for your new repository. Once you have chosen a name and
location, click on the OK button and Enterprise Architect will create a new empty model for you to begin working with.

What has changed?

Although not much will appear to have changed, you now have a working repository into which you can start adding
new elements and diagrams. The main thing to note is that the Browser window now has a new root element called
'Model' which is the starting point from which you will build your own individual repository.

[ » Model
Browser * I x
1 + 4 = - b

Project | Context Diagram Element

N

= Model

Where are we now?

By now we have started up the Trial Edition, created a new repository and loaded that repository into the Enterprise
Architect workspace. Next up we will create some new model elements and diagrams, before moving on to a brief
overview of the user interface.
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Part 3 - Building a Model

First Steps

Now that we have a new model created and loaded into the workspace (from Part 2), our new goal is to add some
content to the model.

There are many ways to add content, but for this first example we will take a convenient shortcut and add model content
using a model pattern. To do this you will:

e Select an appropriate Perspective

e Select a model pattern

e  Familiarize yourself with the pattern content

e Add the pattern content to your repository

e Find the new content in the Browser window and explore any new diagrams

So let's get started ...

Selecting a Perspective

As we mentioned earlier, a Perspective is a constraint placed on the workspace to only show a limited set of
Technologies. We can select a Perspective in a number of ways, but for this walk through we will use the drop menu in
the 'Model Builder' dialog. Our goal will be to create a simple Use Case model that we can later extend and customize.

To display the Model Builder dialog, from the ribbon, choose the option 'Start > Personal > Model Builder'. Next, click
onthe — icon at the top of the dialog's left-hand panel and select 'UML | All UML' as shown here.
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Model Builder

Parent: | Model

Requirements

&

Model Builder

[: Requirement Diagr

All

Active
Specialized

LML

Strategy

Analysis
Requirements

X Design

Business Modeling
5oftware Engineering
Systems Engineering
Simulation

Database Engineering
Enterprise Architecture
Information Exchange
Publishing
Construction

Custom Technologies

Settings...

All UML

Structural

Behavioral

Diagram Builder

Using a Pattern

Doing this will cause all of the UML Model Patterns (and there are quite a few!) to be displayed in the right hand panel.
Scroll down until you find the 'Use Case' section and select the 'Basic Use Case Model'. You should now be looking at
something resembling this image:
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AllURL
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A Use Case Diagrams
Starter Use Case Model
Basic Use Case Model
Basic Use Case Model with Include
Basic Use Case Model with Systern Actor
Basic Use Case Model with Extend
Basic Use Case Model with Generalization
Basic Use Case Model with Collaboration
Basic Use Case Model with Test Cases
Structured Use Case Model
Use Case Model with Activity Diagram
Use Case Model with State Machine Diagram

Sequence Diagrams
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System One or Entity One

Communicatian Disgrams — —
Activity Diagrams
State Machine Diagrams

v v W W W

Timing Diagrams

Create Model(z) Add To:  Firsk Steps &

Basic Use Case Model
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The Basic Use Case Madel pattern creates elements and a Use Case diagram that describes the goals
that user roles wish to achieve from the systemn. The Use Cases are all contained within the System

wactors
System Actor

e =

Combine with selected Package

Actor D

Note that the right hand side has some very useful information about the pattern, including an image to show what you
will get, a discussion of when you should use this pattern, additional references and other material. While some of the
terms and references might be unfamiliar at this stage, it would be a good idea to do a quick read through to become

aware of what we are adding to the new model.

When you have finished reading, click on the Create Model button located on the upper left side of the Model Builder
dialog. Enterprise Architect will now create new model elements, diagrams and Packages as required to make a copy of

this pattern for you to customize and play with.

Lets look at the Browser window

Ok, now that we have created our first model content, let's take a look at what we have added. To do this, take a look at

the Browser window.
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Browser v I X
FIE %5+ 4 =0 b

Project Context Diagram Resources

4 5l Model

4 [C] Basic Use Case Maodel
A B actors
§ Actord
¥ ActarB
$ ActorC
§ ActarD
% Systern Actor E
A B3 Use Cases
se Casze &
Jse Casze B
lJse Caze E
Use Caze D
se Caze C

DO0O000

48

——
—_

=] Systern One or Entity One
*2 Basic Use Case Madel

As you can see from this image, there is new content that has been added to the model. This includes a top level Package
and diagram, and some Actors and Use cases (within the 'Actors' and 'Use Cases' Packages). Let's take a look at this in
detail.

Double-click on the 'Basic Use Case Model' diagram link to show the graphical view of what we have. You should see
this diagram:
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System One or Entity One

wactors
System Actor E
Use Case A Use Case D
Actor A
Use CaseB Use CaseE
ActorB ActorD

Actor C

)
ojolo

In this diagram you can see several Actors and Use Cases. If you click on one of the Actors and then press Alt+G, or
right-click and choose 'Find | In Project Browser' from the context menu, the 'Actors' Package is expanded and the
element selected in the diagram will be selected in the Browser window, as shown here.

Browser - 3 % ¥ $2  Basic Use Case Model, Use Case Diagram

= © pac
EDT& + 4 Q =~ ’ @StartPage IE—|Specmcat|onManager %5 Basic Use Case Model X

Project Context Diagram Resources

4 (Ela Model
4[] Basic Use Case Model

4 01 betars
& Actors, Systern One ar Entity One
§ ActorB (R - -
e Y g W
ot I — | (e (.20

4 01 Use Cases P - —
2 Use Case &
© Use Case B
2 Use Case E i ~
2 UseCaseD \J /‘ T — . )
=3

Use Case C Y
=]

[

]
\_/
v ﬁ\\‘
>

Systern One or Entity One

o Actor B S I S— e Actor D
85 Basic Use Case Model

e
s

-
V,

S
\
/

SRR
s \\\\\\\ﬁm
=
]
4
o
"
o

Actor © % ~—
]

4

As you can see, there is an underlying model-level element in the Browser window that has a graphical representation in
a diagram. Note that you can place a single model element in as many diagrams as you like, and that changing the name
or notes or other element properties will be reflected immediately in all diagrams in which the element has been placed.

Working with Properties

Let's take a closer look at one of the elements and see what kind of information you can add to describe in detail what a

(c) Sparx Systems 2025 Page 14 of 45 Created with Enterprise Architect



Guide to the Trial Edition 2 September, 2025

particular element's purpose and behavior can be.

There are many property windows in Enterprise Architect, and for this walk-through we will look at a few of the most
important. There are many shortcuts and keystrokes to bring up different property sheets, but for now it is simplest to
access them from the main ribbon:

Start > All Windows > Properties > General > Properties

% ’7 '? ’W ’@‘ Eﬁ] A5 Full Screen ?A' ﬁ ﬁé’ é .ill ﬁ 1 My Kanban IE g[

A Visual Style 1 My Gantt
ective Design Share Run \'\l'ork'spa(e Pnzfe:en(es Rev'iew Distu_ssions Journal  Library M_ail Calendar HEID &
Help & Re:
., | Design
Explore Details Tools
ar 5 ot 8 Toobor
) B Focus B Properties B Diagram Layout
= B Inspector B Features B Diagram Filters
B search B bacument B Diagram Layers
Ise C B navigator B responsibilities B External Systems
- B Traceability B scenario Editor B Database Builder
At B Pan and Zoom B relationships B Gap Analysis Matrix or Entity One
Act B system Cutput B tatrix B Schema Compaoser
ne B Portals B surmmary —
ot B Specification Manager
Sys Use Case D
& Cag
Use
Use |
s |
Used  Explore the model and get access ta many of the important features in Enterprise Architect i —
Use Case C ——
Use Case B Use Case E

isic Use Case Model
Actor B

The Properties Window

Let's start with a look at the main Properties window. Select the 'Properties’ item from the 'Start > All Windows
>Properties > General > Properties' ribbon menu.
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Properties O x
=-# )
Element Tags
General -
Mame Actaor C
Type Actor
Stereotype
Alias
Keywords
Status Proposed
Version 1.0
Actor
Abstract
Final Specialization
Leaf
Wisibility Public
Project
Author sparisys
Package Actors
Phase 1.0
Complexity Easy
Created 3/06/2021 5:48:07 PM
Modified 3/06/2021 5:42:07 PM
Language <NOnex>
Filename
GuUID {949C67C2-6311-45a5-B20D-D3EB322F1...
WebEA
-
Properties | Collaborate Toolbox

As you select items on the diagram or in the Browser window, you can see the Properties window change to reflect the
appropriate settings and content for the current selection. If you click on an Actor, you will see the Actor's name and
many other settings. If you select a relationship between a Use Case and an Actor, you will see the Properties window
change to reflect this new type of thing (connector). If you click on blank space on the diagram, the diagram itself will
become the current selection and the appropriate properties will be available in the Properties window.

Note that when you select an element in a diagram and then switch to the same element in the Browser window, the
properties do not change as the two visual elements are actually representations of the same single element.

You can change some element properties by editing the selected item in the Properties window. Try changing an Actor's
name, Alias, Keywords or Status.

The Notes Window

A second very important window to become familiar with is the Notes window. This window is where you will type your
descriptive text about an object's purpose and any other relevant information necessary to fully and completely describe
that object. This is one of the most important windows because when it comes to other people reading and understanding
your model, the Notes and descriptive text are one of the major determinants of how useful and expressive your model
actually is.
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Select the 'Notes' item from the 'Start > All Windows > Design > Create > Notes' ribbon option.

(Shortcut key is Ctrl+3)

Try entering some notes for different elements.

The Responsibility Window

Another major window you should learn to use is the Responsibility window. This has several tabs, each of which

provides important modeling detail.

You can access the Responsibility window using the ribbon option: 'Start > All Windows > Properties > Responsibilities

> Responsibilities'.

On the window select from the tabs: 'Requirements' or 'Constraints' or 'Scenarios' or 'Files'.

(Shortcut key Ctrl+4)

Let's look at each in detail:

1. Firstly there is the 'Requirements' tab. This tab lets you add Requirements for an element that represent
responsibilities that particular element must satisfy. These are sometimes referred to as 'Internal Requirements' to
distinguish them from the more general System Requirements that can involve multiple elements.

» %8  Basic Use Case Model. Use Case Diagram 8§ - =

Case Model. Use Case Diagra Responsibilities
EModel Wizard #2Basic Use Case Model x |4 »

* Requirements  Constraints Scenarios  Files

Requirements Status Priority  External

The system shall implement a secur... | Proposed  Medium

System One or Entity One
&
\J = =
4 K 4
\ —— Usecasea ) [ usecase
FAN AN J \
Actor A e .
™~
™
N
3\ “ e M S
prommgy
N 2 /
%/ Z /
< (
| ———T—0 UseCaseB b [ usecase
VAN 7\ \
Aeors . L\
Cozmmormrrmmmiy ——
& —
( = =
e
I Y
 — ~{\ Use Case C
/N N /
Actor € ~———’
-
4 »

vidth: 105 Height: 70 All UML
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2. Secondly there is the 'Constraints' tab. This tab lets you enter restrictions and constraints on an element's behavior,
capability or structure. Many advanced behavioral models use the 'Constraints' tab to specify, in detail, how a system
will function.

® o Cromree Ryl Ter(Eread - .
» #S  BasicUse Case Model. Use Case Diagranm & * Responsibilities ~ # x Properties v A x
= - ST _
EModel Wizard |2Basic Use Case Model = |4 » . pequirements *Constraints Scenarios  Files =-4
=
Constraint
Constraint Type Status
Users must be defined in the syst.. Invariant Approved MName Users must be defined in the system
System One or Entity One before user logins are accepted
@ . —
e o I Y Va Type Invariant -
L ——— | useCasen | [ usecase Status Invariant
/NN \ J/ . Post-condition
Actor A N e
™ Pre-condition k
\\ Process
& \ A R OCE
T 7 o [
7—;] Use Case B | usecase
A Z % \
n’nnr\s é\‘ /ZO‘ . Notes b
i | == =
BIU&- S %@
@ —
\J Ve ~.
/ \
S | UseCaseC )
\ \
/N AN v 4
Actor C S —”
-
4 »
Vvidth: 105 x Height: 70 AllUML NUM

3. The third tab is the 'Scenarios' tab. This tab lets you either enter simple text or (when you click on the Edit button for
a Scenario) use the Structured Scenario editor to build detailed descriptions of how an element will behave in a
certain situation. Scenarios are most frequently used with Use Cases, but can be used with any element type where
appropriate, to explain some aspect of model behavior.

» UseCase : Use Case B ~ % Responsibilities ~ # x Properties v ax
rard #ZBasic Use Case Model [EIScenarios |4 * . pequirements * Consiraints * Scenarios Files =-#
Type: Scenario Scenario
Basic Path -~ || Basic Path T | Scenario Type Notes Struct...
L1 e 4 B-v- X @ : Basic Path Basic Path Edit. Scenario Basic Path
X N Type Basic Path
Step  Action Uses Results State
€ 1 Display "Add User” window
b2 I \
Notes v R x
Entry Points | Context References Constraints BIU&- =EE %@ 5
Step  Path Name Type Join
o Basic Path Basic Path

4. The final tab is the 'Files' tab, which simply lists any external files that have been associated with the element. You
can easily add files to the list, by right-clicking on it and selecting the 'Add New' option on the menu, and specifying
the file path. You open a file by selecting the "Launch File' option on the same menu. Files you might associate and
access here could include a Statement of Requirements spreadsheet or a User Story document.

There are many (many) more property windows in Enterprise Architect that are used to describe and edit element
specifications. We have seen a few of these now, and as you become more familiar with the tool, you should experiment
with others as the occasion arises.

Getting Help

In general, pressing F1 while the focus is in a Properties window will activate the Help for that window and you can read
about the window's purpose and general usage.
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Working with Diagrams

Diagrams are the visual representation of the model and provide one or more windows into the model's structure and
behavior. Learning to work with diagrams is an essential part of modeling with Enterprise Architect. We will look at
some of the most fundamental aspects of using diagrams to view and build models.

Basic Skills
Open a Diagram

If you want to view or work with an existing diagram, you can open it by double-clicking on its icon in the Browser
window. For this short introduction, you should locate the Basic Use Case Model diagram we created earlier and
double-click on its icon to open it. If it is already open it will be selected and become the focus window.

Selecting and moving elements

Now that we have our diagram open, try clicking on elements to select them. Once selected you can click and drag to
move, right-click to select actions from a context menu, observe or work with an element's properties in the various
property windows and/or modify an element's appearance and other visual characteristics. Note that you can also click on
connecting relationships between elements and likewise edit and view properties, appearance and positioning.

The Layout Ribbon

The third Ribbon category is 'Layout' and it is the main ribbon category devoted to manipulating the appearance of
diagrams. There are commands to change diagram themes, set element appearance, align and format elements, layout
diagrams and filter diagram content. Many of these tools are described in detail in the Help, so take the time to read up
on the tools and actions available so you can make the most of your diagrams.

Basic Editing
Adding a Scenario diagram to a Use Case

Now that we have some familiarity with diagrams, let's add a new one and build up a simple Sequence diagram
indicating the flow of actions and responses between an Actor and a Use Case. First we will need to select a Use Case in
the Browser window that will contain the new Sequence diagram (or Interaction).

Create the Diagram

To begin with, click on 'Use Case A' in the Browser window to select it. Now, right-click on it to display a context menu
and select 'Add | Interaction | with Sequence Diagram'. Give the new Interaction a name and click on the OK button.

You should now have something similar to this image in your Browser window.
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Note that there is a new Interaction container with an empty Sequence diagram. Double-click on the Sequence diagram
icon to make it the new default workspace. Now you will have a blank diagram workspace. Click on the double-arrows
icon at the left end of the diagram title bar to open the Diagram Toolbox. The Toolbox changes to show elements that
are appropriate to the current diagram. In this case it shows elements commonly used in Sequence diagrams. Firstly
though, we will make use of our model and place a link to the relevant Actor onto our diagram.

In our original diagram, Use Case A had a relationship to Actor A, so let's find Actor A in the Browser window and drag
and drop it onto the new diagram.

In the dialog that pops up, select 'Link' as the type of placement required and click on the OK button.
A new visual representation of Actor A is now created and placed onto the Sequence diagram as a Lifeline.

Next, we need to add a Boundary element to represent the system being modeled and how it will interact with our Actor.
From the toolbox, click on the Boundary icon and then click to the right of the Actor lifeline. Use the Properties window
to rename the Boundary element as 'System'. You should now have a diagram that resembles this image:
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OK - we now have an Actor and a System and we want to represent the flow of Action and Response between the two
entities. We can model this using messages between the two.

Click back on the Actor Lifeline and look for the Quicklink button - this is a small 'up arrow' located just at the right
edge of the selected element, and is only visible when the element is selected.
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Now, click-and-hold on the Quicklink button, then drag across to the System Lifeline and release. This creates a new
message in our model, between Actor A and System. Select the new message on the diagram and note that the Properties
window updates to show the properties of the new connector, allowing you to edit the details. After entering a few
details for the message and clicking the Save button, your diagram workspace should resemble this image:
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A return message can be created in similar fashion, by clicking on System, then dragging its Quicklink button across to
the Actor. Select the new message on the diagram and fill in the details in the Connector Properties window. In the
'Control Flow Type' section of the Properties window, select the option 'Is Return'. Your diagram should now display the

return message, similar to this image:
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Building the Model

1. Basic Skills

The Design Ribbon

The Design ribbon groups together commands that are used for creating and modifying model items, such as elements,
diagrams and Packages.

It provides access to a number of windows, such as the Properties window, Features window and Responsibility window,
as well as commands for viewing Package content and diagram content as lists or Gantt charts.

Take a few moments now to explore the different menus and sub-menus presented by the Design ribbon.

We will now use the Design ribbon to perform some basic modeling tasks, such as creating a new Package and creating a
new diagram within the Package, before creating some new elements and connectors on the diagram. In this example,
we will create a simple Class model.

Create a Package

We will create a new Package under the Model Root node, so click on this node in the 'Project' tab of the Browser
window then, from the Design ribbon 'Package' panel, choose 'Add Package'. The 'Model Builder' dialog will appear,
with the 'Diagram Builder' tab page displayed. Here, you can enter a name for your new Package and you can choose to
create a Package only, create a Package with a diagram, or choose a model pattern to insert into the new Package.

For this walk-through, choose 'Package Only', enter a name for the Package, such as 'My Class Model', then click on the
OK button. You should see the new Package in the 'Project' tab of the Browser window, as a child of the Model Root
node.

Create a Diagram
Now, we will create a Class diagram within the new Package.

Click on the Package in the 'Project’ tab of the Browser window then, from the Design ribbon 'Diagram’ panel, choose
'Add Diagram'. The 'Model Builder' dialog will appear, with the 'Diagram Builder' tab page displayed.

The default name for a diagram is the same name as its parent Package; leave this as it is.
In the 'Type' section, select from 'UML Structural', and choose the diagram type 'Class'. Click on the OK button.

The new Class diagram will appear in the Project’ tab of the Browser window and it will open in the main diagram
workspace.

Diagram Toolbox

The Diagram Toolbox pages provide a palette of elements and connectors that can be selected and dropped onto the
currently open diagram. Doing so creates a new element or connector of the selected type within your model and
displays it on the diagram where you dropped it. The Toolbox pages display a set of elements and connectors that are
commonly used with the current diagram type; this set changes as you open diagrams of different types.

Open the Diagram Toolbox now by clicking the 'Toolbox' icon in the 'Diagram' panel of the Design ribbon. The Toolbox
is displayed on the left side of the diagram workspace.

This image shows the new, empty Class diagram and, beside it, the Diagram Toolbox pages showing the elements and
connectors appropriate for working with Class diagrams.
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Add elements to the diagram
Let's now use the Diagram Toolbox to add some elements to our Class diagram.

Select the Class element in the Toolbox, then click on the empty diagram. A new Class named 'Class1' is created in your
model and placed onto the open diagram. The Class name 'Class1' is applied by default. You can type a new name into
the Class on the diagram, or you can change the name later using the Properties window. Create a second Class on the
diagram by again selecting 'Class' in the Toolbox and dragging it onto the diagram.

Your workspace should now resemble this image:
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To create a relationship between two elements on a diagram, simply select a relationship type in the Diagram Toolbox,
then drag a line from one element on the diagram to another. Most relationships are directional, so dragging a link from
Classl to Class2 is different to dragging a link from Class2 to Class].

Click on the Generalize relationship in the Diagram Toolbox then, on the diagram, drag a line from Class2 to Classl1.

The relationship that is created indicates that Class] is a generalization of Class2.
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Add Elements Using Quick Linker

We briefly looked at the Quick Linker in Working with Diagrams, where we created links between two elements in the
form of Interaction messages. Now we are going to use the Quick Linker to create a new element at the same time as
creating a new relationship from an existing element.

In the diagram "My Class Model', click on Class1 to select it. The Quick Linker arrow should be visible beside the
top-right corner of Class1. Click and drag the Quick Linker arrow to the right, releasing the mouse button in empty space
on the diagram. This action displays a pop-up menu that prompts you to choose a relationship type, then an element type.
From the menu, choose 'Realization | Interface'.
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The resulting connector and element are shown here:

Interface
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2. Using Perspectives and Model Patterns

Enterprise Architect offers a wide range of different Perspectives that cater to the many different kinds of modeling you
can perform. As mentioned earlier, a Perspective is a constraint placed upon the user interface to only show a particular
technology or set of technologies. It is used to reduce complexity and help you focus on your task.

Add a Requirements Model

We will now build a simple Requirements Model in our project. Firstly, let's select one of the Requirements
Perspectives. From the 'Perspectives' menu, choose 'Requirements | Requirements'.
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After we select the Requirements Perspective, the Model Builder dialog is displayed, offering just a selection of basic

Requirement model patterns. Firstly, we should choose where in the model this new content will be added. Click on the
folder icon beside the 'Parent:' field at the top of the Model Builder dialog, then choose the Model root node and click on
the OK button. Now, let's select the pattern "Two Level Requirement Hierarchy' and click on the Create Model(s) button.
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The selected model pattern is added to our model under the Model root node.
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Double-click on the diagram link in the 'Project' tab of the Browser window to open the diagram in the main diagram
workspace. You can then select elements on the diagram (or in the 'Project' tab) and use the Properties window to tailor
them to your own use, by renaming them, entering descriptions in the Notes window or setting other properties as

required.

Add a Class Model

We will now add a simple Class Model to our project, following a procedure similar to the one we have just used.

From the Perspectives menu, choose '"UML | Structural'.
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The 'Model Builder' dialog is displayed, showing the Structural Perspective. Scroll through the list to find the Class
diagrams, then click on 'Basic Class Diagram with Operations'. Click the folder icon beside the 'Add To:' field and
choose the Model Root node as the location in which to add the new model content. Finally, click on the Create Model
button to add the new model content to your project.
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The selected model pattern is added to your project; the Packages, diagram and elements are shown in the 'Project' tab of
the Browser window.
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Double-click on the diagram link 'Basic Class Diagram with Operation' in the Browser window. This opens the diagram
in the main workspace. Now, we will use the Features window to view the operations of Class A.

From the 'Explore' panel of the Start ribbon, choose the menu item 'Properties > Features'. The Features window is
displayed; select the 'Operations' tab of this window.
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Now click on Class A in the diagram (or in the 'Project’ tab of the Browser window). You will notice that as soon as
Class A is selected, the details of its operations are displayed in the Features window. Here you can modify an existing
operation, by changing its name, its return type or even its parameter list. When you select an operation in this list, the
Properties window switches to Operation Properties, and displays details of the selected operation.

You can also use the Features window to define new operations, by simply typing a name into the list where it says "New

Operation...".

This image shows the Features window when Class A is selected on the diagram and the Operation Properties window
when Operation B is selected in the Features window.
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We have walked you through some simple modeling operations to give you a basic understanding of how you might use
Perspectives and Model Patterns to create model structures that you can use as a starting point for creating your own

models.

We have also demonstrated using the 'Project’ tab of the Browser window to navigate through the model, using the
Diagram Toolbox to add new content to your model via the diagram and using various Properties windows to inspect and

modify the properties of various model elements.
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Part 4 - Where to Now?

Having created a model in a repository, you might now like to see how your work can be further supported by tailoring
the Enterprise Architect work area to your requirements. You can also re-visit the tools you have used, and learn a little
more about them and about other tools and facilities that are equally valuable in helping you develop and manage your

models.

Customize the Workspace

When you first open Enterprise Architect, you see the default layout of the user interface. You can change the layout and
appearance of the interface in many, many ways, hiding windows you don't need, organizing the dialogs you do need in
the most convenient configuration, changing the display colors and texts, and much more, to suit your personal
preference, the area of work you are responsible for and the tasks you perform.

The sections here show you where you can perform this customization.

Change Visual Style

The illustrations of the user interface you have seen in the Guide have a particular color and appearance - or visual style.
You can change this style to one of several alternatives, using the 'Application Look' dialog (select the 'Start >
Appearance > Visual Style' ribbon option).

Default Mote Zoom:

Window Styles

M Show Menu Icons

Main View Tabs use Caption style
M Main View Tabs at bottom (restart)
Property Sheets wse

B Use Property List for Elements

ote Paragraph Spacing
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The first three fields on the dialog have the greatest visual impact. Try experimenting with changing the values; you can
click on the Apply button and see the effect without having to close the dialog. Note that for some of the permutations
you do not need to have values in all three fields.

Set Some Major Preferences

Preferences are aspects of the system that you personalize so that every project you open in Enterprise Architect, on your
workstation and under your user ID, looks and behaves in the same way - the way you want them to! Each user might see
the same project differently, according to their own preferences.

You start by displaying the 'Preferences' dialog (select the 'Start > Appearance > Preferences > Preferences' ribbon
option).
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4 2 Diagram author  [oovid Stecie Clipboard Format:
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Project Loading Strategy: Load on Demand (Lazy Load) -

Server connections use the option set when creating the connection

As you can see there are many pages of options you can set, although not all options will be important to you. Click on
the page names on the left of the dialog to review the options that are available. If you want an explanation of a setting,
click on the Help button to display a description of every setting on the page.

The most visible preferences are the object colors on diagrams. Open a diagram and then change the settings on the
'Diagram > Standard Colors' page of the dialog. Every setting has an option to revert to the default color, so you can try
all sorts of combinations without losing the standard settings.

Customize Ribbon Categories

The ribbons at the top of the work area together provide access to almost every tool and facility of Enterprise Architect,
but as you are unlikely to use every tool and facility you might consider tailoring the ribbons to exclude things you do
not need. You first display the "My Ribbon Sets' tab of the "Workspace Layout' dialog (select the 'Start > All Windows >
Workspace > Workspace Tools > My Ribbon Sets' option).
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Workspace Layout

LTy ST L R L E T My Ribbon Sets

Create Ribbon Set: Configure Ribbons:

Click on the New button and type in a name for your custom ribbon display. You will see that all the ribbons are now
listed in the 'Configure Ribbons' panel, and if you expand a ribbon name the sections of that ribbon are also shown. For
every ribbon and section that you don't need, you clear the selected checkbox so that the ribbon or section will be
excluded from the ribbon bar.

Click on the Apply button to update the ribbon display. If you want to reinstate the default full ribbon set, click on the
background of the 'Create Ribbon Set' panel and click on the Reset button.

Putting Things in their Place

When you open Enterprise Architect for the first time, the various windows are in position around the display. These
windows - and others that you open - do not have to stay in those positions, you can simply click on the window name
and drag the window to a more convenient spot on the display.

Alternatively, you can dock a window exactly where you put it, so it stays there, open, across many work sessions.

As you move a window, a 'compass' icon displays in the center of the screen and a 'compass point' icon displays on each
edge.

When you move the window over a compass point, an area of the display turns blue. This is the area that the window will
occupy when you drop and dock it. You can then adjust the window borders to suit.

If there is another window in the docking area another compass displays there, with a square in the middle. The compass
points dock the dragged window above, below, or to the side of the other current window, whilst the square makes it a
tab of the same frame as that window.

Using the Workspace facilities

Docking a window puts one window in position at a time, but many of the windows can be used in combination, so to
save you from working out, building and positioning those combinations, the system provides them for you and gives
you the tools to quickly apply them! These tools form the Workspace facility (select the 'Start > All Windows >
Workspace > Workspace Tools > Workspaces' ribbon option).
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Before you try out some layouts, clear the 'Close on Apply' checkbox, so that you can try different layouts without

having to re-open the dialog. Select a layout (such as 'Debug') and click on the Apply button.

You can set a system-defined layout and then move individual windows, or otherwise create a layout that better suits
you. Having done that, you can save it as a personal layout by selecting the 'Start > All Windows > Workspace >
Workspace Tools > Save Workspace' ribbon option, which prompts you to give your layout a name. If you use some
other layout you can come back to yours by selecting it on the 'My Workspaces' tab of the 'Workspace Layout' dialog.
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Going Back to Work

You do a lot of work using windows such as the Diagram View (with several diagrams as tabs, perhaps), Relationship
Matrix and Model Search.

Having reached the end of a work session, you might want to start your next work session by picking up where you left
off. You can capture your current work status using the Working Sets window (select the 'Start > All Windows >
Workspace > Manage Working Sets' ribbon option).
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You right-click on the central panel of the 'Manage Working Sets' dialog and select the 'Store Main Tab View History'
option, which captures the views that you have open as you close down your work station. If you also select the 'Apply
When Model Opens' option, the system will automatically open those views when you open your model in the next work
session. Alternatively, you could use the 'Open Working Set' option when you are ready to resume that work, if you need
to do something else first.

Quick Reference

Ribbons in Brief

Ribbons, shown at the top of the work area, provide access to almost every tool and facility in Enterprise Architect. Each
ribbon supports a domain of work - such as designing the model components and structure - and is divided into segments
to group the tools and facilities according to the structure or function the tools support.

E‘ﬁ‘ ﬁ ﬁ E EE A g’a Full Screen a B & El @ Vé & My Kanban E [ Home Page

A Visual Style 1 My Gantt @ Libraries
Design Share Run Workspaces Perspectives Preferences Discussions Review Team Mail Calendar Journal Help ® Regi
- - - - egister

- h Library -
Desktop Collaborate Help

This example is the Start ribbon, which provides access to tools for organizing your work and your work area. In
particular, look at the options in the 'Application' panel, which provides the tools for seeing what is in your model and
where particular objects are. These tools include:

e  Browsers - such as the 'Project' tab of the Browser window

e Properties displays - such as the Properties window itself and windows showing Notes, related Documents, Features
and Constraints

e The Trace facilities for examining and tracing relationships between pairs of elements and sequences of elements

(c) Sparx Systems 2025 Page 39 of 45 Created with Enterprise Architect



Guide to the Trial Edition 2 September, 2025

Portals Window

The Portals Window displays one of eleven Portals, and provides the facility for switching to a different Portal. The
Portals identify tasks in particular areas of work, and provide links to the window or dialog for performing each task. The
Guidebook and Learning Portals provide links to online information that describes a feature of Enterprise Architect and
how to work with it. You display the Portals window by selecting the 'Explore > Portals' option at the left end of the
ribbon bar.

Portals
= Execute -

Execution Analyzer

Edit Analyzer Scripts

Open Source File

Explore
Merge
{7_-) Recent Places
Build
'D\ Recent Activity
Deploy
E Working Sets
Run
Eg Model Views
; Test
Design
H:l Workspaces Simulator
@ Perspectives Simulation
== Windows Debugger
@ Exend Debug
) Brecute Record
Help
Profile
E cuidebook
. Code
ﬂ Learning
Toolbars Test
Show Toolbar ¥ ¥SLT
Perspectives

Perspectives refine the model development facilities in Enterprise Architect to support a particular technology or domain,
The most visible effects of setting a Perspective are that the contents of the Diagram Toolbox are restricted to those
element and connector sets used in the domain, and the model Patterns are tailored to generate diagram and/or model
structures of exactly the type for modeling in your selected area.

You can list and select the Perspectives from the Perspective' drop-down list in the top right of the display.
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Collaboration

If you are working as a member of a team, you will need to contact colleagues with anything from a quick question to a
list of formal review comments. Whichever type of message you want to send, Enterprise Architect has a facility to
create and deliver that message.

You can access the facilities through the 'Start > Collaborate' ribbon segment, selecting the 'Discussions', 'Review' or
'Mail' options. The Discussions option gives you a Chat facility too.

EC% E‘ & El @ w 1 My Kanban

59 My Gantt
Discussions Review Team Mail Calendar |ournal

i - Library
Collaborate

(Note that the Mail and Chat facilities operate on user IDs, which cannot be set in the Trial Edition. The windows
display, but you cannot send a message.)

Shortcut Keys
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Many of the facilities and operations in Enterprise Architect can be selected by pressing keyboard keys as well as by
selecting ribbon or menu options.

For a list of the keyboard shortcuts you can use, access the Learning Portal (select the 'Explore > Portals > Learning'
ribbon option) and look at the Keyboard Shortcuts and Diagram Shortcuts topics under the 'Quick Reference' heading.

Resources You Can Use

Help

At any time, if you want information on the purpose of a screen or how to complete it, you can select one of these
options to display the Help topic describing that screen:

e PressFl1

e  (Click on the icon in the screen header, or
e  Click on the Help button at the bottom of the screen
Or you can access the Help by selecting the 'Start > Help > Help > Open Help System' ribbon option.

Each Help topic displays as a web page. You can click on the list of topics on the left of the page to explore related
and/or more detailed topics, or click on a point in the 'breadcrumb’ trail above the topic to access more conceptual topics
or Help on a different subject area.

SrrPARX

Index User Interface The Enterprise Architect Ribbons Start Ribbon
= Explore Panel The 'Start' ribbon provides a range of facilities for exploring, navigating and viewing the
_ navigate and search for items, to view the important events, messages, discussions anc
=l view Panel view and change your workspace settings, including styles and preferences. This ribbon
B collaborate Panel registering licence keys and checking for updates.
El Help Panel

The Example Model (EAExample)

The Example model is a collection of model fragments, brought together into a single model, to illustrate the many
different ways to use Enterprise Architect across a broad range of model domains. The Example model does not
represent a model of a working system, instead it provides samples from many disparate systems.

The example model is provided as part of the Enterprise Architect product installation and you can open it from the
'Help' panel of the 'Start' ribbon, selecting 'Help | Open the Example Model'.

When you load the EAExample model, its default diagram 'Getting Started' is loaded. The 'Getting Started' diagram
contains a series of links to other diagrams that relate to different modeling domains, such as Business Modeling or
Systems Modeling, as well as some of the tasks you might want to perform in Enterprise Architect, such as Project
Management and Publishing. Double-clicking on a diagram link will open the diagram. The next level of diagrams
typically contain a description and some instructions on how to access related features in Enterprise Architect, and
further links to model examples for that area of interest.
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As an example, try double-clicking on 'Requirements Model' in the 'Getting Started' diagram, then '"Tracing
Requirements' on the next diagram. and finally 'Traceability Diagrams' on the diagram with the heading 'Traceability'.
This will bring you to an example of a Traceability Diagram.
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Traceability Diagram

A number of tools are available for updating diagrams to show
traceability:

- 0n a diagram, right-click an element and choose: 'Insert Related
Elements' to automatically add elements that are linked to the selected

The command 'Insert Related Elements' can be accessed either from the
Design ribbon by choosing the option 'Element > Insert Related', or by
right-clicking the element of interest on your diagram and choosing
'Insert Related Elements' from the context menu.

element

- On the Relationships window, use the context menu option 'Place
Related Element in Diagram' to add elements to the diagram thatare
directly linked to the selected element

- On the Traceability Window, add elements that are indirectly linked

Insert Related
Elements
-image

G

This diagram was created using the 'Insert Related Elements' command.
The element 'REQD11 - Manage User Accounts' was manually placed on
the diagram, then all other elements were added automatically using the
'Insert Related Elements’ command.
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You will find a description of what is on the Traceability Diagram, why it is useful and how to create one for yourself.
You can right-click on the diagram itself - or its elements - and 'Find' them in the Browser window to see where the
elements come from and how they relate to each other.

Webinars and Video Resources

Sparx Systems has published a number of web seminars, tutorials and video demonstrations of the use of Enterprise
Architect tools and facilities, on our website. These recordings are often quite short and all are easy to watch.

You can access the recordings through the Learning Portal (select the 'Explore > Portals > Learning' ribbon option) by
clicking on the 'Resources' option under the 'About' heading. This displays the 'Resources & Tutorials' web page, which
provides three separate icons for the webinars, demonstration videos and tutorials.

Guidebooks

For a more in-depth discussion of Enterprise Architect's support for an area of work, you can read one of the many PDF
Guidebooks held in the Sparx Systems online library. You can access these through the Guidebook Portal.

You can either read a guidebook online or print it.
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